Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RME: Internal error when retrieving Startup Config (Debug attached)

Hi,

We have around 4 devices that just started receiving this error

++++++++++++++++++++++

CM0057 PRIMARY STARTUP Config fetch SUCCESS, archival failed for sfsl-access-sw05 Cause: Internal error Action: Verify that archive exists for device. CM0061 PRIMARY RUNNING Config fetch SUCCESS for sfsl-access-sw05, no change in configuration. CM0060 VLAN RUNNING Config fetch SUCCESS for sfsl-access-sw05, version number 71 archived.

++++++++++++++++++++++++++++++

I set the Archive Management logging to debug and dcmaservice.log is attached.

This contains the Sync job for one device only called "sfsl-access-sw05".

Is there a way to fix this without having to delete and re-add the device ?

RME version is 4.0.5.

Thanks,

Naman

8 REPLIES
Cisco Employee

Re: RME: Internal error when retrieving Startup Config (Debug at

Are all of these devices the same device type? Can you enable debugs for config archive to get some more details?

New Member

Re: RME: Internal error when retrieving Startup Config (Debug at

I don't see any debug for "Config Archive" ? I have "Config CLI, Config Editor,Config Job,Config JobManager".

3 are 3560s and 1 is a 2960. However we have around 200 other 3560, which don't have any problem.

Thanks,

Naman

Cisco Employee

Re: RME: Internal error when retrieving Startup Config (Debug at

The most important debug for a config archive problem is ArchiveMgmt Service debugging. The most important log is dcmaservice.log.

New Member

Re: RME: Internal error when retrieving Startup Config (Debug at

That is already attached to the post. The dcmaservice.log attached was captured with ArchiveMgmt Level set to debugging.

This is one of the messages from the log file

+++++++++++++++++++++++++++++++

,DEBUG,[Thread-22335],com.cisco.nm.rmeng.genericarchive.ArchiveUtils,getBranchLocation,333,D:\PROGRA~1\CSCOpx\files\rme\dcma\devfiles/3327/PRIMARY/STARTUP

[ Wed Sep 26 12:16:20 CDT 2007 ],ERROR,[Thread-22335],com.cisco.nm.rmeng.dcma.configmanager.DeviceArchiveManager,deleteStartupConfig,1817,CM0003: Version $1 does not exist in archive $2 Cause: Version may have been deleted

[ Wed Sep 26 12:16:20 CDT 2007 ],ERROR,[Thread-22335],com.cisco.nm.rmeng.dcma.configmanager.ConfigManager,updateArchiveForDevice,1419,Error archiving config for sfsl-access-sw05

[ Wed Sep 26 12:16:20 CDT 2007 ],DEBUG,[Thread-22335],com.cisco.nm.rmeng.dcma.configmanager.ConfigManager,updateArchiveForDevice,1421,Exception..com.cisco.nm.rmeng.dcma.configmanager.ArchiveManagerException

at com.cisco.nm.rmeng.dcma.configmanager.DeviceArchiveManager.deleteStartupConfig(DeviceArchiveManager.java:1819)

at com.cisco.nm.rmeng.dcma.configmanager.DeviceArchiveManager.archiveNewVersionIfNeeded(DeviceArchiveManager.java:1108)

at com.cisco.nm.rmeng.dcma.configmanager.ConfigManager.updateArchiveForDevice(ConfigManager.java:1331)

at com.cisco.nm.rmeng.dcma.configmanager.ConfigManager.performCollection(ConfigManager.java:3057)

at com.cisco.nm.rmeng.dcma.configmanager.CfgUpdateThread.run(CfgUpdateThread.java:29)

++++++++++++++++++++++++++++++++

I then checked the directory "D:\Program %NMSROOT%\files\rme\dcma\devfiles\3327\PRIMARY\STARTUP" and there is nothing in there ?

Thanks,

Naman

Cisco Employee

Re: RME: Internal error when retrieving Startup Config (Debug at

Try removing the Device from RME, then re-add it and try it again.

HTH,

-J

Cisco Employee

Re: RME: Internal error when retrieving Startup Config (Debug at

Looks like a case of the database being out of sync with the file system. Perhaps those revisions were manually deleted. The solution is to remove the 3327 directory, then delete the device from RME and re-add it.

New Member

Re: RME: Internal error when retrieving Startup Config (Debug at

Since I am the only one who manages this system, so I can guarantee you that I never deleted any directory\version.

I wanted to avoid Add\Re-Add but guess there is no other option..!

Thanks,

Naman

Cisco Employee

Re: RME: Internal error when retrieving Startup Config (Debug at

I can't think of any other way a file would be DELETED (0 bytes, maybe, but not physically removed). There may be a purge issue, but I haven't seen anything that can be reproduced.

Yes, once the database and the file system get out of sync, your only choice is to remove and re-add (but you only need to do this for RME). However, in this case, since you have no configs saved for this device, you won't lose much.

180
Views
15
Helpful
8
Replies