Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

rme inventory

rme inventory pending for long time

8 REPLIES
Cisco Employee

Re: rme inventory

What version of RME? On what platform? Where are you seeing the pending status exactly?

Re: rme inventory

Dear Joe,

I am working for the same LMS problem. Actually the problem is:

Inventory polling is successfull for all the devices except for one.( so the polling job saying failed) after the possing it automatically goes for inventory collection. But the inventory collection job stays pending for long time(hours) after that it says "Not Attempted"

from one of your threads you had told to increase the snmp timeout to atleast 10 secs so I did the same. The inventory collecion job is still running I can confirm you about the job status tomorrow.

The RME is 4.2 on LMS 3.1(upgraded from 3.0)

AS last time I had some issues with Archiving(Archive status was showing wrong figures) I had to reinitiate RME database.After reinitialization it is ok now . But the inventory collection problem was same as before.

Thanks

Sachi

Cisco Employee

Re: rme inventory

Enable ICServer debugging under RME > Admin > System Preferences > Application Loglevel Settings, and run a new Inventory Collection for this device. Post the IC_Server.log, show ver, and show run from this device.

Re: rme inventory

Actually this device is failed in polling & its ok as this device is down now( due to this failed device the polling job failing).

But the collection is not happening for all the devices.

I will enable debugging tomorrow & will post the same.

Re: rme inventory

Pls find the IC-Server.log . As you know inventory collection job says "Not Attempted" after long time it stays in pending for all the devices.

Cisco Employee

Re: rme inventory

It appears ICServer has locked up. If you want to troubleshoot this, I recommend you open a TAC service request so a full thread dump can be obtained from the ICServer process.

However, if you just need to get it working, restarting ICServer might help. To do that, run:

pdterm ICServer

pdexec ICServer

Inventory collection may start to work again after that.

Re: rme inventory

Hi Joe,

Even after executing the commands still the inventory collection job is failing for most of the devices. Only few showing as "successfull" some are saying "successfull with no changes" & all others are saying "Not Attempted"

pdterm ICServer

pdexec ICServer

excuted both the commands.

Cisco Employee

Re: rme inventory

One device must still be locking up ICServer. When this happens, all subsequent devices will fail as not being attempted. As I said before, I suggest you open a TAC service request so a thread analysis can be done on ICServer.

247
Views
5
Helpful
8
Replies