Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

RME-Software upgrade fails for 3750


RME 4.1.1

The software distribution job is always failing for this cisco 3750 switch.

I tried to fetch a small text file on the switch from cw server to verify UDP-69 connectivity. TFTP worked fine for the test file.

C:\PROGRA~1\CSCOpx\files\rme\jobs\swim\job_ID folder is attached with.

SNMP credentials are fine and cw also has write permissions in switch snmp config.

I noticed that the image we were trying to push was 10.4 MB while the available space on switch flash was 8 MB, but shouldn't this image go to RAM first and CW should take care of erasing the old image to create space for the new image!!

New Member

Re: RME-Software upgrade fails for 3750

attaching logs

Cisco Employee

Re: RME-Software upgrade fails for 3750

It looks like you may be seeing a known issue with SSH. Can you try with telnet to see if it works?

As for the size, RME thinks this image is 7755065 bytes, so it should fit in flash just fine.

New Member

Re: RME-Software upgrade fails for 3750

The debugs mentioned that SSH succeeded and cw was able to fetch the config

But how can RME decide on which image to delete to create space.

As in this case, the image that cw is trying to push is 10.4 and the existing free space is 7-8 MB.

Even if the image copy succeeded and device wanted a reload, how does it help!! the device might still re-boot with an older image.

Do you still suggest to try Telnet instead of SSH!

Cisco Employee

Re: RME-Software upgrade fails for 3750

If RME determines that there is not enough free space, it will delete what is on flash, copy in the new image, then copy back all preserved files (e.g. the config, vlan.dat, etc.).

It's strange that RME thinks this image is only ~ 7 MB, though. It makes me think that perhaps the image was downloaded incorrectly. You should try re-adding this image to your SWIM repository after a new download.

Yes, after reloading the image, try a transfer using telnet.

CreatePlease to create content