Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Route-map backup

Hello,

I want to set a backup for route-map.

I have a tunnel set on my router and route map that set all HTTP traffic throught tunnel.

interface Ethernet0

description LAN

ip address 10.0.0.1 255.255.255.192

...

ip policy route-map redir

!

route-map redir permit 100

match ip address 120

set interface tunnel 21

!

access-list 120 permit tcp 10.0.0.0 0.0.0.255 any eq 80

access-list 120 deny ip any any

!

interface Tunnel21

ip address 172.16.21.2 255.255.255.0

...

tunnel source X

tunnel destination X

tunnel mode ipip

!

ip route 0.0.0.0 0.0.0.0 Dialer1

tunnel go across Dialer1.

When dialer1 fails i want that the HTTP traffic go across different interface but i don't know how to do this.

Some ideas?

thanks.

3 REPLIES

Re: Route-map backup

Hi

AFAIK in addition to the tunnel interface set under route map,you can also define one more interface in addition to that.

route-map redir permit 100

match ip address 120

set interface tunnel 21 tunnel 20

You can also verify the functionality of the route map commands once you configure the route maps and make the tunnel interface down accordingly..

dont shut the tunnel 21 just make the destination ip unreachable so that your tunnel will go down.

Also ensure you have keepalive set on both the tunnel interfaces so that it will go down once it fails to have the reachability to the destination ip.

regds

Re: Route-map backup

Remember:

U can always set a backup interface/HOP in route-map, with the cmd "set ip next-hop", provided the IP or interface is only at 1 hop distance.

Bronze

Re: Route-map backup

hi

route-map evaluation is the same like for ACL it consists of a scan, in a predetermined order,the scan is aborted once the first statement match is found and an action associated with the statement match is performed. so you can use i.e

route-map redir permit 100

match ip address 120

set interface tunnel 21

route-map redir permit 110 <----the next statement

match ip address 120

set interface tunnel xx <---- the other tunnel

HTH

do rate if it does help

302
Views
11
Helpful
3
Replies