Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Route-map based ip policy not working

Hi,

I have one 1841 routes with 2 internet providers (ADSL routers connected to 1841 FE interfaces).

One of those is primary and other serves as backup connection. Default route is 192.168.1.1 and secondary is 192.168.2.1

I want to route all traffic from specific local hosts to secondary ISP, while maintaining all the rest through primary ISP. Used route-map based ip policy.

My problem is that policy seems to work OK for all traffic except POP3 and some IM applications.

Any clue about where may be the problem? My configuration follows:

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.0

ip nat outside

ip virtual-reassembly

zone-member security out-zone

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.2.2 255.255.255.0

ip nat outside

ip virtual-reassembly

zone-member security out-zone

duplex auto

speed auto

!

interface Vlan1

description LAN$FW_INSIDE$

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly

zone-member security in-zone

ip policy route-map ALPI

!

ip route 0.0.0.0 0.0.0.0 192.168.1.1 track 123

ip route 0.0.0.0 0.0.0.0 192.168.2.1 250

!

access-list 109 permit ip host 192.168.0.66 any

!

route-map ALPI permit 10

match ip address 109

set ip next-hop 192.168.2.1

!

Thanks in advance for your help,

Albert Moran

2 REPLIES
Hall of Fame Super Silver

Re: Route-map based ip policy not working

After you posted this question in this forum you then posted this question in the WAN Routing and Switching forum where I have posted an answer. I suggest that any further discussion be consolidated in that forum.

HTH

Rick

New Member

Re: Route-map based ip policy not working

Sorry about the double post. At first I did not see my own post and though it was not sent correctly (my fault). When re-sending it, considered the other forum as more adequate.

Albert

222
Views
0
Helpful
2
Replies