Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Routers and Switch Conf for Network Management

Following are my Router and Switch Configuration

Router A

!

interface Fastethernet0/0

no ip address

duplex auto

speed auto

!

interface Fastethernet0/0.1

encapsulation dot1q 2

ip address 192.168.121.249 255.255.255.248

!

interface Fastethernet0/0.2

encapsulation dot1q 3

ip address 192.168.99.249 255.255.255.248

!

interface Fastethernet0/0.3

encapsulation dot1q 4

ip address 192.168.4.137 255.255.255.248

Switch A

!

interface fa0/12

switchport mode trunk

!

interface vlan4

ip address 192.168.4.138 255.255.255.248

Now the problem is with the ip address of Switch. Somehow with vlan4 it is not establishing a connection with Router. If i change the interface on Switch from vlan4 to its default of vlan1 than it works fine and also communicates with my CiscoWorks at the other side of Router.

My actual Network Management VLAN is 4. Can someone help me in this regard.

With Best Regards

Mansoor

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Routers and Switch Conf for Network Management

Hi Mansoor,

It looks like you have forgotten to change the native vlan from its default value of vlan 1 to vlan 4

The native VLAN is used for untagged traffic when the port is in 802.1Q trunking mode. While configuring 802.1Q trunking, it is very important to keep in mind that the native VLAN must be configured the same on each side of the trunk link

Command to use for Router

int fa0/0.3

encapsulation dot1Q 4 native

Command to use for switch

int fa0/12

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

To check the settings use the following command on switch.

show int fastEthernet 0/12 switchport

Let us know if that sorts out your problem

Sarb

2 REPLIES

Re: Routers and Switch Conf for Network Management

Mansoor,

From what I can see your configs look right.

1. Your not using vlan 1 for anything

2. 2950's depending on which version only support dot1q and you have do1q 4 for vlan 4 so thats right.

3. Both ips are in the same bit boundary.

Here are a couple of things you can try shut down your interfaces and bring them back up. It'll take about 45 seconds for them to come up then try pinging from the switch to the router a couple of times, and vica versa. Be patient might take a moment longer than you expect.

Two for S&G try shutting interface vlan 1 down on the switch. I know it shouldn't do anything but It seems like I remember I've had problems before with both of them up.

Three make sure the vlans are setup in your vlan database. To verify execute the following command

"sh vlan brief"

If your vlans are missing go and add them with the following from the privledge exec mode.

switch#vlan database

switch(vlan)# vlan 4 name VLAN-4

switch(vlan)# vlan 3 name VLAN-3

switch(vlan)# vlan 2 name VLAN-2

switch(vlan)# exit

Hope that Might help

Patrick

New Member

Re: Routers and Switch Conf for Network Management

Hi Mansoor,

It looks like you have forgotten to change the native vlan from its default value of vlan 1 to vlan 4

The native VLAN is used for untagged traffic when the port is in 802.1Q trunking mode. While configuring 802.1Q trunking, it is very important to keep in mind that the native VLAN must be configured the same on each side of the trunk link

Command to use for Router

int fa0/0.3

encapsulation dot1Q 4 native

Command to use for switch

int fa0/12

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

To check the settings use the following command on switch.

show int fastEthernet 0/12 switchport

Let us know if that sorts out your problem

Sarb

255
Views
0
Helpful
2
Replies
CreatePlease to create content