Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

RSPAN traffic in Linux

I am having difficulties with getting RSPAN traffic in Linux over my trunk link.

Here's the setup .

[PC1]---[Gi0/1--CoreSw--Gi0/2]---802.1q trunk---[PC2_Linux]

CoreSW - Cisco C3560E version IOS 12.2(35r)SE

PC2_Linux - Linux PC with a VLAN is working properly

Current configuration of Gi0/1:

interface GigabitEthernet0/1

description MVTS1 port 1

switchport access vlan 21

switchport mode access

end

Current configuration of Gi0/2:

interface GigabitEthernet0/2

description Link to XEN01/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 60,66,98,208

switchport mode trunk

channel-protocol lacp

channel-group 1 mode passive

end

Current configuration of VLAN 98:

vlan 98

remote-span

end

Current configuration of monitor sessions:

monitor session 2 source interface Gi0/1

monitor session 2 destination remote vlan 98

I'm trying to view a traffic from Gi0/1 on PC2. I don`t see it.

Can who help me and tell where the error?

Thanks.

  • Network Management
1 REPLY
Silver

Re: RSPAN traffic in Linux

A Catalyst 2950 switch may not RSPAN traffic correctly. This is due to an ASIC limitation specific to the 2950 platform.

556
Views
0
Helpful
1
Replies
This widget could not be displayed.