Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Blue

Same box LMS 2.6 upgrade from LMS 2.2 issue

/opt/CSCOpx is a symlink to /product/CSCO/CSCOpx created by LMS 2.2 installaton. I tried modifying the following two files to point to /opt/CSCOpx rather than /product/CSCO/CSCOpx, before executing setup.sh, to no avail. It seems they get written over with "/product/CSCO/CSCOpx" everytime during pkgadd of CSCOcore:

/opt/CSCOpx/etc/coreinstall.cshrc

/opt/CSCOpx/etc/coreinstall.profile

***************

Installation of <CSCOcsv> was successful.

application CSCOcsv Command Service Library

INFO: performing pkgadd -a /tmp/cscotmp/CSCO.admin -d /lms26/cs33/packages CSCOcore

/opt/CSCOpx

INFO: Package CSCOcore - Installed. Correcting pkgchk errors - Done.

Processing package instance <CSCOcore> from </lms26/cs33/packages>

...

Installation of <CSCOcore> was successful.

application CSCOcore CWCS Utilities

ERROR: /opt/CSCOpx/etc/coreinstall.cshrc

ERROR: file size <199> expected <244> actual

ERROR: file cksum <16370> expected <20235> actual

ERROR: /opt/CSCOpx/etc/coreinstall.profile

ERROR: file size <204> expected <249> actual

ERROR: file cksum <16806> expected <20671> actual

ERROR: Package verification failed : CSCOcore aborting.

=================================================================

Finished: Wed Mar 28 15:22:21 EDT 2007

=================================================================

===============- Software Installation Tool Completed -==============

=================================================================

===================- Possible Warnings/Errors Encountered -===================

WARNING: This is an upgrade to CiscoView 6.1.2. The CiscoView related data like

WARNING: Device List,Preferences etc. will not be preserved during the upgrade.

WARNING: Exiting installation beyond this point might result in system instability.

ERROR: /opt/CSCOpx/etc/coreinstall.cshrc

ERROR: file size <199> expected <244> actual

ERROR: file cksum <16370> expected <20235> actual

ERROR: /opt/CSCOpx/etc/coreinstall.profile

ERROR: file size <204> expected <249> actual

ERROR: file cksum <16806> expected <20671> actual

ERROR: Package verification failed : CSCOcore aborting.

=====================================================================

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

Please attach the full install log and the /var/sadm/install/contents file from this server to the SR. I also noticed you were not installing from CD. We strongly recommend CD-based installations where applicable to prevent installation problems.

24 REPLIES
Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

This error is focusing on the size and checksum of the files more than the location. Did you modify the contents of these files? They should contain the non-canonical NMSROOT path (i.e. /opt/CSCOpx).

Blue

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

It seems to me pkgadd of CSCOcore (done by Common Service 3.3's setup.sh) is the one that replaced /opt/CSCOpx with /product/CSCO/CSCOpx in those files, everytime.

Much earlier during the installation:

INFO: Verifying image for package CSCOcsv...OK.

INFO: Verifying image for package CSCOcore...OK.

INFO: Verifying image for package CSCOapch...OK.

I'm puzzled then why later on it felt the need of "INFO: Package CSCOcore - Installed. Correcting pkgchk errors - Done."

Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

The early package verification checks are done against the install media. The later pkgchk repair is done against what is installed. However, this kind of package problem cannot be repaired.

You may have found a bug with custom path installations on Solaris. Since it sounds like this is reliably reproducible. I recommend you open a TAC service request so a new bug can be filed if needed.

Blue

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

In the meantime, is there any workaround? The only one I can think of is grepping for CSCOtools (the pkg installed in front of CSCOcore) in the install log, and as soon as I see it, try to overwrite the two "bad" files with copies I made containing "/opt/CSCOpx", repeatedly. This approach seems really iffy even on paper.

Or, I can explore abandoning the custom install path all together. Then the question becomes: Are there any existing LMS 2.2 files I need to modify that have /product/CSCO/CSCOpx hardcoded, so LMS 2.6 can forget about /product completely? One immediate issue coming to mind is: While LMS 2.2 symlinks /opt/CSCOpx to /product/CSCO/CSCOpx, RWAN's IPM 2.5 just installs straight into /product/CSCO/CSCOipm, CSCOcwbS, etc., without and linking with /opt.

Blue

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

Oh great, it's not happy either way:

=================================================================

===============- Software Installation Tool Completed -==============

=================================================================

===================- Possible Warnings/Errors Encountered -===================

WARNING: This is an upgrade to CiscoView 6.1.2. The CiscoView related data like

WARNING: Device List,Preferences etc. will not be preserved during the upgrade.

WARNING: Exiting installation beyond this point might result in system instability.

ERROR: /product/CSCO/CSCOpx/etc/coreinstall.cshrc

ERROR: file size <244> expected <199> actual

ERROR: file cksum <20235> expected <16370> actual

ERROR: /product/CSCO/CSCOpx/etc/coreinstall.profile

ERROR: file size <249> expected <204> actual

ERROR: file cksum <20671> expected <16806> actual

ERROR: Package verification failed : CSCOcore aborting.

=====================================================================

Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

Unfortunately, I do not have a server I can use to test a custom installation at this point. That is why I suggested you open a TAC service request so more research can be done.

Blue

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

I have an S2 TAC case opened. Do you know what kind of turnaround time I could expect for an issue such as this?

Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

I couldn't find any existing bugs related to this problem, so a new one may need to be filed. With a possible recreate involved to create the bug, it could be a while. What is the SR number?

Blue

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

605700989. LMS 2.2 End-of-Support is end of June 2007, right?

Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

Please attach the full install log and the /var/sadm/install/contents file from this server to the SR. I also noticed you were not installing from CD. We strongly recommend CD-based installations where applicable to prevent installation problems.

Blue

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

Will do. Does it matter I was installing from CD images mounted with "lofiadm -a" and "mount -F hsfs"?

Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

Image mounting was not tested. While I see no reason why it should not work, it would be safest to do the install from a real mounted CD.

Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

I found the (or a) problem. This is what I suspected. The coreinstall files have duplicate contents entries. Try this:

* Backup /var/sadm/install/contents

* Remove the two entries for /opt/CSCOpx/etc/coreinstall.profile and /opt/CSCOpx/etc/coreinstall.cshrc:

/opt/CSCOpx/etc/copyright/CSCOxrcs.copyright f xerces 0640 casuser casusers 49 3925 1040130052 CSCOxrcs

/opt/CSCOpx/etc/copyright/CSCOxrts.copyright f pxxrts 0640 casuser casusers 2035 14288 1132763479 CSCOxrts

* Save the contents file, and redo the installation

This should work for you (unless there is other contents corruption I missed). DO NOT proceed with this until you have a good backup of contents.

Blue

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

I'm confused. Do I remove these two:

/opt/CSCOpx/etc/copyright/CSCOxrcs.copyright f xerces 0640 casuser casusers 49 3925 1040130052 CSCOxrcs

/opt/CSCOpx/etc/copyright/CSCOxrts.copyright f pxxrts 0640 casuser casusers 2035 14288 1132763479 CSCOxrts

or these four?

/opt/CSCOpx/etc/coreinstall.cshrc f core 0640 casuser casusers 199 16370 1175176578 CSCOcore

/product/CSCO/CSCOpx/etc/coreinstall.cshrc f core 0440 casuser casusers 244 20235 1175176658 CSCOcore

/opt/CSCOpx/etc/coreinstall.profile f core 0640 casuser casusers 204 16806 1175176578 CSCOcore

/product/CSCO/CSCOpx/etc/coreinstall.profile f core 0440 casuser casusers 249 20671 1175176658 CSCOcore

Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

ONLY the top two (i.e. the two I listed). The /products entries MUST remain.

Blue

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

So I should remove

/opt/CSCOpx/etc/coreinstall.cshrc f core 0640 casuser casusers 199 16370 1175176578 CSCOcore

/opt/CSCOpx/etc/coreinstall.profile f core 0640 casuser casusers 204 16806 1175176578 CSCOcore

Not

/opt/CSCOpx/etc/copyright/CSCOxrcs.copyright f xerces 0640 casuser casusers 49 3925 1040130052 CSCOxrcs

/opt/CSCOpx/etc/copyright/CSCOxrts.copyright f pxxrts 0640 casuser casusers 2035 14288 1132763479 CSCOxrts

Correct?

Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

ONLY the two I mentioned in my post. NOTHING else should be removed from this file.

Blue

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

So these two should get removed? They don't seem to have anything to do with coreinstall.

/opt/CSCOpx/etc/copyright/CSCOxrcs.copyright f xerces 0640 casuser casusers 49 3925 1040130052 CSCOxrcs

/opt/CSCOpx/etc/copyright/CSCOxrts.copyright f pxxrts 0640 casuser casusers 2035 14288 1132763479 CSCOxrts

Blue

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

Well, I took out the two coreinstall lines:

/opt/CSCOpx/etc/coreinstall.cshrc f core 0640 casuser casusers 199 16370 1175176578 CSCOcore

/opt/CSCOpx/etc/coreinstall.profile f core 0640 casuser casusers 204 16806 1175176578 CSCOcore

It got it past CSCOcore:

Installation of was successful.

application CSCOcore CWCS Utilities

INFO: performing pkgadd -a /tmp/cscotmp/CSCO.admin -d /lms26/cs33/packages CSCOapch

INFO: Uninstall-Mode=UPGRADE :Old Package is being uninstalled

And it finished fine.

Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

Good. You should be good to go with the rest of the 2.5.1 upgrade, then on to the 2.6 mega-patch CD.

Blue

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

Thanks for all your help. Is this a bug? Will this be fixed on new CDs of LMS 2.6 or a later maintenance release?

Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

This may have been a problem with LMS 2.2. My analysis of the 2.5.1 code (this file isn't touched in 2.6) leads me to believe that this should no longer happen moving forward.

Cisco Employee

Re: Same box LMS 2.6 upgrade from LMS 2.2 issue

Sorry, I completely mis-copied the lines in my post. My mouse must have slipped. You removed the correct lines. The two lines in this post MUST remain. Sounds like you did the right thing.

157
Views
10
Helpful
24
Replies
CreatePlease to create content