Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Seed device unreachable

Hi. Just installed LMS 3.0.1 on a new server. Previously used LMS 2.6.

Tried adding seed devices in Common Services>Device and Credentials>Device Discovery>Discovery Settings> Configure for Seed Device Settings. Under global I have added the seed device (using the loopback address), set the snmp, no filters, global settings - checked use default credentials and selected use loopback address.

Majority of the devices come back as unreachable. The switches have snmp strings, logging to the new ciscoworks server ip, and a new line access-list 10 permit new ciscoworks server ip. I cannot find the jump router boundary option in this new version. The snmp string are the same as used in LMS 2.6.

The new ciscoworks server ip has been added to the same firewall rule as the one running LMS 2.6.

Just added a new device at a new location. The LMS 2.6 discovers the device but LMS 3.0.1 says its unreachable.

I can do a sh access-lists and see matches to what corresponds for the LMS2.6 but not LMS3.0.1.

Any ideas?

8 REPLIES
Cisco Employee

Re: Seed device unreachable

If seed devices are being reported as unreachable, then there is an issue with SNMP. First, check that the device really is reachable from the LMS server by doing an SNMP Walk from Device Center. Use sysObjectID as the starting OID.

If that works, start a sniffer trace filtering on traffic to one Unreachable device. Then start a new Discovery. When it completes, look at the trace to see what it shows.

One thing to note that if the devices are already in DCR, then Discovery will use the credentials in DCR rather than the ones you've configured in Discovery.

New Member

Re: Seed device unreachable

Hi,

Thanks for the quick reply:

Using one of the IPs on the device, the result is:

The following is a SNMP walk of device (one ip of device) starting from .1.3.6.1.4.1.9.1.633

SNMP Walk Output

--------------------------------------------------------------------------------

.1.3.6.1.4.1.9.1.633

.1.3.6.1.4.1.9.1.633 = No Such Object available on this agent at this OID

Using the loopback IP of the device, the result is:

The following is a SNMP walk of device (loopback IP) starting from .1.3.6.1.4.1.9.1.633

SNMP Walk Output

--------------------------------------------------------------------------------

.1.3.6.1.4.1.9.1.633

Failed to snmpwalk the device. Please check your community string and starting OID, and try again.

Also what is the proper way of adding devices to LMS3.0? Was the way I did it on message 1 correct?

Thanks,

Stan

New Member

Re: Seed device unreachable

in your global settigs what are you using for preferred ip, i found this issue with using sysname, all unreachable but after checking connectivity I found no issues. As soon as I changed it to resolve by name, all were reachable.

Re: Seed device unreachable

Your snmp walk indicates that the server cannot reach the devices through the loopback address (routing issue, ACL, Firewall) but it can reach the 'normal' IP address of the device. Change the IP address of the devices in DCR to one your LMS server can reach.

by the way, to use the snmpwalk correctly enter .1.3.6.1.2.1.1.2 instead of .1.3.6.1.4.1.9.1.633 (or just the string sysObjectID)

Cisco Employee

Re: Seed device unreachable

You entered the wrong thing. You entered the value of sysObjectID for the starting OID. You should have just entered "sysObjectID". Make sure the SNMP Walk tool can query the sysObjectID of the device. The actual OID value will not be pollable.

New Member

Re: Seed device unreachable

Thanks! I've entered in the correct OID.

The following is a SNMP walk of device (loopback ip) starting from .1.3.6.1.2.1.1.2

SNMP Walk Output

-----------------------------------------

.1.3.6.1.2.1.1.2

Failed to snmpwalk the device. Please check your community string and starting OID, and try again.

The following is a SNMP walk of device ('normal ip of device) starting from .1.3.6.1.2.1.1.2

SNMP Walk Output

-----------------------------------------

.1.3.6.1.2.1.1.2

.1.3.6.1.2.1.1.2.0 = OID: .1.3.6.1.4.1.9.1.633

In Common Services > Device Discovery, the following numbers stay the same consistently:

Device Discovery Summary

Discovery Status: Completed

Discovery Start Time: Fri Feb 20 11:00:02 EST 2009

Discovery End Time: Fri Feb 20 11:24:11 EST 2009

Total Devices Discovered: 73

Reachable Devices: 6

Unreachable Devices: 67

Devices Newly Added to DCR: 0

Devices Updated to DCR: 6

When I click on the 67 unreachable devices, the list shows the device ip I'm interested in as First Found By Module as System and Unreachable.

All the other device ips show First Found By Module as CDP and Unreachable

I have added the ip of the device that the snmp walk can find to the DCR thru the CiscoWorks Assistant>Server Setup> Add Devices> Run Discovery checked.

In the Discovery Module Tab, Layer 2 Discovery Protocol - Cisco Discovery Protocol (CDP) is checked. On the seed Devices tab,under Global, clicked add and put in the IP address of the device. In the snmp settings tab, snmp strings are correct & no filter settings, and

Global Settings: Preferred DCR Display Name=Host Name, Preferred Management IP=Use LoopBack Address, and

use Default Credentials is checked.

Am I missing any other settings? I don't remember how the other 6 reachable devices were entered.

New Member

Re: Seed device unreachable

Also I just noticed that when you click next, the next screen of Add Devices Steps shows that Device Discovery in (CiscoWorks Server backup IP, instead of the actual CiscoWorks Server IP) is displayed and it is Running (Discovery Started Successfully).

Can this be an issue when it displays the backup IP instead of the actual server IP when it is doing the discovery?

Cisco Employee

Re: Seed device unreachable

This tells me that the device is truly not SNMP reachable. This can mean a bad community string, or a firewall or access-list blocking access. You will need to track down where on the network the SNMP packets are being dropped.

A device which is found to be unreachable via System means that the device is a seed device (either in DCR or statically configured as seed).

If you're absolutely sure the SNMP credentials are correct, and the device is not already in DCR (seen under Common Services > Device and Credentials > Device Management), then the network must be dropping the packets somewhere. If the device is already in DCR, try re-entering the SNMP credentials under Device Management to make sure they are correct.

Before Discovery will mark these devices as reachable, you must be able to SNMP Walk sysObjectID from Device Center using the SNMP credentials that are configured either in DCR or in Discovery.

737
Views
0
Helpful
8
Replies