Cisco Support Community
Community Member

simple erase flash question


I have a pix which is on 6.3. I want to put 7.2(3) on it but not enough space in flash.

I dont need to keep anything that is on it so I just want enough space for the new image.

I though to delete contents of flash its just clear flashfs? when I run that command it appears to clear it but I still get not enough space.


here is the message

Received 8386560 bytes

Erasing current image

Insufficient flash space available for this request:

Size info: request:8314936 current:1966136 delta:6348800 free:2752512


Re: simple erase flash question

If you have a PIX501, 506, or 506E, you can install 7.x code. If you have a higher platform, you'll need to purchase a flash memory upgrade.

HTH and please rate.

Re: simple erase flash question

I faced a similar problem with pix sometime back. When looking out for solutions, I read somewhere that erase flash doesnt completely remove ios from flash but compress & stores it. Probably thats what the delta content represents in your output. have u tried delete command. I dnt exactly remember, whether its delete or something else to completely remove ios from flash. Searching..... will post back.

Community Member

Re: simple erase flash question

its bad flash guys.

How to Check if the Router has a Bad Flash

If the router has a bad Flash, it will not be able to download the Cisco IOS software image. If you issue the show flash command, it will not be able to recognize the Flash. Below is an example of a bad Flash:

3810#show flash

8192K bytes of processor board System flash (Unknown flash)

Directory of flash:/

%Error opening flash:/ (Invalid argument)

No space information availableIf the Flash is bad, it should be replaced.

Community Member

Re: simple erase flash question

nm - saw that it was flash related.

Was going to add the following.

I ran into this when trying to take my PIX 525 from 6.3(5) to 8.0. Wasn't making sense because the device has the required 16MB flash, but it wasn't working. During the intial reboot in the upgrade process the new code rewrites how it addresses and uses flash and allows you to use a flash amounts greater than 8MB, but before that on 6.3(5) I believe you can only use 8MB chunks.

You might check to make sure you're using PIX code 7.0/8.0 code and not ASA 7.0/8.0, which was my issue. I know better but for some reason it wasn't clicking that the code would be specific to the firewall hardware. Also the PIX code stays under 8MB while the ASA includes more bloat that gets it up into the 14MB.

You'd think if you're using the wrong code that it would tell you, but it does not, at least on 6.3(5). It simply says insufficient memory. However on newer releases it does state image not valid for platform.

CreatePlease to create content