Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

SNMP via User Tracking

Every day around 10:30a cst CiscoWorks LMS2.6 is hitting 2 of my subnets with SNMP requests that don't have the correct Community string. After looking through all the jobs that I see in the Job Browser, there are none that run during this time frame. Or even close to this time. The ONLY thing I can find that runs at this time is User Tracking.

Here's a Snippet from the UT.log (not sure if this is the right log, the name seems to make sense though) file:

2007/06/15 10:26:42 EvalTask-vmpsadmin-11 ani WARNING C3750VmpsAdminSMFGetVlanRoutingInfo: SNMP error com.cisco.nm.lib.snmp.futureapi.SnmpReqTimeoutException: SnmpRequestTimeout on <network>.12.10 while performing SnmpWalk(*) at index = -1

2007/06/15 10:27:00 EvalTask-vmpsadmin-05 ani WARNING C3750VmpsAdminSMFGetVlanRoutingInfo: SNMP error com.cisco.nm.lib.snmp.futureapi.SnmpReqTimeoutException: SnmpRequestTimeout on <network>.12.5 while performing SnmpWalk(*) at index = -1

2007/06/15 10:28:14 EvalTask-vmpsadmin-03 ani WARNING C3750VmpsAdminSMFGetVlanRoutingInfo: SNMP error com.cisco.nm.lib.snmp.futureapi.SnmpReqTimeoutException: SnmpRequestTimeout on <network>.12.8 while performing SnmpWalk(*) at index = -1

2007/06/15 10:29:05 EvalTask-vmpsadmin-05 ani WARNING C3750VmpsAdminSMFGetVlanRoutingInfo: SNMP error com.cisco.nm.lib.snmp.futureapi.SnmpReqTimeoutException: SnmpRequestTimeout on <network>.12.11 while performing SnmpWalk(*) at index = -1

2007/06/15 10:29:57 EvalTask-vmpsadmin-08 ani WARNING C3750VmpsAdminSMFGetVlanRoutingInfo: SNMP error com.cisco.nm.lib.snmp.futureapi.SnmpReqTimeoutException: SnmpRequestTimeout on <network>.12.9 while performing SnmpWalk(*) at index = -1

Why would user tracking be sending out SNMP packets? Is there somewhere I can go to configure the String I want it to use? I found in the Device discovery section where I can set the string, but that already contains the correct string.

My devices are configured properly with the correct snmp host commands and the device credentials are correct in the DCR. Any ideas where else to look for this culprit?

1 REPLY
Cisco Employee

Re: SNMP via User Tracking

User Tracking will use SNMP to query the ARP tables of routers, and the CAM/MAC tables on switches. In this case, it needs to map VLANs to subnets, and it is polling the cviRoutedVlanIfIndex object on your 3750 switches. The community string UT will use to poll devices is kept in the DCR (i.e. Common Services > Device and Credentials > Device Management).

However, when the CAM/MAC table is read from switches, UT will do community string indexing to get MAC addresses from all available VLANs. This has been known to trigger a lot of authFail traps. The best thing to do is to get a sniffer trace around the time this is happening filtering on one device that is sending the traps. See what community string is being used. If it is clearly wrong, then correct it in DCR. Else, if the community string is correct, but the "@index" portion is wrong, post your ANIServer.properties, and it may be possible to tune some things to avoid this problem.

164
Views
0
Helpful
1
Replies
CreatePlease to create content