Cisco Support Community
Community Member

Software management

I am trying to upgrade the software of a 3750 switch with ciscoworks. I added the image to the repository, and created a job to push it to a 3750 on the network. The job failed.

Note that Ciscoworks' connection to the device is working properly, through SNMP and telnet.

Looking closely in the switch_telnet.log file, when the switch is trying to copy flash to tftp, there is an %Error writing tftp://... (Timed out)...

Same thing happens later when the switch tried to retrieve the new image from the ciscoworks tftp server: %Error opening tftp://... (timed out)

I double checked that the host based firewall on the ciscoworks server is turned off, and CWCS tftp service is Started. (Ciscoworks is running on Windows 2003).

I have no idea where to look next to get to the source of this problem and fix it. Any ideas and suggestions would be greatly appreciated.

Thank you.

Cisco Employee

Re: Software management

First thing to check is to see if there are any firewalls or access-lists between the CiscoWorks server and the device that could be blocking UDP port 69. One of the best ways to do this is a manual TFTP test. Create an empty file in NMSROOT\tftpboot called test.cfg. Then try to perform the following from your network device:

copy runn tftp://x.x.x.x/test.cfg

Where x.x.x.x is the IP address of the CiscoWorks server. If that fails with the same error, then the problem is in your network.

If you find that TFTP is blocked, and you cannot allow it, consider switching to RCP instead. Setup for RCP is documented in the SWIM online help within RME.

CreatePlease to create content