Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Spanning Tree MIB empty

Hi all,

i have a switch (WS-C3560-8PC) Cisco IOS Software, C3560 Software (C3560-IPBASEK9-M), Version 12.2(50)SE3, RELEASE SOFTWARE (fc1)
where I get no values when asking the spanning tree mib (1.3.6.1.2.1.17.2).

But this switch is configured like all other, where I get values:

spanning-tree mode rapid-pvst
spanning-tree portfast bpduguard default
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
Is this model not supported to use the STP mib, or must i configure something more to get values?

Best Regards

Berthold

  • Network Management
1 REPLY
Cisco Employee

Re: Spanning Tree MIB empty

  The problem you are seeing might be due to the fact that the BRIDGE-MIB uses community string indexing.  Check the link for details.  Basically, you need to append the VLAN you want to poll at the end of the community string i.e.

snmpwalk -v2c -c public@30 10.10.10.1 1.3.6.1.2.1.17

  This would mean you are polling for details on VLAN 30.  If you do not append anything to the community, it will poll the default VLAN.  If there are no ports associated to the default VLAN, then it would be expected not to see any results.


520
Views
0
Helpful
1
Replies
This widget could not be displayed.