Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

SSH issue with LMS 3.1

Hi, I've read several threads with the same issue, some docs (such as user guide for campus manager 5.1) and still have no solution.

So, I've tried to SSH to devices from campus manager-> topology view but always got this message "ssh client is not found".

I've created campusmgr.properties in my home directory (C:\Documents and Settings\Administrator) with the single line in it "CMSSH=C:\\PUTTY\\PUTTY.EXE" (without "").

I've load PUTTY.EXE into the C:\PUTTY.

I've also updated Campus Manager - Version & Patch Level: 5.1.1.

What's wrong?

Any advice?

Regards, Eugene

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: SSH issue with LMS 3.1

The messages I am expecting to see are not here. It's as if you're still running Campus 5.1. Try clearing out the Java Web Start cache under the General tab of the Java Control Panel. Click the Delete Files button, and remove everything. Then restart your browser, and try launching Topology Services again.

10 REPLIES
Cisco Employee

Re: SSH issue with LMS 3.1

You will need to be on CM 5.1.1 as there was a bug that prevented this from working in CM 5.1. Everything else is right assuming you're currently logged in as Administrator. Please post the output of the Java Web Start console.

Also, make sure that the file is really campusmgr.properties without a hidden .txt extension. Windows has a tendency to add extensions when they shouldn't be there.

Community Member

Re: SSH issue with LMS 3.1

Hi, jclarke.

CM version is 5.1.1.

I'm log in as Admin (default user profile in LMS).

File is campusmgr.properties without .txt extension.

>>Please post the output of the Java Web Start console

please, explain, how can I show it?

Cisco Employee

Re: SSH issue with LMS 3.1

In the task tray, there is a Java icon. Right-click on it, and you should be able to launch the console.

Community Member

Re: SSH issue with LMS 3.1

start->control panel -> java

general

update

java

security

advanced ???

can not find output of the Java Web Start console ;(

Cisco Employee

Re: SSH issue with LMS 3.1

It's the Java console option under the advanced tab. You need to enable the console. Then it will pop up automatically when you launch Topology Services.

Community Member

Re: SSH issue with LMS 3.1

thanks.

Cisco Employee

Re: SSH issue with LMS 3.1

The messages I am expecting to see are not here. It's as if you're still running Campus 5.1. Try clearing out the Java Web Start cache under the General tab of the Java Control Panel. Click the Delete Files button, and remove everything. Then restart your browser, and try launching Topology Services again.

Community Member

Re: SSH issue with LMS 3.1

Hi, jclarke.

So it was cache. Thanks a lot. Now I can connect to such devices as ASA, but the ssh option for connection to the call managers has disappeared...

Is it possible from the Topology Servicesto connect to CCM through ssh?

Cisco Employee

Re: SSH issue with LMS 3.1

No. The current code assumes that CCMs run Windows, and do not have an SSH server.

Community Member

Re: SSH issue with LMS 3.1

Thanks for your help!!!

275
Views
0
Helpful
10
Replies
CreatePlease to create content