Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

STP Topology Change - Alert Spamming

Hello,

We recently setup CiscoWorks and we are constantly (about every 10 minutes, sometimes more frequently) getting notifications of "STP Topology Change". I checked the logs on the switches as well as HSRP and CPU utilization and port utilization. I don't see any evidence or possible causes of Topology changes. We do use VOIP phones. I'm wondering if the fact that all the access ports are actually trunk ports (VOIP and client PC) could be causing these alerts when machines are unplugged or turned off. Has anyone experienced this?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: STP Topology Change - Alert Spamming

This is coming from DFM based on the reception of the topologyChange trap from the switch.

Typically, voice ports are not trunks, but rather one access port which can support two vlans (a primary and a voice). In this case, portfast should be enabled, and topology changes will not occur. For example:

interface FastEthernet0/1

switchport access vlan 30

switchport mode access

switchport voice vlan 20

spanning-tree portfast

spanning-tree bpduguard enable

end

2 REPLIES
Cisco Employee

Re: STP Topology Change - Alert Spamming

This is coming from DFM based on the reception of the topologyChange trap from the switch.

Typically, voice ports are not trunks, but rather one access port which can support two vlans (a primary and a voice). In this case, portfast should be enabled, and topology changes will not occur. For example:

interface FastEthernet0/1

switchport access vlan 30

switchport mode access

switchport voice vlan 20

spanning-tree portfast

spanning-tree bpduguard enable

end

New Member

Re: STP Topology Change - Alert Spamming

Thank you. Adding portfast and bpduguard is on the list of things to do in our next maintenance. = )

226
Views
0
Helpful
2
Replies
CreatePlease to create content