Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

strange behavior of tcl script

Hi. I noticed that this script acting weird from time to time. It works fine 80% of the time but sometimes It stops randomly with --------------------more---------------- response on the screen and "enter" key must be pressed multiple times to complete it. The is no errors being showed on the screen. The following script is ran manually using alias and switches certain ports on the switch from one vlan to another based on administrator input. The switch is 6509 with SUP32 running 12.2(33)SXI3 IOS version. Any ideas? Did someone have similar problem? Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: strange behavior of tcl script

This is CSCsm37007.  It is fixed in recent versions of EEM 3.0 which is not available for your platform.  As a workaround, you can do "term len 0" before running the command.

--

Please support CSC Helps Haiti

https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com

2 REPLIES
Cisco Employee

Re: strange behavior of tcl script

This is CSCsm37007.  It is fixed in recent versions of EEM 3.0 which is not available for your platform.  As a workaround, you can do "term len 0" before running the command.

--

Please support CSC Helps Haiti

https://supportforums.cisco.com/docs/DOC-8895

https://supportforums.cisco.com

New Member

Re: strange behavior of tcl script

Thank you, Joe.

It still happens though but not as often as it used to. I can live with it

200
Views
0
Helpful
2
Replies
CreatePlease login to create content