Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Sync Archive Fails

I am receiving the following errors when attempting to Sync Archive on a few of our units.

n CM0151 PRIMARY RUNNING Config fetch failed for <devicename>

o Cause: Could not enter ENABLE Mode from USER Mode on Device.

n TELNET: Failed to establish TELNET connection to <deviceip> -

o Cause: Authentication failed on device 3 times.

n TFTP: Failed to fetch config using TFTP.

o Action: Check if protocol is supported by device and required device package is installed. Check device credentials. Increase timeout value, if required. --

I have checked and confirmed the permissions on the causer and the account has full control from the root of C:\program files\CSCOpx\files\rme\dcma down. Any suggestions would be appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Sync Archive Fails

Yeah, it would based on the original output. The best way to troubleshoot TFTP/SNMP is to start a sniffer trace filtering on UDP traffic to this device. Then perform another sync archive job. when it fails, look at the sniffer trace. It should indicate the problem.

Common causes for TFTP failure are bad SNMP read-write community string in DCR, firewall blocking udp/69 or ephemeral UDP ports, or bad permissions on the server's tftpboot directory.

10 REPLIES
Cisco Employee

Re: Sync Archive Fails

The error points to bad credentials in DCR for this device. Export the DCR inventory to CSV, then visually verify the credentials. Then test that you can telnet/SSH to the device using those credentials from the LMS server.

New Member

Re: Sync Archive Fails

I will do that. Another question, since we have the system configured to use the RO Community String and RW Community String for retrieving the archive why does it bypass this option and goes straight to Telnet?

Cisco Employee

Re: Sync Archive Fails

It doesn't look like your protocol order is specified correctly. Post a screenshot of RME > Admin > Config Mgmt > Transport Settings.

New Member

Re: Sync Archive Fails

Here is the screen shot.

Config Fetch

1 - SSH

2 - Telnet

3 - TFTP

Config Deploy

1 - SSH

2 - Telnet

3 - TFTP

Cisco Employee

Re: Sync Archive Fails

Yep, that's the problem. SSH and telnet come before TFTP. If you want to use TFTP/SNMP, promote the TFTP option to be first for config fetch.

New Member

Re: Sync Archive Fails

I have changed the settings and am trying it now on one of the devices and post shortly.

New Member

Re: Sync Archive Fails

I did not show a setting to only use the SNMP setting so I set this to

1 - TFTP

2 - SSH

3 - Telnet

No joy still fails.

Cisco Employee

Re: Sync Archive Fails

Yeah, it would based on the original output. The best way to troubleshoot TFTP/SNMP is to start a sniffer trace filtering on UDP traffic to this device. Then perform another sync archive job. when it fails, look at the sniffer trace. It should indicate the problem.

Common causes for TFTP failure are bad SNMP read-write community string in DCR, firewall blocking udp/69 or ephemeral UDP ports, or bad permissions on the server's tftpboot directory.

New Member

Re: Sync Archive Fails

Thank you. I will try this out also.

1) Compare the DCR file credentials for the device

2) wireshark the traffic and kick off the arhive

Will post back when I get a chance. Have a Happy 4th of July.

New Member

Re: Sync Archive Fails

You led me down the right path. I ran wireshark on the CW server and started the archive. We could see the SNMP traffic going back and forth. However, the config was being transfered via tftp and it was failing. We checked the firewall between us and the units and sure enough there was a rule in but not coming back. We adjusted this and now we are getting successful archives. Thanks for your time.

220
Views
0
Helpful
10
Replies