Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Syslog Collector on CiscoWorks 2.2 not working

Hello,

We have a Win2K server with CW Common services 2.2. The Syslog collector is not working properly. I stopped and restarted the CW Daemon process and rebooted the server - Still doesn't work.

I also restarted the CW Syslog process in the Services in Admin Services.

I see that the $NMSROOT/CSCOpx/log/syslog.log file is incrementing in size but I am still not getting anything from the Syslog Collector in RME/Admin/Syslog collector status.

How can I fix this? Thanks, Bob Schlifke

3 REPLIES

Re: Syslog Collector on CiscoWorks 2.2 not working

I assume it is a problem with the filesize of your syslog.log file. Stop the daemons with 'net stop crmdmgtd' and also 'net stop crmlog'. If you still need the syslogs in the file make a backup of the file and overwrite the contents of the original file with nothing:

> syslog.log

restart the daemons with 'net start crmlog' and 'net start crmdmgtd'

New Member

Re: Syslog Collector on CiscoWorks 2.2 not working

Thank you so much for the help!

I didn't need to backup the syslog.log file. I just renamed it and restarted the crmlog and crmdmtgd processes. The Syslog Collector is now showing stats! I am guessing it takes awhile for anything to show up in the 24-hour reports.

Thanks again,

Re: Syslog Collector on CiscoWorks 2.2 not working

fine!

you can bypass this issue by using logrot.pl which is located in NMSROOT\bin.

Look at the online help or search this forum for 'logrot.pl' to get more details about it.

180
Views
0
Helpful
3
Replies
CreatePlease to create content