Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Silver

telnet from topology services

hello

we are upgrading from CW LMS 2.6 to 3.2

we found that in this version we are not able to telnet to devices from topology services

in this link

http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_common_services_software/3.3/release/notes/cs33rel.html#wp54971

i found this bug : CSCsh49922

i think this is our case.

they give only the solution for Windows XP client systems with Internet Explorer 7 browser. the solution works but

is there any other solution if i am using Windows server 2003 with IE 8  (i am telnetting from the server itself).

actually i permit telnet to devices only from ciscoworks machine (acl).

i tried firefox with windows server 2003 but it was not successfull

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: telnet from topology services

You should uninstall all versions of the JPI, then try and launch Topology Services from the server.  You will then get a page which has a link to download JPI 1.6.0_11 from the server itself.  Download, and install this plug-in as the local Administrator.  Then, relaunch your browser, and relaunch Topology Services.  You should see some additional jar files installed.  At this point, you can switch from local Administrator to your actual user, and Campus should work.  Telnet should aslo work provided you have the telnet.exe binary installed on the system.

8 REPLIES
Cisco Employee

Re: telnet from topology services

IE 8.0 is not supported at the moment.  That said, I was under the impression that the same IE 7.0 solution would work for IE 8.0.  Firefox 3.0 has been tested, and does work.  I have used it the lab, and telnet is working just fine (using JPI 1.6.0_11 on the 2003 client).

Silver

Re: telnet from topology services

thank you joe for your reply.

i am trying to download the JPI that you suggested but i can't find it.

can you suggest one good url?

thanks

Hall of Fame Super Silver

Re: telnet from topology services

For older Java versions, I use the archive at http://java.sun.com/prodcuts/archive

Silver

Re: telnet from topology services

i am using JPI 1.6.0_17-b04

Cisco Employee

Re: telnet from topology services

You should uninstall all versions of the JPI, then try and launch Topology Services from the server.  You will then get a page which has a link to download JPI 1.6.0_11 from the server itself.  Download, and install this plug-in as the local Administrator.  Then, relaunch your browser, and relaunch Topology Services.  You should see some additional jar files installed.  At this point, you can switch from local Administrator to your actual user, and Campus should work.  Telnet should aslo work provided you have the telnet.exe binary installed on the system.

Silver

Re: telnet from topology services

thank you joe.

i can telnet using the 1.6.0_11 JPI with firefox

Community Member

Re: telnet from topology services

i removed any explorer versions and used only IE 6 installed on windows server 2003

i copied the file telnet.exe from windows\system32 to desktop  then tried to open the telnet from the topology

it works fine

Community Member

Re: telnet from topology services

I installed first firefox 3.0 then browse to telnet.exe to be used in telnet sessions.

674
Views
3
Helpful
8
Replies
CreatePlease to create content