Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Topology services cannot connect with multihomed LMS 3.2

Hi,

I'd like to ask for you help. I've installed LMS 3.2 on a server with 2 NICs and we're having a problem executing Topology Service from a remote host.

When I try to launch Topology-Services I get the following error:

Campus Manager Error: "Cannot connect to ANIServer: ANIServer6.0-<hostname>"

Probable cause: "Unknown hostname..."

Recommended Action: "Check wether the ANIServer6.0-<hoostname> process is up and running"

I can see in the java trace that the host communicates correctly with the primary NIC and I don't know for what reason, it uses the second NIC IP of the LMS server when it has to connnect to the OSAGENT service (port 42342 ).

basic: JNLP2ClassLoader.findClass: com.sun.corba.se.impl.presentation.rmi.bcel.StubFactoryFactoryBCELImpl: try again ..
basic: JNLP2ClassLoader.findClass: com.sun.corba.se.impl.presentation.rmi.bcel.StubFactoryFactoryBCELImpl: try again ..
basic: JNLP2ClassLoader.findClass: com.cisco.nm.ani.share.idl.AniClientModule.AniClientHelper: try again ..
basic: JNLP2ClassLoader.findClass: com.cisco.nm.ani.share.idl.AniClientModule.AniClient: try again ..
basic: JNLP2ClassLoader.findClass: com.cisco.nm.ani.share.idl.AniClientModule._AniClientStub: try again ..
network: Cache entry found [url: https://<IP_NIC_primary>:443/CSCOcm/classpath/NS_Ref, version: null] prevalidated=false/0
network: Connecting https://<IP_NIC_primary>:443/CSCOcm/classpath/NS_Ref with proxy=DIRECT
network: ResponseCode for https://<IP_NIC_primary>:443/CSCOcm/classpath/NS_Ref : 304
network: Encoding for https://<IP_NIC_primary>:443/CSCOcm/classpath/NS_Ref : null
network: Disconnect connection to https://<IP_NIC_primary>:443/CSCOcm/classpath/NS_Ref
network: Connecting socket://<IP_NIC_secondary>:42342 with proxy=SOCKS @ <proxy>:8080

For security reasons, the host is strictely not allowed to communicate with the secondary NIC (it is not routable).

- Is it possible to bind all the communications of the "remote client" to the primary NIC IP ?

- How can I force the java client to use the primary NIC when it concerns the OSAGENT service ?

- Is Topology Services supported with multi homed configuration ?

Thanks in advance for your answers.

Regards.

3 REPLIES

Re: Topology services cannot connect with multihomed LMS 3.2

Kindly check if the hostname of the server is resolveable properly with the correct IP address on the client machine and port 42342 is not blocked between server and client in any way.

Its must that client must resolve the hostname of the LMS server with the correct IP Address. If DNS is not configured on the client machine, then you need to do manual entry in the host file of the client machine. I hope you are able to launch the topology from the LMS server.

Also check this :-

To run Topology on a multi-homed machine, there are two requirements.  

All IP addresses must be configured in DNS.

Owing  to restrictions with CORBA, only one IP address can be used by the  client or browser to access the server. You must select one IP address  as the external address, with which the client will login to the  CiscoWorks server.

To select an IP address, modify the gatekeeper file located in NMSROOT\lib\vbroker\gatekeeper.cfg

where NMSROOT is the directory (opt/CSCOpx by default) in which CiscoWorks is installed.

Replace every instance of external-IP-address with the external IP address you choose, and remove the "#" character, from the following:

#vbroker.gatekeeper.backcompat.callback.host=external-IP-address

#vbroker.se.exterior.host=external-IP-address

#vbroker.se.iiop_tp.host=external-IP-address

#vbroker.se.interior.host=external-IP-address

After modifying the gatekeeper file, restart the Daemon Manager. To do this, first stop the Daemon Manager by entering:

net stop crmdmgtd

Now, start the Daemon Manager by entering:

net start crmdmgtd

Hope it helps

Thanks

Gaganjeet

New Member

Re: Topology services cannot connect with multihomed LMS 3.2

Hi gachugh,

The LMS server name is not resolvable for now but we added manually an entry in the host file of the client machine and we still have the same issue in the trace of the java web start.

Yes we are able to launch topology Services from the server but not from a remote client.

gatekeeper.cfg does not longer exist since LMS 3.1 so we cannot modify the file.

Any others ideas ?

Thanks

Re: Topology services cannot connect with multihomed LMS 3.2


Hi .


Gatekeeper.cfg is removed from LMS 3.1. Gatekeeper was part of VisioBrooker which was 3rd party software now removed  from LMS 3.1 (it's JacORB) instead.


As you well said, in the documentation of the LMS 3.1 only two lines are 
mentioned aboutMulti-Homed server:

Multi-homed Machines

A multi-homed machine is a machine that has multiple NIC cards,
eachconfigured with different IP addresses. To run CiscoWorks Common
Services on a
multi-homed machine, all IP addresses must be configured in DNS:
http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_common_services_software/3.2/release/n
otes/cs32rel.html#wp59562


Sorry for pointing towards Gatekeeper.cfg as you are running LMS 3.2


Now to fix this issue, first thing is that all the IP address of the CiscoWorks server should be configured in DNS so that client machine should be able to resolve it. Secondly as I suggest before, kindly check if tcp/42342 and tcp/43242 is open between client and server.


Please check the nslookup output from the client machine and see if it resolves the IP address of the LMS server. If you have made the entry in the host file then nslookup should resolve the  correct IP address of the server.

Thanks

Gaganjeet


1264
Views
0
Helpful
3
Replies
CreatePlease to create content