Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Topology Services not connecting router to switch

Campus Manager 4.0.4 - when looking at a subnet with topology services, if the router has a sub-interface it is never drawn as being connected to the switch it is plugged into. Even though it is clearly seen with CDP?? Is this a bug with this version? Does it work with older versions of CiscoWorks??

4 REPLIES
New Member

Re: Topology Services not connecting router to switch

Which subnet mask are you running over the link? We found a fault in CM 4.0.x with /31 masks. Although our switches\ routers would display the correct cdp neighbours the point to point link wasn't displayed in topology services.

Cisco have patched the IPv4Address.class file, although it hasn't been released to public (CSCsd66335).

HTH

New Member

Re: Topology Services not connecting router to switch

Over 90% of the subnets are /24, with a couple using /22. The fault shows up with all of them. It does not occur when there is no sub-interface used.

New Member

Re: Topology Services not connecting router to switch

Must be a bug with this version. I just tested setting up a sub-interface on two of our 3750's and I get the same result (CM 4.0.4).

I've seen some weird bugs in the way Campus manager recognises links. Maybe raise a TAC case and see if support can help? The TAC team in Sydney were excellent in troubleshooting my fault listed above.

New Member

Re: Topology Services not connecting router to switch

Hi, did you fix the issue?

We are having the same problem.

Thank you

Julio

224
Views
3
Helpful
4
Replies
CreatePlease login to create content