Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Unable to distribute software in Cisco Prime 4.1

I currently have an issue distributing software via the software repository in Cisco Prime 4.1.

For any IOS that I try to distribute, I get the following error...

SWIM1001: The input parameters to the Image Distribution/Image Import/Image Activate are invalid. # You may have used incorrect Device Data for this task. # Check the application log file for more details.

I checked the log and do not see what could be causing the issue.

Any help would be appreciated.

9 REPLIES
Cisco Employee

Unable to distribute software in Cisco Prime 4.1

Hi Ben,

There is a BUG somewhat releated to the issue that you are running into ,however try the below steps and see how it works:

Follow the steps given below:

1.      Go to Admin > Collection Settings > Inventory > Edit the Inventory/Config Timeout and Retry Settings and select the device and click Edit Device Attribute

2.       Click inline Edit

3.       Select Device in the window that appears, enter the timeout for the required fields, click modify

=======================================================

You can set Telnet timeout value to 1000 and Read delay to 600. Initially you can set time out value to some range, if it is not working out, you can gradually increase in form of 100, ie if you initially set telnet time out value to 800, and try the job, if it fails due to time out, you can increase to 900 and so on.

=========================================================

4.       Click apply

Thanks-

Afroz

[Do rate the useful post]

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

Unable to distribute software in Cisco Prime 4.1

Thanks for the response Afroz,

Unfortunately it did not work. I changed the settings a few times and got the same error.

Thanks.

Cisco Employee

Unable to distribute software in Cisco Prime 4.1

Hi,

Try to re-add  Image in the software Repository

or another thin that you can try is to delete and re-add the device ..otherwise you need to share SWIM_debug.log (NMSROOT\log) after enabling the SWIM  Debug.

Thanks-

Afroz

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

Unable to distribute software in Cisco Prime 4.1

I have added the SWIM_debug.log into the post.

Thanks so much for your help.

Cisco Employee

Unable to distribute software in Cisco Prime 4.1

Ben ,

I need the fresh logs , logs that you have shared are from 6 Dec and they are not in Debug mode.

Enable the debugging for SWIM  , Go to

Admin > System > Debug Settings > Config and Image Management Debugging settings >> select softwaremgmt

change the log level to DEBUG , run a new SWIM job..

Note:clear the content of the swim_debug.log file first before running a new job..

Thanks-

Afroz

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

Re: Unable to distribute software in Cisco Prime 4.1

Here is a newer one with the debugging turned on and cleared out.

Thanks so much for the help.

Cisco Employee

Re: Unable to distribute software in Cisco Prime 4.1

Hi Ben,

Are you sure ,Job is failing ?

from the logs ,it looks like upgarde was sucessful.  I did not find any relevant Error or exception..

=================================

0

C2900

15.1(4)M6

IP|SLA|IPv6|IS-IS|FIREWALL|PLUS|QoS|HA|NAT|MPLS|VPN|LEGACY PROTOCOLS|3DES|SSH|APPN|IPSEC

c2900-universalk9-mz.SPA.151-4.M6.bin

c2900-universalk9-mz.SPA.151-4.M6.bin

flash:

SYSTEM_SW

IOS<EOFIELD>C2900-UNIVERSALK9-MZ<EOFIELD>15.1(4)M6<EOFIELD>

15.1(4)M7

IP|SLA|IPv6|IS-IS|FIREWALL|PLUS|QoS|HA|NAT|MPLS|VPN|LEGACY PROTOCOLS|3DES|SSH|APPN|IPSEC

SYSTEM_SW

c2900-universalk9-mz.SPA.151-4.M7.bin

tftp://x.x.x.x/c2900-universalk9-mz.SPA.151-4.M7.bin

74610796

flash0:1

flash0:1:c2900-universalk9-mz.SPA.151-4.M7.bin

==========================================

can you check the device IOS and see if it was upgarded.

Thanks-

Afroz

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

Re: Unable to distribute software in Cisco Prime 4.1

Yeah I know, very strange, this is from the Job Report - Plus when I check the Router the IOS is not there. I have TFTP the IOS to the router and it works fine, I deleted the file and tried using Cisco Prime and it failed.

Processing Device : FtCampbell2

Start Time : Tue Dec 10 07:15:20 EST 2013


Device is locked for exclusive access.


The supported protocols for image transfer are: RCP,TFTP,SCP


Sufficient free space is available on flash0 for the new image.


SWIM1001: The input parameters to the Image Distribution/Image Import/Image Activate are invalid.

You may have used incorrect Device Data for this task.

Check the application log file for more details.


Device is unlocked.


Device Upgrade Result : Failed

End Time:Tue Dec 10 07:15:52 EST 2013

New Member

Re: Unable to distribute software in Cisco Prime 4.1

Found the fix, did not have TFTP Wrapper Support configured. A friend of mine found this, once configured everything worked great, strange thou that the logs did not pick that up.

Configuring TFTP

The TFTP (Trivial File Transfer Protocol) daemon shipped by CiscoWorks Common Services supports TCP (Transmission Control Protocol ) Wrappers.

If the TCP Wrapper support is not configured properly in the server where CiscoWorks is installed, the jobs requiring TFTP may fail.

To ensure that TFTP works properly, check the following configuration files:

http://www.cisco.com/en/US/i/templates/blank.gifIf /etc/hosts.allow file is present, ensure that the command in.tftpd is given as in.tftpd:ALL If the command is not there in the file at all, add it as in.tftpd:ALL

http://www.cisco.com/en/US/i/templates/blank.gif If /etc/hosts.deny file is present, ensure that the command in.tftpd is not there in the file

http://www.cisco.com/en/US/i/templates/blank.gif If both the files are not present (/etc/hosts.allow and /etc/hosts.deny), you do not need to make any changes

559
Views
0
Helpful
9
Replies
CreatePlease login to create content