Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Unattended LMS 2.6 installation

I like to do an unattended installation of LMS 2.6. I think it should be possible, but I don't know how the answer file looks like. Could someone give me a hint?

8 REPLIES
Cisco Employee

Re: Unattended LMS 2.6 installation

Here is a sample answer file for Windows:

adminPassword=admin

casuser=casuser

destination=d:\apps\cscopx

systemIdentityAccountPassword=admin

Run setup.exe as:

setup.exe quiet answerfile=C:\path\to\answerfile

For Solaris:

adminPassword=admin

secretPassword=admin

destination=/opt/CSCOpx

Then run setup.sh as:

setup.sh -q /path/to/answerfile

New Member

Re: Unattended LMS 2.6 installation

Thanks for support, it works.

Do you also know a line to add a license file (I'm running windows)?

Cisco Employee

Re: Unattended LMS 2.6 installation

This is not possible to do during an unattended installation. The product will be installed as an eval. Later, you can add the license file via the web.

New Member

Re: Unattended LMS 2.6 installation

Ok, thanks.

Silver

Re: Unattended LMS 2.6 installation

In a ideal world I would :

- "clone" the up to date ciscoworks in my lab,

- install it with a "default" configuration file at the customer site,

- disable the modules he doesn't want,

- install the customer license.

Bring in the customer devices and start the customization my customer wants.

Cheers,

Michel

Silver

Re: Unattended LMS 2.6 installation

I tried a windows install in quiet mode on LMS 3.0.

e:\setup quiet answerfile=d:\answerfile.txt

It reads the destination directory d:\CSCOpx from the answerfile.

It creates the directory.

And then decides the directory is ... read only

????

bummer.

Has anybody been able to get this to work?

Cheers,

Michel

Cisco Employee

Re: Unattended LMS 2.6 installation

Yes, it does work. It would be helpful to see your answerfile and your installation log.

New Member

Re: Unattended LMS 2.6 installation

I have tried a silent installation of RME. But an error occurs and the installation failed. In normal installation mode it works.

It's strange, because no additional program is running and the listed files (see attachment) shouldn't be locked.

123
Views
5
Helpful
8
Replies
CreatePlease to create content