Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Upgrading from LMS 4.1 to Cisco Prime Infrastructure

Looking for some information and confirmation on the upgrade process.

Currently we are running LMS 4.1 with a valid SAS Service Contract which will allow me to upgrade to Prime Infrastructure 1.1 or Prime Infrastructure 1.2 using the upgrade tool at no charge. After using the tool I am given access to download PI1.1 or PI1.2, however, it only actually let me download PI1.1 but said i do not have the proper permissions to download the 1.2 license. I also noticed that the software images for 1.2 are not available ont he ciso download page.

I am wondering what the latest version of Prime Infrastructure I will be able to upgrade to without an additional purchase. Can I upgrade up to all the way up to 1.4 or can I only go up to 1.2 (but then where is the download for the software).

If i can upgrade to 1.4 then what path should I take? 1.1 to 1.3 to 1.4? Just skip 1.2 since the download is not available and it will not let me download the license file?

Thank you for your help

Everyone's tags (3)
5 REPLIES
Cisco Employee

Upgrading from LMS 4.1 to Cisco Prime Infrastructure

Hi Patrick

PI 1.2 is no more available for download because it is a buggy version and we recommend to upgrade to PI 1.3 atleast.

PI 1.4 is not successor release to PI 1.3 but it is a different software train parallel with PI 1.3

Please check warning notice at PI 1.4 download page:

http://software.cisco.com/download/release.html?mdfid=284763234&softwareid=284272932&release=1.4.0&flowid=44203

Also check this link:

https://supportforums.cisco.com/docs/DOC-35177

Accordingly you can decide which version is suitable for you.

You can check about SAS contract with your account team, till what PI version you can downlload.

Thanks

Mahavir

New Member

Upgrading from LMS 4.1 to Cisco Prime Infrastructure

Thank you Mahavir.

"If you have an active SAS contract on LMS 4.x you  can use the  product upgrade tool to order Cisco Prime Infrastructure 1.2  at no  charge. Visit http://www.cisco.com/upgrade." are instuctions in the Ordering Guide for 1.2 but I am unable to find an Ordering Guide for to 1.3 or 1.4.

I was able to get the license for 1.1 through the upgrade tool (not able to get the license for 1.2 probably because of the buggy release) but will this license work for upgrading to 1.3? Can I just install 1.3 or would I have to install 1.1 and upgrade to 1.3? I suspect that this license will work up to 1.4 but am not sure what version to start the install at.

Hall of Fame Super Silver

Upgrading from LMS 4.1 to Cisco Prime Infrastructure

LMS 4.x to Prime 1.x would not be considered a functional or recommended "upgrade" for most intents as you would lose several major capabilities (Topology, Ciscoview, many reports, compliance templates, etc.). Your best path right now would be to move your LMS along to the current version - 4.2.4. The release notes explain the upgrade path for that.

Licensing and upgrade eligibility-wise you need SASU for PI (not plain SAS for LMS) for major upgrades (i.e to go to 2.0). An LMS SAS contract entitles you to migrate to PI 1.2 which in effect means 1.3 although Cisco had some issues with updating the ordering system so there was not actually a SKU for PI 1.3 sold - only the 1.2 version which, when combined with your LMS SAS service contract, entitles you to move to PI 1.3 (or 1.4 but that's not generally recommended). More details are in the Prime Ordering and Licensing Guides here.

Personally, I recommend customers with existing LMS 4.x installations wait until PI 2.1 comes out to consider the upgrade. 2.0 still misses several tools present in LMS 4.x.

If you really want to move over to PI, you can export the data from LMS 4.2.4 and import into PI 1.3 (or 2.0).

New Member

Upgrading from LMS 4.1 to Cisco Prime Infrastructure

Great information Marvin, Thank you.

My last concern is about the licensing. I get an access denied message when I attempt to download the 1.2 license from the upgrade tool but was able to download the 1.1 license from the upgrade tool.

Will this license work if I wanted to install 1.3/1.4? Do I need to start by installing 1.1 then upgrading?

Thank you

Pat

Hall of Fame Super Silver

Upgrading from LMS 4.1 to Cisco Prime Infrastructure

The license file for PI 1.1 should continue to work with 1.2 or 1.3 per the note at the bottom of table 3 here. (Note the caveat about adding additional lifecycle or assurance licenses.)

If you have difficulty with the upgrade portal you can always contact TAC directly and ask for licensing support. The team there can issue your license directly once they verify your entitlement.

If you're set on PI 1.x, you can go straight on to PI 1.3. I'd strongly recommend you set it up on a server in evaluation mode first though before jumping feet first into production.

1258
Views
0
Helpful
5
Replies