Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

User Tracking problem

Hello

we're using the following version of Cisco LMS

1. CiscoWorks Common Services 3.0.4 08

2. Campus Manager 4.0.5 13

3. CiscoView 6.1.4 13

4. Device Fault Manager 2.0.5 13

5. Internetwork Performance Monitor 2.6.0 05

6. Integration Utility 1.6.0 05

7. Resource Manager Essentials 4.0.4 08

We?re having an issue with User Tracking not reporting some IPs of hosts on some of our 2950 switches. The 2950s are used as edge switches and all of them patch into a 3750. All the switches (and gateways) involved are managed by LMS and are snmp walkable. The 2950 switches affected by this have the same config/IOS as those that are working fine.

If I go to Device Centre and have a look at the UT End Host Report for one of the affected switches, there are only mac addresses listed. If I go to User Tracking in Campus Manager and search for hosts by IP the affected IPs are in the User Tracking database but are listed as being on an interface on the 3750.

I?ve tried to delete these entries from the User Tracking database by selecting them and clicking delete. If I go back into the User Tracking database (before running an Acquisition) and search for the IPs I?ve just deleted, they are still there. Do I have to purge the database before running an aquisition?

Thanks

Andy

4 REPLIES
Cisco Employee

Re: User Tracking problem

If UT is showing the MAC addresses, but the IP address and/or hostname fields are empty, chances are that ANI did not discover the default gateway of the host correctly. Is the default gateway showing up correctly in topo services?

Have a look at this link:

http://www.cisco.com/warp/customer/477/Campus/ani.shtml#s7

Re: User Tracking problem

Thanks for the link. I worked through the ANI Discovery section and didn?t experience any problems. The only strange thing I noticed was that the command

snmpwalk -v 2c -c @VLANnumber 1.3.6.1.2.1.17.4.3.1

returned mac addresses in upper case, while the command

snmpwalk -v 2c -c 1.3.6.1.2.1.4.22.1.2.

returned the same mac addresses in lower case.

I?ve tried deleting switches form Topology and rediscovered them ok. Gateway and switches are all LMS managed and snmp walkable.

I?ve checked the ut.log but there?s not much in there ? is there any other debug options for UT that I can use?

Thanks

Andy

Re: User Tracking problem

got this sorted - a couple of weeks ago we renamed the gateway switches. i had updated the details in Common Services and redisvovered them in Campus Manager. the switches were all snmp reachable and walkable but we started having problems with UT - hosts not being discovered or only hosts macs being discovered or hosts being reported as being on the interface of the switch above the one they were on.

i had a look at DFM and found the switches with their old names listed under Device Management with their status listed as Questioned (SNMP Timeout). i deleted the switches from both Common Services and Campus manager and ran Device Discovery - Data Collection and UT aquisition. Now all hosts are discovered correctly

Cisco Employee

Re: User Tracking problem

Great...I thought it would be a default gateway issue ad not being updated or correct in campus

220
Views
4
Helpful
4
Replies
CreatePlease login to create content