Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Using TCL and ios_config to set VLANs

I have a tcl script running which goes through all the notconnect ports and sets their vlan's to a parking vlan. In the lab this runs perfect on a sup-iv 4507 running 12.2(53)SG. Trying the same script on a production 4510 Sup V-10GE causes it to fail on the ios_config command. Something as simple as: ios_config "int fa4/1" "switchport access vlan 666"

The error message I get is "%ERROR: Standby doesn't support this command"

I've definitely narrowed it to the ios_config command, but I can't find any reason this works on one and not the other.

Any suggestions?

3 REPLIES
Cisco Employee

Re: Using TCL and ios_config to set VLANs

I'm guessing the lab switch is not configured for HA where as the production switch is. This is most likely a bug, but I could not find one which involved Tcl. I suggest opening a TAC service request so a recreate can be done, to try and isolate the underlying cause.

Blue

Re: Using TCL and ios_config to set VLANs

Is the prod box running one of the IOS versions affected by this bug?

CSCsl01427

Symptoms: The following symptoms all relate to the same root cause:

1. In syntax check mode, if there is a standby in SSO mode, the cts dot1x command does not work and the following error messages are displayed:

RouterRP(syntax-if)#cts dot1x %ERROR: Standby doesn't support this command ^ % Invalid input detected at '^' marker.

RouterRP(syntax-archive)#path disk0: %ERROR: Standby doesn't support this command ^ % Invalid input detected at '^' marker.

2. After a redundancy force-switchover, the applet configuration is lost and retains only the applet name. (This is done by configuring an applet on the main RP and switchover to the Standby by issuing a redundancy force-switchover. Issue the sh run command on the Standby which is now the main RP.) All the action statements are lost.

3. The Standby switch reloads by itself after going into the event manager applet configuration mode:

Config Sync: Line-by-Line sync verifying failure on command: event manager applet cli-test-01 due to parser return error

4. The Standby switch may also reload upon removing the command event manager applet:

RouterRP(config)#event manager applet 1 EEM: Applet 1 is currently being modified

OR

RouterRP(config)#no event manager applet 1 EEM: Applet 1 is currently being modified

Conditions: The symptoms are observed in syntax check mode, if there is a standby in SSO mode.

Workaround: There is no workaround.

Cisco Employee

Re: Using TCL and ios_config to set VLANs

This is actually a good bug, but I don't believe this is the case here. According to what I found internally, both 12.2(52)SG and 12.2(53)SG SHOULD have the fix which is why I suggested the TAC SR. I've now checked the source code just to be sure, and I find the fix was committed to 12.2(53)SG. If this is the code on the production switch, then it should be fine.

1690
Views
5
Helpful
3
Replies