Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WS-SVC-NAM-2 upgrade from 3.4(1a)

Dear All,

            I have WS-SVC-NAM-2 with following details.

NAM application image version: 3.4(1a)

Maintenance image version: 2.1(3)

NAM Daughter Card Micro code version: 1.34.1.27 (NAM)

BIOS Version: 4.0-Rel 6.0.9

Installed patches:

No patches are installed on this system.

I need to upgrade to latest application inage i.e. 5.1.x

As 3.4(1a) is EOL since long time and to upgrade it to the latest I need to first upgrade my exisiting image to 3.6, but on cisco software download page for NAM-1/NAM-2 application image I counld not found 3.6x.

So can someone tell me how to upgrade to 3.6x from exisiting 3.4(1a) for latest upgrade ?

Thanks & Regards

Ahmed...

Everyone's tags (1)
17 REPLIES
New Member

Re:WS-SVC-NAM-2 upgrade from 3.4(1a)

I got confirmation from Cisco that I can't upgrade from 3.4(1a) to 3.6 or 4.x as both softwares are EoL.

I need to install fresh configuration with 4.x.

Even 3.6 & 4.x can't be upgraded to 5.x.

HTH

Sent from Cisco Technical Support Android App

New Member

WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi,

i have the same query, i want to upgrade "WS-SVC-NAM-2" from 3.4(1a) to the lates version " 6.0.2"

1. can i upgrade directly or i need to upgrade to version 4 or 5 ?

2. can upgrade this module by GUI "WEB" or only command.

3. can you give the procesure for upgrade?

Thanks

New Member

WS-SVC-NAM-2 upgrade from 3.4(1a)

this module doesn't have any configuration like new, long time installed  but no one use it

Cisco Employee

WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi Ahmad and steven,

NAM 3.4 and 3.5 is way old NAM application Image. Development team does not support it.

even they don't recommeneded to use 4.2 as there are few challanges with NAM 4.2 Image as well..

I would suggest to go directly for  6.x  or 5.x .

Here  is the download link :

http://software.cisco.com/download/release.html?mdfid=277991104&softwareid=282700108&release=6.0.2&relind=AVAILABLE&rellifecycle=&reltype=latest&i=rm

NOTE : you would need 2 GB of RAM  on NAM for this upgarde

use the below link for Image upgarde:

http://www.cisco.com/en/US/docs/net_mgmt/network_analysis_module_software/5.1/switch/configuration/guide/advcfg.html#wp1035516

IMP : use the

--install

keyword clears  and recreates all of the NAM partitions; this action is similar to  restoring the factory-default state. If you use the

--install keyword, the previously stored reports and data (if any) will be lost

Thanks-

Afroz

[Do rate the useful post]

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi Aforz,

i am really appreciayed your cooperation, i have one question regarding the RAM, in show tech i have this output

show version
NAM application image version: 3.4(1a)
Maintenance image version: 2.1(2)
NAM Daughter Card Micro code version: 1.34.1.27 (NAM)
BIOS Version: 4.0-Rel 6.0.9
Installed patches:

No patches are installed on this system.

show memory
Installed:      990 MB
Available:      727 MB
System Usage:   262 MB

can i upgrade upgrade to latest version 6-0-2  directly ? and from the above memory is it the RAM is enough ?

becuase you mentioned need 2G

Thanks

Cisco Employee

WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi Steven ,

You may be able to upgarde ,however you need to have 2GB of RAM for the optimum performace of NAM module.

Thanks-

Afroz

[Do rate the useful post]

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi Afroz,

you mean i have enough RAM for upgrade, but regarding 2 GB is it Mandotary or only for performance ?

Thanks

Cisco Employee

WS-SVC-NAM-2 upgrade from 3.4(1a)

You might be able to upgarde but 2GB is recommended

Thanks-

Afroz

[Do rate the useful post]

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi Afroz,

i am really appreciate for your cooperation, so i will upgrade with the same RAM if the customer doesn't want to buy 2 GB and i will not see any issue,

i have another queery  you mentioned i have to use install do you mean i need to use it in this command

root@localhost# upgrade ftp-url --install

am i right?

Cisco Employee

WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi,

root@localhost# upgrade ftp-url --install   

Yes ..that is correct

Thanks-

Afroz

[Do rate the useful post]

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

WS-SVC-NAM-2 upgrade from 3.4(1a)

HI,

thans alot

i will upgrade with the same RAM because the customer doesn't want to buy 2 GB, i hope i will not face an issue

thanks again

Cisco Employee

Re: WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi ..

I am gald  that my post was helpful for you !!!

Thanks-

**Rating Encourages contributors **

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi Ahmad,

              I will be upgrading NAM application version to 5.1.2, I searched many cisco documents, but did not found anything useful how to install NAM application [NOT UPGRADE] as I can not upgrade to 5.1.2 from any 3.x or 4.x version.

I found your comment helpfull to to use --install to installl rather than upgrade.

Can you please confirm that --install will install rather than upgrade ?

Thanks & Regards

Ahmed.

Cisco Employee

WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi Ahmed,

****Upgarde procedure keep the Old data and take you you to the New version *******

This  is an Upgarde Procedure ,however  if you use the  --install command during the Upgarde Procedure ,it will wipeout the old data and NAM will be like a factory Installed and then it will upgarded to New Version.

Follow the below link ,in the step 5:

Step 5 Upgrade the NAM application software as follows:

DON NOT USE THIS 

root@localhost# upgrade ftp-url

where ftp-url is the FTP location and name of the NAM software image file

or

USE THIS ONE

root@localhost# upgrade ftp-url --install

Note The --install keyword clears and recreates all of the NAM partitions; this action is similar to restoring the factory-default state. If you use the --install keyword, the previously stored reports and data (if any) will be lost.

http://www.cisco.com/en/US/docs/net_mgmt/network_analysis_module_software/5.1/switch/configuration/guide/advcfg.html#wp1035516

IMP :: It is recommended to have 2GB RAM for running 5.x image

Thanks-

Afroz

[Do rate the useful post]

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi Afroz,

how are you, hope you are doing well, i have one question, if i want to upgrade nam module from current version 3.4(1a) to version 4.2, do i need fresh installation or i can do normal upgrade?

can i use GUI for upgrading or only way by using commands line?

thanks agian:)

Cisco Employee

WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi Steve,

It can be done only via CLI .

and you need to do a Fresh installed ,if you are moving from 3.4 to 4.x

Thanks-
Afroz
[Do rate the useful post]
****Ratings Encourages Contributors ****

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
New Member

WS-SVC-NAM-2 upgrade from 3.4(1a)

Hi Afroz,

thanks for quick answer and i will the same above steps.

thanks

950
Views
0
Helpful
17
Replies