Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Issue with cisco ONS 15310. Slot with Ethernet ports, designed for bridging.

Hi, guys. I’ve got an issue with cisco ONS 15310 sdh optical network. I’ve got a special slot with Ethernet ports, designed for bridging. Assume, we’ve got to multiplexers, named A and B with ports A0 and B0 respectively. The ios console of these slots says, the configuration is as follows:

no ip address set on these ports

Ports are administratively up

Auto mdix

Bridge groups are the same on these ports.

Dot1q tunnel.

I’m trying to monitor a device with an ip-address connected to port B0. It answers ping if I connect the notebook directly to a device. But if I connect the notebook to port A0 and ping the device pluged in port B0 through the optical network, it doesn’t answer. I tried connections with straight and cross cable.

Guys, who set the network said, it should work as a point to point bridge with no extra configuration. But it doesn’t. I used wireshark sniffer to lookup what’s happening on port A0. All I see is cdp-s from port A0 and self-announcements of the notebook.

Any suggestions? Thank you in advance.

Everyone's tags (5)
7 REPLIES
Hall of Fame Super Silver

Issue with cisco ONS 15310. Slot with Ethernet ports, designed f

I'm assuming you are using ML-100T-8 cards - correct?

It sounds like you might possibly have an issue with the VLAN or dot1q tunneling setup. Have you had a look at the configuration guides for the card (here)?

Can you possibly post the IOS configuration from the ML-100T-8 cards at each end?

New Member

Issue with cisco ONS 15310. Slot with Ethernet ports, designed f

A

Current configuration : 3263 bytes

!

! Last configuration change at

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname A

!

boot-start-marker

boot-end-marker

!

enable password -

!

clock timezone -

ip subnet-zero

no ip routing

no ip domain-lookup

!

no mpls traffic-eng auto-bw timers frequency 0

!

bridge 13 protocol ieee

bridge 30 protocol ieee

bridge 40 protocol ieee

bridge 121 protocol ieee

bridge 122 protocol ieee

bridge 140 protocol ieee

bridge 141 protocol ieee

bridge 142 protocol ieee

bridge 143 protocol ieee

bridge 144 protocol ieee

!

!

interface FastEthernet0

description -

ip address x.x.x.x 255.255.255.0

no ip route-cache

mode dot1q-tunnel

bridge-group 140

bridge-group 140 spanning-disabled

!

interface FastEthernet1

description --- A0 ---

no ip address

no ip route-cache

mode dot1q-tunnel

bridge-group 141

bridge-group 141 spanning-disabled

!

interface FastEthernet2

description -

no ip address

no ip route-cache

mode dot1q-tunnel

bridge-group 142

bridge-group 142 spanning-disabled

!

interface FastEthernet3

description -

no ip address

no ip route-cache

mode dot1q-tunnel

bridge-group 143

bridge-group 143 spanning-disabled

!

interface FastEthernet4

description -

no ip address

no ip route-cache

mode dot1q-tunnel

bridge-group 144

bridge-group 144 spanning-disabled

!

interface FastEthernet5

description -

no ip address

no ip route-cache

mode dot1q-tunnel

bridge-group 121

bridge-group 121 spanning-disabled

!

interface FastEthernet6

description -

no ip address

no ip route-cache

mode dot1q-tunnel

bridge-group 122

bridge-group 122 spanning-disabled

!

interface FastEthernet7

description -

no ip address

no ip route-cache

mode dot1q-tunnel

bridge-group 13

bridge-group 13 spanning-disabled

!

interface POS0

description -

no ip address

no ip route-cache

crc 32

!

interface POS0.1

encapsulation dot1Q 141

no ip route-cache

no snmp trap link-status

bridge-group 141

!

interface POS0.2

encapsulation dot1Q 142

no ip route-cache

no snmp trap link-status

bridge-group 142

!

interface POS0.3

encapsulation dot1Q 143

no ip route-cache

no snmp trap link-status

bridge-group 143

!

interface POS0.4

encapsulation dot1Q 144

no ip route-cache

no snmp trap link-status

bridge-group 144

!

interface POS0.5

description -

encapsulation dot1Q 140

no ip route-cache

no snmp trap link-status

bridge-group 140

!

interface POS1

description -

no ip address

no ip route-cache

crc 32

!

interface POS1.1

encapsulation dot1Q 121

no ip route-cache

no snmp trap link-status

bridge-group 121

!

interface POS1.2

encapsulation dot1Q 122

no ip route-cache

no snmp trap link-status

bridge-group 122

!

interface POS1.3

description -

encapsulation dot1Q 13

no ip route-cache

no snmp trap link-status

bridge-group 13

!

ip classless

no ip http server

!

!

!

!

control-plane

!

!

line con 0

line vty 0 4

password -

login

!

!

end


New Member

Re: Issue with cisco ONS 15310. Slot with Ethernet ports, design

B

Building configuration...

Current configuration : 3712 bytes

!

! Last configuration change at

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname B

!

boot-start-marker

boot-end-marker

!

enable password -

!

clock timezone -

ip subnet-zero

no ip domain-lookup

!

no mpls traffic-eng auto-bw timers frequency 0

!

bridge 100 protocol ieee

bridge 140 protocol ieee

bridge 141 protocol ieee

bridge 142 protocol ieee

bridge 143 protocol ieee

bridge 144 protocol ieee

!

!

interface Loopback0

ip address 192.x.0.x 255.255.255.255

!

interface FastEthernet0

description -

no ip address

mode dot1q-tunnel

bridge-group 140

bridge-group 140 spanning-disabled

!

interface FastEthernet1

description --- B0 ---

no ip address

mode dot1q-tunnel

bridge-group 141

bridge-group 141 spanning-disabled

!

interface FastEthernet2

description -

no ip address

mode dot1q-tunnel

bridge-group 142

bridge-group 142 spanning-disabled

!

interface FastEthernet3

description -

no ip address

mode dot1q-tunnel

bridge-group 143

bridge-group 143 spanning-disabled

!

interface FastEthernet4

description -

no ip address

mode dot1q-tunnel

bridge-group 144

bridge-group 144 spanning-disabled

!

interface FastEthernet5

no ip address

shutdown

!

interface FastEthernet6

no ip address

shutdown

!

interface FastEthernet7

description -

no ip address

shutdown

mode dot1q-tunnel

bridge-group 100

bridge-group 100 spanning-disabled

!

interface POS0

description -

no ip address

crc 32

!

interface POS0.1

encapsulation dot1Q 141

no snmp trap link-status

bridge-group 141

!

interface POS0.2

encapsulation dot1Q 142

no snmp trap link-status

bridge-group 142

!

interface POS0.3

encapsulation dot1Q 143

no snmp trap link-status

bridge-group 143

!

interface POS0.4

encapsulation dot1Q 144

no snmp trap link-status

bridge-group 144

!

interface POS0.5

description -

encapsulation dot1Q 140

no snmp trap link-status

bridge-group 140

!

interface POS1

no ip address

crc 32

!

interface POS1.1

encapsulation dot1Q 100

no snmp trap link-status

bridge-group 100

!

router ospf 100

log-adjacency-changes

network 192.x.0.x 0.0.0.0 area 0

!

ip default-gateway [x.x.x.x]

ip classless

no ip http server

!

!

snmp-server community public RO

snmp-server ifindex persist

snmp-server trap link ietf

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps tty

snmp-server enable traps config

snmp-server enable traps cpu threshold

snmp-server enable traps entity

snmp-server enable traps syslog

snmp-server enable traps hsrp

snmp-server enable traps config-copy

snmp-server enable traps bridge

snmp-server enable traps ospf state-change

snmp-server enable traps ospf errors

snmp-server enable traps ospf retransmit

snmp-server enable traps ospf lsa

snmp-server enable traps ospf cisco-specific state-change

snmp-server enable traps ospf cisco-specific errors

snmp-server enable traps ospf cisco-specific retransmit

snmp-server enable traps ospf cisco-specific lsa

snmp-server enable traps bgp

snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message

snmp-server enable traps ipmulticast

snmp-server enable traps rtr

snmp-server enable traps mpls traffic-eng

snmp-server enable traps mpls ldp

snmp-server enable traps rsvp

snmp-server enable traps l2tun session

snmp-server enable traps mpls vpn

snmp-server host x.x.x.x public

!

!

control-plane

!

!

line con 0

line vty 0 4

password -

logging synchronous level 4

login

!

!

end

New Member

Re: Issue with cisco ONS 15310. Slot with Ethernet ports, design

I'm assuming you are using ML-100T-8 cards - correct?

Yes.

It sounds like you might possibly have an issue with the VLAN or dot1q tunneling setup. Have you had a look at the configuration guides for the card (here)?

Can’t access the page.

Can you possibly post the IOS configuration from the ML-100T-8 cards at each end?

Yes.

I use interfaces FastEthernet1 on both sides.

Today I tried "no mode dot1q-tunnel" on these interfaces. Didn't help.

Hall of Fame Super Silver

Re: Issue with cisco ONS 15310. Slot with Ethernet ports, design

Sorry about the bad link - you should be able to use this customer link for the ML-100T-8 card:

http://www.cisco.com/en/US/customer/docs/optical/15000r9_1/ethernet/310/guide/31091_ether.html

Hmmm. I was going to suggest what you already tried - "no mode dot1q tunnel".

Having that mode on means the Ethernet interfaces on the ML-100T-8 are expecting your traffic to enter with VLAN tags. Please have a look at this guide:

http://www.cisco.com/en/US/docs/routers/7600/ios/12.2SR/configuration/guide/dot1qtnl.html

(The link is for a 7600 router guide but the concepts are applicable to IOS in general.)

You should make sure that you are tagging your traffic towards the ONS at both ends (that is, you are set up as a trunk port and using dot1q encapsulation: "switchport mode trunk" and "switchport trunk encapsulation dot1q" commands on your switches at each end) and that you are forcing the port towards the ONS to be in spanning tree forwarding mode ("spanning-tree portfast trunk" command).

New Member

Issue with cisco ONS 15310. Slot with Ethernet ports, designed f

Your advices were very very very very helpful! It looks more clear now.

Thanks! Thanks for helping me, I really appreciate such a support.


Hall of Fame Super Silver

Issue with cisco ONS 15310. Slot with Ethernet ports, designed f

You're welcome.

Please rate posts if they help.

1048
Views
0
Helpful
7
Replies
CreatePlease login to create content