Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

sfp module problem in 3560

Hi all,

I have two same switches: S1 - WS-C3560X-24P (ver. IOS 12.2 SE2).

I put them two identical SFP modules CISCO GLC-SX-MM SFBR-5766PZ. (inter gi1/1 or gi1/2)

I reset the factory settings.

I tried:

no shutdown

service unsupported-transceiver

but still (not connected or down)

When connecting media converters (DIGITUS) -  all works

Please help with the interface configuration step by step, because I lose my job.

**************************************************************************************************

Switch#sh logging

Syslog logging: enabled (0 messages dropped, 0 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)


No Active Message Discriminator.




No Inactive Message Discriminator.



Console logging: level debugging, 14 messages logged, xml disabled,

filtering disabled

Monitor logging: level debugging, 0 messages logged, xml disabled,

filtering disabled

Buffer logging: level debugging, 14 messages logged, xml disabled,

filtering disabled

Exception Logging: size (4096 bytes)

Count and timestamp logging messages: disabled

File logging: disabled

Persistent logging: disabled


No active filter modules.


Trap logging: level informational, 16 message lines logged


Log Buffer (4096 bytes):


*Mar 1 00:00:04.613: Read env variable - LICENSE_BOOT_LEVEL =

*Mar 1 00:00:07.054: %IOS_LICENSE_IMAGE_APPLICATION-6-LICENSE_LEVEL: Module name = c3560x Next reboot level = ipbase and License = ipbase

*Mar 1 00:00:52.957: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down

*Mar 1 00:00:54.702: %SPANTREE-5-EXTENDED_SYSID: Extended SysId enabled for type vlan

*Mar 1 00:00:58.695: %PLATFORM_ENV-6-FRU_PS_OIR: FRU Power Supply 1 inserted

*Mar 1 00:01:16.999: %SYS-5-RESTART: System restarted --

Cisco IOS Software, C3560E Software (C3560E-UNIVERSALK9-M), Version 12.2(55)SE3, RELEASE SOFTWARE (fc1)

Technical Support:

http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Thu 05-May-11 15:57 by prod_rel_team

*Mar 1 00:01:18.685: MKA-LLI: Failover Event

*Mar 1 00:01:19.222: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to down

*Mar 1 00:01:20.857: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to down

*Mar 1 00:01:21.444: %USB_CONSOLE-6-MEDIA_USB: Console media-type is USB.

*Mar 1 00:01:25.412: %PLATFORM-6-FRULINK_INSERTED: FRULink 10G ST module inserted.

*Mar 1 00:05:12.433: %SYS-5-CONFIG_I: Configured from console by console

*Mar 1 00:07:54.686: %SYS-5-CONFIG_I: Configured from console by console

*Mar 1 00:08:47.341: %SYS-5-CONFIG_I: Configured from console by console

Switch#

**********************************************************************

Switch#sh run

Building configuration...


Current configuration : 1504 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Switch

!

boot-start-marker

boot-end-marker

!

!

!

!

no aaa new-model

system mtu routing 1500

!

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

!

!

interface FastEthernet0

no ip address

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

!

interface GigabitEthernet0/8

!

interface GigabitEthernet0/9

!

interface GigabitEthernet0/10

!

interface GigabitEthernet0/11

!

interface GigabitEthernet0/12

!

interface GigabitEthernet0/13

!

interface GigabitEthernet0/14

!

interface GigabitEthernet0/15

!

interface GigabitEthernet0/16

!

interface GigabitEthernet0/17

!

interface GigabitEthernet0/18

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

!

interface GigabitEthernet0/24

!

interface GigabitEthernet1/1

!

interface GigabitEthernet1/2

!

interface GigabitEthernet1/3

!

interface GigabitEthernet1/4

!

interface TenGigabitEthernet1/1

!

interface TenGigabitEthernet1/2

!

interface Vlan1

no ip address

!

ip classless

ip http server

ip http secure-server

!

ip sla enable reaction-alerts

!

!

line con 0

line vty 5 15

!

end

************************************************************************

Switch#sh interfaces gig1/1

GigabitEthernet1/1 is down, line protocol is down (notconnect)

Hardware is Gigabit Ethernet, address is ccef.48a5.8419 (bia ccef.48a5.8419)

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Auto-duplex, Auto-speed, link type is auto, media type is 1000BaseSX SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts (0 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

Switch#

*************************************************************************

Switch#sh interface gig1/1 summary


*: interface is up

IHQ: pkts in input hold queue IQD: pkts dropped from input queue

OHQ: pkts in output hold queue OQD: pkts dropped from output queue

RXBS: rx rate (bits/sec) RXPS: rx rate (pkts/sec)

TXBS: tx rate (bits/sec) TXPS: tx rate (pkts/sec)

TRTL: throttle count


Interface IHQ IQD OHQ OQD RXBS RXPS TXBS TXPS TRTL

-------------------------------------------------------------------------

GigabitEthernet1/1 0 0 0 0 0 0 0 0 0

Switch#

*************************************************************************

Switch#sh interface gig1/1 counters errors


Port Align-Err FCS-Err Xmit-Err Rcv-Err UnderSize OutDiscards

Gi1/1 0 0 0 0 0 0


Port Single-Col Multi-Col Late-Col Excess-Col Carri-Sen Runts Giants

Gi1/1 0 0 0 0 0 0 0

Switch#

*************************************************************************

HELP?

4 REPLIES
New Member

sfp module problem in 3560

Hi Tomasz,

Follow the below steps:-

1) ensure that the module is detected in switch by show inventory

2) Ensure fiber link which is Mumltimode or single mode

3) Check red led in module as well as in fiber patch cord. both should be cross.

New Member

sfp module problem in 3560

Hi bharat chaudhari,

I follow Y steps:

1)

Switch#sh inventory

NAME: "1", DESCR: "WS-C3560X-24P"

PID: WS-C3560X-24P-S   , VID: V02  , SN: FDO1536V09D

NAME: "Power Supply 0", DESCR: "FRU Power Supply"

PID: C3KX-PWR-715WAC   , VID: V01  , SN: LIT152903B9

NAME: "FRULink Slot 1 - FRULink Module", DESCR: "FRULink 10G ST Module"

PID: C3KX-NM-10G       , VID: V01  , SN: FDO15331HK8

NAME: "GigabitEthernet1/4", DESCR: "1000BaseSX SFP"

PID: Unspecified       , VID:      , SN: AGM12301ECP

and

Switch#sh inter gi1/4 capabilities

GigabitEthernet1/4

  Model:                 WS-C3560X-24P

  Type:                  1000BaseSX SFP

  Speed:                 1000

  Duplex:                full

  Trunk encap. type:     802.1Q,ISL

  Trunk mode:            on,off,desirable,nonegotiate

  Channel:               yes

  Broadcast suppression: percentage(0-100)

  Flowcontrol:           rx-(off,on,desired),tx-(none)

  Fast Start:            yes

  QoS scheduling:        rx-(not configurable on per port basis),

                         tx-(4q3t) (3t: Two configurable values and one fixed.)

  CoS rewrite:           yes

  ToS rewrite:           yes

  UDLD:                  yes

  Inline power:          no

  SPAN:                  source/destination

  PortSecure:            yes

  Dot1x:                 yes

I have multimode fiber link.

On C3KX-NM-10G Network module leds always off (no reactions on plug in SFP module).

I check fiber patch cord on croos and no cross - no diffrent - no alive.

At the end sh runn

Switch#sh runn

Building configuration...

Current configuration : 1652 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service unsupported-transceiver

!

hostname Switch

!

boot-start-marker

boot-end-marker

!

no aaa new-model

system mtu routing 1500

!

spanning-tree mode pvst

spanning-tree extend system-id

!

no errdisable detect cause gbic-invalid

!

vlan internal allocation policy ascending

!

interface FastEthernet0

no ip address

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

!

interface GigabitEthernet0/8

!

interface GigabitEthernet0/9

!

interface GigabitEthernet0/10

!

interface GigabitEthernet0/11

!

interface GigabitEthernet0/12

!

interface GigabitEthernet0/13

!

interface GigabitEthernet0/14

!

interface GigabitEthernet0/15

!

interface GigabitEthernet0/16

!

interface GigabitEthernet0/17

!

interface GigabitEthernet0/18

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

!

interface GigabitEthernet0/24

!

interface GigabitEthernet1/1

speed nonegotiate

!

interface GigabitEthernet1/2

speed nonegotiate

!

interface GigabitEthernet1/3

speed nonegotiate

!

interface GigabitEthernet1/4

speed nonegotiate

!

interface TenGigabitEthernet1/1

!

interface TenGigabitEthernet1/2

!

interface Vlan1

no ip address

!

ip classless

ip http server

ip http secure-server

!

ip sla enable reaction-alerts

!

line con 0

line vty 5 15

!

end

help?

Hall of Fame Super Gold

sfp module problem in 3560

service unsupported-transceiver

Why do you have this command for?

I have two same switches: S1 - WS-C3560X-24P (ver. IOS 12.2 SE2)

This is useless information.  What is EXACTLY your IOS version?

Post the complete output to the command "sh idp interface G1/4".

New Member

sfp module problem in 3560

Hi Leo Laohoo,

service unsupported-transceiver

This command someone tell mi to check,

Two switches connected the short optical fiber. One port is up. The second is still down. I have two identical configurations (switch) except vlan1 192.168.0.1 and 192.168.0.2

shutdown / no shutdown does not help.

I have sh ver and idp.

********************************************************

Switch#sh ver

Cisco IOS Software, C3560E Software (C3560E-UNIVERSALK9-M), Version 12.2(55)SE3, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Thu 05-May-11 15:57 by prod_rel_team

Image text-base: 0x00003000, data-base: 0x02800000

ROM: Bootstrap program is C3560E boot loader

BOOTLDR: C3560E Boot Loader (C3560X-HBOOT-M) Version 12.2(53r)SE2, RELEASE SOFTWARE (fc1)

Switch uptime is 1 hour, 0 minutes

System returned to ROM by power-on

System image file is "flash:/c3560e-universalk9-mz.122-55.SE3/c3560e-universalk9-mz.122-55.SE3.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

License Level: ipbase

License Type: Permanent

Next reload license Level: ipbase

cisco WS-C3560X-24P (PowerPC405) processor (revision B0) with 262144K bytes of memory.

Processor board ID FDO1536V09D

Last reset from power-on

1 Virtual Ethernet interface

1 FastEthernet interface

28 Gigabit Ethernet interfaces

2 Ten Gigabit Ethernet interfaces

The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address       : CC:EF:48:A5:84:00

Motherboard assembly number     : 73-12555-05

Motherboard serial number       : FDO15361GBA

Model revision number           : B0

Motherboard revision number     : D0

Model number                    : WS-C3560X-24P-S

Daughterboard assembly number   : 800-32786-01

Daughterboard serial number     : FDO15360C3Q

System serial number            : FDO1536V09D

Top Assembly Part Number        : 800-31329-02

Top Assembly Revision Number    : E0

Version ID                      : V02

CLEI Code Number                : COMJS00ARB

Hardware Board Revision Number  : 0x03

Switch Ports Model              SW Version            SW Image

------ ----- -----              ----------            ----------

*    1 30    WS-C3560X-24P      12.2(55)SE3           C3560E-UNIVERSALK9-M

Configuration register is 0xF

**************************************************************************************************************

Switch#sh idp inter gig1/1

General SFP Information

-----------------------------------------------

Identifier            :   0x03

Connector             :   0x07

Transceiver           :   0x00 0x00 0x00 0x01 0x00 0x00 0x00 0x00

Encoding              :   0x01

BR_Nominal            :   0x0D

Vendor Name           :   CISCO-AVAGO

Vendor Part Number    :   SFBR-5766PZ

Vendor Revision       :   0x20 0x20 0x20 0x20

Vendor Serial Number  :   AGM12301ECP

-----------------------------------------------

Other Information

-------------------------------------------------------

Port asic num         : 00

Port asic port num    : 06

SFP presence index    : 00

SFP iter cnt          : 27272

SFP failed oper flag  : 0x00000000

IIC error cnt         : 0

IIC error dsb cnt     : 0

IIC max sts cnt       : 6

Chk for link status   : 01

Link status           : 01

Autoneg enable        : 00

Flow control Pause    : 00

Flow control asymPause: 00

Duplex mode           : 00

PcsInfo               : 0x05331AA0

MacInfo               : 0x05331A88 0x05331A80

AutoNeg               : 0x05331A80 0x05331A88

Sfp selection asic reg map

--------------------------------

stbi                 : 0x00

sfpControl           : 0x4E

Regs Loc             : 0xF0000000

--------------------------------

miscStatus

   rps300Stat1      1

   rps300Stat2      1

   rps300Present    1

   modeSwitchActive 0

stackPhyControl

   sPhyLoopback     0

   sPhyALock1       1

   sPhyALock0       1

   sPhyBLock1       0

   sPhyBLock0       1

stackCable

   cableIdA_1       0

   cableIdA_0       1

   eqSelectA_1       0

   eqSelectA_0       0

   cableIdB_1       0

   cableIdB_0       1

   eqSelectB_1       0

   eqSelectB_0       0

SFF-8472 MSA EEPROM Data

===========================================

000 :  03 04 07 00 00 00 01 00 00 00

010 :  00 01 0D 00 00 00 37 1B 00 00

020 :  43 49 53 43 4F 2D 41 56 41 47

030 :  4F 20 20 20 20 20 00 00 17 6A

040 :  53 46 42 52 2D 35 37 36 36 50

050 :  5A 20 20 20 20 20 20 20 20 20

060 :  03 52 00 ED 00 1A 00 00 41 47

070 :  4D 31 32 33 30 31 45 43 50 20

080 :  20 20 20 20 30 38 30 37 32 35

090 :  20 20 00 00 00 D4 00 00 06 7A

100 :  4B 2E 0B FD CD 98 5B DC 1F 04

110 :  8A 29 51 74 86 00 00 00 00 00

120 :  00 00 00 00 F2 43 EA C0

YETI INTERNAL REGS

-----------------------------------------------

Location=0xD8000500     :  Value=0x00

Location=0xD8000501     :  Value=0x00

Location=0xD8000502     :  Value=0x00

Location=0xD8000503     :  Value=0x00

Location=0xD8000504     :  Value=0x00

Location=0xD8000505     :  Value=0x00

Location=0xD8000506     :  Value=0x00

Location=0xD8000507     :  Value=0x02

Location=0xD8000508     :  Value=0x00

Location=0xD8000509     :  Value=0x40

Location=0xD800050A     :  Value=0x00

Location=0xD800050B     :  Value=0x00

Location=0xD800050C     :  Value=0x05

Location=0xD800050D     :  Value=0x00

Location=0xD800050E     :  Value=0x01

Location=0xD800050F     :  Value=0x00

Location=0xD8000510     :  Value=0x0F

yetiIICinited           :  Value=0x00000001

yetiIICLockPassCnt      :  Value=0

yetiIICLockFailCnt      :  Value=0

yetiIICLockApp          :  Value=35

-----------------------------------------------

*****************************************************************************************************************************

Switch#sh runn

Building configuration...

Current configuration : 3300 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service unsupported-transceiver

!

hostname Switch

!

boot-start-marker

boot-end-marker

!

!

!

!

no aaa new-model

system mtu routing 1500

!

!

!

!

crypto pki trustpoint TP-self-signed-1218806784

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1218806784

revocation-check none

rsakeypair TP-self-signed-1218806784

!

!

crypto pki certificate chain TP-self-signed-1218806784

certificate self-signed 01

  3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31323138 38303637 3834301E 170D3933 30333031 30303031

  32325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32313838

  30363738 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100C88C EF241877 24B0441E BDDC8A90 A6505A21 35F3C17F A62FEB85 04940363

  C3201331 DDA767FF F78AE7BC 7EA326B3 FDC0385E E871E1E8 29D0C912 5EFEBB1C

  4EB7AA24 611D8C75 9AF5F288 1A3C8F90 B7D2470B 71B47E9C 9849A1E8 636C9B32

  DEDE8112 7D1391EC B12D6ED1 F24A4C61 69D8DF1F FCBAA3EF 6D6DCDEB A767DAB1

  5F150203 010001A3 67306530 0F060355 1D130101 FF040530 030101FF 30120603

  551D1104 0B300982 07537769 7463682E 301F0603 551D2304 18301680 1471FECC

  C14AB1D2 6B947571 8A54621A D16FBD39 8F301D06 03551D0E 04160414 71FECCC1

  4AB1D26B 9475718A 54621AD1 6FBD398F 300D0609 2A864886 F70D0101 04050003

  81810036 07E4C958 BC358C2A 934C8EC8 83EEF5AC 3CFE7A96 E7FC54DE A9216FE9

  11986898 3D3A9663 E516A971 68FA225C C387C12D 77606551 50FBAD91 31A5C3FE

  70EACE07 021EBEAD 4072AA28 C80CD3A3 C9A73C52 4B0F121D 42A82FB8 02B3CDB1

  B91C0CDC F2DF8079 37CE197B E4335AF3 3EB1D5CF D37D12F6 7DB18CE2 C2CE5B9F 215F6C

  quit

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

no errdisable detect cause gbic-invalid

!

vlan internal allocation policy ascending

!

!

!

interface FastEthernet0

no ip address

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

!

interface GigabitEthernet0/8

!

interface GigabitEthernet0/9

!

interface GigabitEthernet0/10

!

interface GigabitEthernet0/11

!

interface GigabitEthernet0/12

!

interface GigabitEthernet0/13

!

interface GigabitEthernet0/14

!

interface GigabitEthernet0/15

!

interface GigabitEthernet0/16

!

interface GigabitEthernet0/17

!

interface GigabitEthernet0/18

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

!

interface GigabitEthernet0/24

!

interface GigabitEthernet1/1

speed nonegotiate

!

interface GigabitEthernet1/2

speed nonegotiate

!

interface GigabitEthernet1/3

!

interface GigabitEthernet1/4

!

interface TenGigabitEthernet1/1

!

interface TenGigabitEthernet1/2

!

interface Vlan1

ip address 192.168.0.1 255.255.255.0

!

ip classless

ip http server

ip http secure-server

!

ip sla enable reaction-alerts

!

!

line con 0

line vty 0 4

login

line vty 5 15

login

!

end

******************************************************************************************************************************

11351
Views
0
Helpful
4
Replies