Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

1750 VoIP Delays

Have a 1750 VoIP network, IOS"flash:c1700-sv3y-mz_121-5_T7.bin", Star Topology, 128k Links to Corporate and 784k at central site.

Voice Cuts offs eventually, but Only from one office to the rest.

Pings goes from 60 to 200 ms during voice problems.

No CRC,Discards at Serial level

I see this at SH Fram pvc XX command

(at every pvc at central and remote)

Output queue size 1/max total 600/drops 11043

fragment type end-to-end fragment size 160

cir 128000 bc 1280 be 0 limit 160 interval 10

mincir 128000 byte increment 160 BECN response no

frags 16033183 bytes 769770152

frags delayed 16033183 bytes delayed 769770152

Why every traffic is on delayed? Even when there is no FastEth traffic.

How can a avoid it?

Config at remote

interface FastEthernet0

description connected to 192.168.35.0

ip address 192.168.35.1 255.255.255.0

speed 10

no cdp enable

!

interface Serial0

bandwidth 256

backup delay 10 30

backup interface Async5

no ip address

encapsulation frame-relay

no ip mroute-cache

load-interval 30

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial0.1 point-to-point

description connected to CV_CANCUN

bandwidth 256

ip unnumbered FastEthernet0

no ip mroute-cache

no cdp enable

frame-relay interface-dlci 28

class VoIP-128Kbs

frame-relay ip rtp header-compression

!

!

map-class frame-relay VoIP-128Kbs

frame-relay cir 128000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 128000

no frame-relay adaptive-shaping

frame-relay fair-queue

frame-relay fragment 160

!

!

voice-port 1/0

operation 4-wire

type 2

signal immediate

!

!

dial-peer voice 80 voip

destination-pattern 80....

session target ipv4:192.168.1.2

dtmf-relay cisco-rtp

ip precedence 5

!

Config at Central

!

interface Serial0/0

description Connected to E1 Link to CCI-Mx (Cancun POP)

bandwidth 2048

no ip address

encapsulation frame-relay

no ip mroute-cache

load-interval 30

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

!

interface Serial0/0.6 point-to-point

description connected to AR_COZUMEL

bandwidth 256

ip unnumbered FastEthernet0/0

no ip mroute-cache

no cdp enable

frame-relay interface-dlci 28

class VoIP-128Kbs

frame-relay ip rtp header-compression

!

!

map-class frame-relay VoIP-512Kbs

no frame-relay adaptive-shaping

frame-relay cir 512000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 512000

frame-relay fair-queue

frame-relay fragment 160

!

!

map-class frame-relay VoIP-128Kbs

no frame-relay adaptive-shaping

frame-relay cir 128000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 128000

frame-relay fair-queue

frame-relay fragment 160

!

dial-peer voice 80 voip

destination-pattern 80....

session target ipv4:192.168.1.2

dtmf-relay cisco-rtp

ip precedence 5

!

2 REPLIES
Community Member

Re: 1750 VoIP Delays

Looks like your traffic shaping parameters are set up ok on your remote. One issue I see here is that you have no methodology of setting up Queues to service the voice traffic first. If you're showing fragmentation on the frame-relay interface and packets being delayed, there is definetely traffic on it.

My suggestion therefore would be to

1) put voice in a LLQ so it can be serviced before the data, you can treat the other data in 1 queue if you want.

2) put a sniffer on the E1 to dettermine what this other traffic is that you say is not there.

Check for implementing QOS design guide on CCO. Also, check out LLQ. If you have trouble, post a reply and I will send you a sample.

One other thing, Hopefully you're not oversubscribing the CIR at the host side or the remote. The traffic shaping at the remote indicates 128k cir which is fine but you also say that you have a 768 pipe at the host.

I see that Cancun is interface .6 and that you have a frame-relay map class for 512 as well. If so, 2 interfaces essentially one at 512 and the other at 128k would eat up your CIR of 768 at any given time so if you have more remotes, that could be an issue as well.

Community Member

Re: 1750 VoIP Delays

Could you please send me a sample of QoS and LLQ ..?

Regards

LN

100
Views
0
Helpful
2
Replies
CreatePlease to create content