Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

26XX and36XX MGCP Configuration

Does anyone have a sample configuration for setting up a 2600 or 3600 as an MGCP gateway?

10 REPLIES
New Member

Re: 26XX and36XX MGCP Configuration

I don't believe the 2600's or 3600's run MGCP yet. They may in some version of 12.1. Here is a sample from a VG200:

[OK]

VG200-IMCBP-GW1#term len 0

VG200-IMCBP-GW1#sh run

Building configuration...

Current configuration:

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname VG200-IMCBP-GW1

!

enable secret 5 $1$o1cZ$rbWB4yjTm29aEfooZypat.

!

!

!

!

!

ip subnet-zero

no ip domain-lookup

!

mgcp

mgcp call-agent 10.10.19.19

mgcp dtmf-relay codec all mode out-of-band

mgcp sdp simple

mgcp ip-tos precedence 5

mgcp default-package hs-package

!

!

!

!

ccm-manager switchback graceful

ccm-manager redundant-host 10.10.19.18

ccm-manager mgcp

!

!

!

interface FastEthernet0/0

ip address 10.40.4.15 255.255.255.0

shutdown

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.40.4.1

no ip http server

!

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

!

voice-port 1/1/1

!

dial-peer voice 1 pots

application MGCPAPP

port 1/0/0

!

dial-peer voice 2 pots

application MGCPAPP

port 1/0/1

!

dial-peer voice 3 pots

application MGCPAPP

port 1/1/0

!

dial-peer voice 4 pots

application MGCPAPP

port 1/1/1

!

!

line con 0

password 7 020856551D12

logging synchronous

login

transport input none

line aux 0

line vty 0 4

password 7 11074B0B0106

login

!

no scheduler allocate

end

New Member

Re: 26XX and36XX MGCP Configuration

Thanks for the info although I have 12.1 (5)T on a 2600 with Call Manager 3.1 (5a). The 2600 has all the MGCP commands listed, I've just never seen them before and the Cisco web site doesn't have anything on it yet for the 26XX or 36XX.

Anonymous
N/A

Re: 26XX and36XX MGCP Configuration

The 2600 and 3600 does support MGCP (version 0.1). IOS 12.1.5T (the one you have) has support for MGCP.

See foll URL for more info. (command reference and configs ...

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t3/mgcp1213.htm

-anand

New Member

Re: 26XX and36XX MGCP Configuration

Thanks. This is exactly what I was looking for.

New Member

Re: 26XX and36XX MGCP Configuration

I'm trying to do the same but when entering the line item application MGCPAPP it does not register in upper case and I was told that this is crucial.

The router is registering with the CM but when I dial 9 to grab a line I get fast busy.

Cisco Employee

Re: 26XX and36XX MGCP Configuration

Entering application MGCPAPP in all upper case is not necessary... there was a minor parser bug in an early release of software. The problem is more likely in the MGCP registration.

If you do a show ccm on the router, I believe the first or second line of output will tell you the MGCP Domain Name. This is made up of the router hostname and router domain-name from the IOS config. Whatever this says, even if it's not in DNS, that's exactly what it needs to say for the MGCP Domain Name in the device configuration for the gateway on the CallManager. Make sure it's the same, reset the device in CallManager, and reload the router if possible.

If it's still not working, open a TAC case and be prepared to send:

- output of show running

- output of show version

- output of show ccm

- output of debug mgcp packet

- CCM trace file from the CallManager with Detailed tracing enabled.

New Member

Re: 26XX and36XX MGCP Configuration

thanks man - that did the trick!

Much appreciated.

Paul.

New Member

Re: 26XX and36XX MGCP Configuration

I am having trouble with MGCP on a 3640 running 12.1.5T(7). The cmm-manager command is not available. Do I have the right IOS??

Here is my config

RT1_MMT_BNE#sh run

Building configuration...

Current configuration : 2650 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname RT1_MMT_BNE

!

logging rate-limit console 10 except errors

enable password cisco

!

voice-card 1

!

ip subnet-zero

ip cef

!

!

no ip finger

no ip domain-lookup

ip dhcp excluded-address 192.168.100.1 192.168.100.49

!

ip dhcp pool 1

network 192.168.100.0 255.255.255.0

option 150 ip 192.168.100.10

default-router 192.168.100.1

!

mgcp

mgcp call-agent 192.168.100.10

isdn switch-type primary-net5

isdn voice-call-failure 3

isdn alert-end-to-end

call rsvp-sync

no voice hunt unassigned-number

no voice hunt invalid-number

voice rtp send-recv

!

voice service voip

h323 call start fast

!

voice class codec 100

codec preference 1 g711ulaw

codec preference 3 g729r8

!

!

!

!

!

!

!

controller E1 1/0

framing CRC4 Australia

pri-group timeslots 1-10,16

!

translation-rule 1

Rule 1 ^0.% 000

Rule 2 ^2.% 002

Rule 3 ^3.% 003

Rule 4 ^4.% 004

Rule 5 ^6.% 006

Rule 6 ^7.% 007

Rule 7 ^9.% 009

!

translation-rule 2

Rule 1 ^9.% 32909

!

!

interface Loopback0

no ip address

!

interface FastEthernet0/0

description MTE_BNE LAN

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.1

description Managment vlan

encapsulation isl 1

ip address 192.168.10.1 255.255.255.0

no ip redirects

!

interface FastEthernet0/0.2

description Voice Vlan

encapsulation isl 100

ip address 192.9.100.101 255.255.255.0

no ip redirects

!

interface FastEthernet0/0.3

description Voice Vlan

encapsulation isl 200

ip address 192.168.100.1 255.255.255.0

no ip redirects

!

interface Serial1/0:15

no ip address

no ip route-cache cef

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.9.100.254

no ip http server

!

!

voice-port 1/0:15

cptone NZ

timeouts interdigit 2

music-threshold -48

!

voice-port 2/0/0

!

voice-port 2/0/1

!

voice-port 2/1/0

!

voice-port 2/1/1

!

dial-peer cor custom

!

!

!

dial-peer voice 100 pots

destination-pattern 0

progress_ind alert enable 1

progress_ind connect enable 1

translate-outgoing calling 2

direct-inward-dial

port 1/0:15

!

dial-peer voice 200 voip

destination-pattern 9

voice-class codec 100

session target ipv4:192.168.100.10

dtmf-relay h245-alphanumeric

ip precedence 5

no vad

!

dial-peer voice 300 pots

application mgcpapp

port 2/0/0

!

dial-peer voice 301 pots

application mgcpapp

port 2/0/1

!

dial-peer voice 302 pots

application mgcpapp

port 2/1/1

!

!

line con 0

transport input none

line aux 0

line vty 0 4

password cisco

login

!

end

RT1_MMT_BNE# sh ver

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3640-IS-M), Version 12.1(5)T7, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/cgi-bin/ibld/view.pl?i=support

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Mon 16-Apr-01 20:24 by ccai

Image text-base: 0x60008950, data-base: 0x61142000

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

ROM: 3600 Software (C3640-IS-M), Version 12.1(5)T7, RELEASE SOFTWARE (fc1)

RT1_MMT_BNE uptime is 2 hours, 8 minutes

System returned to ROM by reload

System image file is "flash:c3640-is-mz.121-5.T7.bin"

cisco 3640 (R4700) processor (revision 0x00) with 124928K/6144K bytes of memory.

Processor board ID 25117033

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

Channelized E1, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

Primary Rate ISDN software, Version 1.1.

1 FastEthernet/IEEE 802.3 interface(s)

11 Serial network interface(s)

1 Channelized E1/PRI port(s)

2 Voice FXO interface(s)

2 Voice FXS interface(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

RT1_MMT_BNE#

Regards

Darren

New Member

Re: 26XX and36XX MGCP Configuration

I offer no help as I am having the same problem.....I am very interested in the solution..Maybe Dave from Cisco can help here?

New Member

Re: 26XX and36XX MGCP Configuration

You need 12.1.5.XM2 it then supports the ccm-manager command and all starts working!!!

Rgds

Darren

211
Views
0
Helpful
10
Replies
CreatePlease to create content