Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

2950 and IP phones...No connectivity for PC's

Phones work...PC's don't....Any ideas? I add the PC to a static access port and I can ping everything. Same config on a 3550-24 works fine...weird....Oh, and the "switchport trunk encap dot1q" command is NOT available on this platform...even more weird....

Switch To Phone:

interface FastEthernet0/1

description IP phone and PC

switchport trunk native vlan 7

switchport mode trunk

switchport voice vlan 17

switchport priority extend cos 5

no ip address

!

Switch trunk to router:

interface FastEthernet0/12

description Trunk to 1760 router

switchport trunk native vlan 7

switchport mode trunk

no ip address

Router interface:

!

interface FastEthernet0/0

no ip address

speed auto

!

interface FastEthernet0/0.7

encapsulation dot1Q 7 native

ip address 192.168.7.254 255.255.255.0

!

interface FastEthernet0/0.17

encapsulation dot1Q 17

ip address 192.168.17.254 255.255.255.0

!

2 REPLIES
New Member

Re: 2950 and IP phones...No connectivity for PC's

Auto negotiation is junk on these switches. Hardcode 100/full and you'll be working fine.

New Member

Re: 2950 and IP phones...No connectivity for PC's

Try adding switchport access vlan 7 (in your case) to the ports as well and this should fix your issues if you still have them. I had similar issues and this resolved my problems by setting both the native and the access VLAN to be the same. If you have PC's that you setup trunking on in software, the access vlan 7 is not necessary. If you are using your PC's as just that, static access, you will need to add this command if I am not mistaken.

Please someone correct me if I am wrong.

Matt

113
Views
0
Helpful
2
Replies
CreatePlease to create content