Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

3 of 4 calls lost

I have a VG200 with a callmanager 3.2 (2) SPG the vg200 is configured with a 4 channel T1-CAS (inbound only) when anyone calls only 1 in 4 calls is actually made it seems to be a cycle example.: good , bad, bad, bad, good , bad, bad, bad. and so forth. I can post configs if need be (I am kinda new to this so go easy on me)

9 REPLIES
Bronze

Re: 3 of 4 calls lost

Please post your configs (without passwords please) so we can have a look and make sure that your channel-groups are setup appropriately.

Rick

New Member

Re: 3 of 4 calls lost

here is my show run

Current configuration : 1349 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname pecos

!

enable secret 5 (removed!)

voice-card 1

!

ip subnet-zero

no ip domain lookup

!

!

!

voice call carrier capacity active

voice rtp send-recv

!

!

!

!

!

!

!

!

!

!

controller T1 1/0

framing esf

linecode b8zs

cablelength short 133

ds0-group 0 timeslots 1-12 type e&m-wink-start

!

!

interface FastEthernet0/0

ip address 168.215.178.19 255.255.248.0

no ip mroute-cache

speed 10

full-duplex

no cdp enable

h323-gateway voip bind srcaddr 168.215.178.19

!

ip classless

ip route 0.0.0.0 0.0.0.0 168.215.183.254

no ip http server

ip pim bidir-enable

!

!

no cdp run

snmp-server community ********** RO

snmp-server community *********** RW

snmp-server enable traps tty

call rsvp-sync

!

voice-port 1/0:0

connection plar 1200

!

!

mgcp profile default

!

dial-peer voice 1 pots

destination-pattern 1...

port 1/0:0

!

!

dial-peer voice 2 voip

incoming called-number 9

destination-pattern 1...

progress_ind setup enable 3

session target ipv4:168.215.178.18

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 3 pots

destination-pattern 9T

port 1/0:0

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password ******

login

!

end

and here is show ver

Cisco Internetwork Operating System Software

IOS (tm) VG200 Software (VG200-I6S-M), Version 12.2(11)T3, RELEASE SOFTWARE (fc

2)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sun 22-Dec-02 12:22 by ccai

Image text-base: 0x800080B4, data-base: 0x80BD2938

ROM: System Bootstrap, Version 12.1(1r) [phanguye 1r], RELEASE SOFTWARE (fc1)

pecos uptime is 21 minutes

System returned to ROM by reload

System image file is "flash:vg200-i6s-mz.122-11.T3.bin"

cisco VG200 (MPC860) processor (revision 0x102) with 26624K/6144K bytes of memor

y.

Processor board ID JAB05080QQK (0)

M860 processor: part number 0, mask 49

Primary Rate ISDN software, Version 1.1.

1 FastEthernet/IEEE 802.3 interface(s)

1 Channelized T1/PRI port(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

If you need anything else just ask (this is a 4 channel T1-cas)

Re: 3 of 4 calls lost

Can you do a 'test dsp 1' then option 1 . which DSPs are ALIVE? They all should be alive. You can further do a 'show voice dsp' or 'test dsp 1' (option 2) to see what dsp id's each voice-port/timeslot is tied to. When you place calls do a 'show voice call summ' and on the bad calls maybe they are hitting a common dsp id.

Do you have any errors in the log or across the console on the bad calls?

Did the bad calls used to work then stop working with no changes?

Just some things to get started...to see if it may be a DSP issue of some sort.

New Member

Re: 3 of 4 calls lost

pecos#test dsp 1

Section:

1 - Query dsp resource and status

2 - Display voice port's dsp channel status

3 - Print dsp data structure info

4 - Change dsprm test Flags

5 - Modify dsp-tdm connection

6 - Disable DSP Background Status Query

7 - Enable DSP Background Status Query

8 - Enable DSP control message history

9 - Disable DSP control message history

q - Quit

Select option : 1

Dsp firmware version: 4.0.26

Maximum dsp count: 15

On board dsp count: 3

Jukebox available

Total dsp channels available 12

Total dsp channels allocated 12

Total dsp free channels 0

Quering dsp status......

3 - Print dsp data structure info

4 - Change dsprm test Flags

5 - Modify dsp-tdm connection

6 - Disable DSP Background Status Query

7 - Enable DSP Background Status Query

8 - Enable DSP control message history

9 - Disable DSP control message history

q - Quit

Select option : 2

Voice port 1/0:0 has 12 time slots

time slot 1: dsp_id=12, signal_channel=128(OPEN), voice_channel=0(IDLE)

time slot 2: dsp_id=13, signal_channel=128(OPEN), voice_channel=0(IDLE)

time slot 3: dsp_id=14, signal_channel=128(OPEN), voice_channel=0(IDLE)

time slot 4: dsp_id=12, signal_channel=129(OPEN), voice_channel=1(IDLE)

time slot 5: dsp_id=13, signal_channel=129(OPEN), voice_channel=1(IDLE)

time slot 6: dsp_id=14, signal_channel=129(OPEN), voice_channel=1(IDLE)

time slot 7: dsp_id=12, signal_channel=130(OPEN), voice_channel=2(IDLE)

time slot 8: dsp_id=13, signal_channel=130(OPEN), voice_channel=2(IDLE)

time slot 9: dsp_id=14, signal_channel=130(OPEN), voice_channel=2(IDLE)

time slot 10: dsp_id=12, signal_channel=131(OPEN), voice_channel=3(IDLE)

time slot 11: dsp_id=13, signal_channel=131(OPEN), voice_channel=3(IDLE)

time slot 12: dsp_id=14, signal_channel=131(OPEN), voice_channel=3(IDLE)

here is a "good call"

Voice port 1/0:0 has 12 time slots

time slot 1: dsp_id=12, signal_channel=128(OPEN), voice_channel=0(ACTIVE)

time slot 2: dsp_id=13, signal_channel=128(OPEN), voice_channel=0(IDLE)

time slot 3: dsp_id=14, signal_channel=128(OPEN), voice_channel=0(IDLE)

time slot 4: dsp_id=12, signal_channel=129(OPEN), voice_channel=1(IDLE)

time slot 5: dsp_id=13, signal_channel=129(OPEN), voice_channel=1(IDLE)

time slot 6: dsp_id=14, signal_channel=129(OPEN), voice_channel=1(IDLE)

time slot 7: dsp_id=12, signal_channel=130(OPEN), voice_channel=2(IDLE)

time slot 8: dsp_id=13, signal_channel=130(OPEN), voice_channel=2(IDLE)

time slot 9: dsp_id=14, signal_channel=130(OPEN), voice_channel=2(IDLE)

time slot 10: dsp_id=12, signal_channel=131(OPEN), voice_channel=3(IDLE)

time slot 11: dsp_id=13, signal_channel=131(OPEN), voice_channel=3(IDLE)

time slot 12: dsp_id=14, signal_channel=131(OPEN), voice_channel=3(IDLE)

well all seems to be workking well when i forward the calls to a unity port?????? will test during business hours to see if issues exists

New Member

Re: 3 of 4 calls lost

ok unforwarded from unity and forwarded to a shared extension of 1001

DSP's all show "idle" on a call that doesn't ring through. is this a telco issue? I don't have a console cable to it at this time but can get one on it if necessary

Re: 3 of 4 calls lost

What is the T1 controller connecting to?

Try to place many calls at once, and do the command above repeatedly to see what ports and DSP ids are reporting ACTIVE on working calls and see if the bad calls follow a pattern (same dsp ID, same channel, etc never going active). For option 1, you need to 'term mon' to see console output to telnet session. also see if you have any errors in your router log.

Cisco Employee

Re: 3 of 4 calls lost

Hi Ryan,

I wonder why the controller is configured for 12 channels if the telco provisioned only 4 for inbound.

A "sh voice dsp" will show you ds0-dsp mapping, which should yield some hints on what channels are being used for the "good" calls, and therefore whether any patterns exists.

-ben

New Member

Re: 3 of 4 calls lost

now all calls are show on the DSP's but NONE of them are passed on to the Callmanager. there are no errors when i perform a term mon and call. it no appears thant the information is simply not being passed between the VG200 and the callmanager. (and they can ping each other) Same with timeslots set to 1-4

New Member

Re: 3 of 4 calls lost

RESOLVED! the connection plar 1200 had been removed when i shutdown the voice port to set up the ds0-group under the T1 controller...added and all is well...btw the true resolution was ...it was a telco issue...however i GREATLY appriecate all the troubleshooting you assisted me with.

144
Views
0
Helpful
9
Replies
CreatePlease to create content