Cisco Support Community
Cisco Employee

3524XL and voice vlans

What am I doing wrong? I have two Vlans, (120 - Office PC's) (125 - Office Phones)

I have an office of 7960 Phones. I would like the PC port on the phone to be Set to vlan 120 and the phone obviously to talk on vlan 125.

I have tried the following commands the phone never registers or works. Set the switch port to straight vlan 125 and the phone registers right up.

>int f0/6

>switchport voice vlan 125

>switchport access vlan 120

What is wrong with this?

Community Member

Re: 3524XL and voice vlans

Assuming the basics - you have separate subnets on vlans 120 and 125 with routing between them. You also have the DHCP scopes for both vlans set up correctly with the router and option 150 set on both and CallManger on the appropriate vlan/IP subnet - logically it should be 125

I believe the correct set up should be, with the IP phone beinga switch in its own right runing 802.1q:

interface fa 0/6

switchport trunk encap dot1q

switchport mode trunk

switchport access vlan 120

switchport voice vlan 125

Cisco Employee

Re: 3524XL and voice vlans

interface FastEthernet0/2

 switchport trunk encapsulation dot1q

 switchport trunk native vlan 120

 switchport mode trunk

 switchport voice vlan 125

CreatePlease to create content