Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

6509 msfc qos

Have 6509 msfc2 at the core and 2651 at the remote. Have qos service policy at core and remote. Output of show policy interface at remote shows traffic meeting policy criteria and being prioritized. Output at core shows no matching traffic. Can you utilize matching traffic based on dscp and ef values on 6509, or is there another method to prioritize this traffic at the core so that each end of the link is giving the voice traffic the priority over the data traffic?

  • Other Collaboration Voice and Video Subjects
4 REPLIES
Cisco Employee

Re: 6509 msfc qos

What does the QoS on the 6500 look like? Have you configured it on the MSFC or the Supervisor? Note that if you configured it on the MSFC, it does not mean anything as not every packet hits the MSFC(due to MLS/CEF). Refer to the following page for QoS guidelines

http://www.cisco.com/warp/public/473/#LANqos

http://cio.cisco.com/univercd/cc/td/doc/product/lan/cat6000/sw_6_3/confg_gd/qos.htm

New Member

Re: 6509 msfc qos

The service policy is bound to the multilink interfaces. There are route-maps on the vlan interfaces on the msfc that match traffic patterns and set their precedence values. There is a service policy bound to the multilink interfaces with class-maps that reference acls that classify the priority of the traffic across the wan based on the precendence matched on the acl. The configuration on the remote 2651 routers is identical in terms of the route-maps and service policy. The output from the show policy interface Multilink1 for the remote is as follows:

Multilink1

Service-policy output: Qos-Policy

Class-map: Voice (match-all)

14013163 packets, 2531701128 bytes

5 minute offered rate 159000 bps, drop rate 0 bps

Match: access-group 104

Weighted Fair Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 800 (kbps) Burst 20000 (Bytes)

(pkts matched/bytes matched) 14013163/2531701128

(total drops/bytes drops) 0/0

Class-map: Voice_Control (match-all)

12058676 packets, 594885057 bytes

5 minute offered rate 2000 bps, drop rate 0 bps

Match: access-group 105

Weighted Fair Queueing

Output Queue: Conversation 265 (depth/total drops/no-buffer drops) 0/39/0

Class-map: class-default (match-any)

10978117 packets, 10077936457 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Weighted Fair Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 256

(total queued/total drops/no-buffer drops) 0/0/0

Bandwidth 50 (kbps) Max Threshold 64 (packets)

(pkts matched/bytes matched) 12058676/594885057

Here is the output from the core msfc:

Multilink1

service-policy output: Qos-Policy

class-map: Voice_Control (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

match: access-group 111

0 packets, 0 bytes

5 minute rate 0 bps

queue size 0, queue limit 12

packets output 0, packet drops 0

tail/random drops 0, no buffer drops 0, other drops 0

bandwidth: kbps 50, weight 1

class-map: Voice (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

match: access-group 112

0 packets, 0 bytes

5 minute rate 0 bps

queue size 0, queue limit 225

packets output 0, packet drops 0 tail/random drops 0, no buffer drops 0, other drops 0

bandwidth: kbps 900, weight 29

class-map: class-default (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

match: any

0 packets, 0 bytes

5 minute rate 0 bps

queue size 0, queue limit 530

packets output 0, packet drops 0

tail/random drops 0, no buffer drops 0, other drops 0

fair-queue: per-flow queue limit 132

Finally, here is the configuration utilized on both devices to classify and prioritize the voip traffic across the wan:

class-map match-all Voice_Control

match access-group 105

class-map match-all Voice

match access-group 104

policy-map Qos-Policy

class Voice

priority 800

class Voice_Control

bandwidth 50

class class-default

fair-queue

route-map Set-IP-Qos permit 10

match ip address 101

set ip precedence flash

!

route-map Set-IP-Qos permit 20

match ip address 102

!

route-map Set-IP-Qos permit 30

match ip address 103

set ip precedence routine

access-list 101 permit tcp any any range 2000 2002

access-list 101 permit tcp any any eq 1720

access-list 101 permit tcp any any range 11000 11999

access-list 101 permit udp any any eq 2427

access-list 102 permit udp any any range 16384 32767

access-list 103 permit ip any any

access-list 104 permit ip any any precedence critical

access-list 104 permit ip any any dscp ef

access-list 105 permit ip any any precedence flash

access-list 105 permit ip any any dscp af31

Any help is greatly appreciated.

New Member

Re: 6509 msfc qos

It has been confirmed via TAC that this feature is not currently supported on the flex wan modules. Sorry......

Cisco Employee

Re: 6509 msfc qos

What does the QoS on the 6500 look like? Have you configured it on the MSFC or the Supervisor? Note that if you configured it on the MSFC, it does not mean anything as not every packet hits the MSFC(due to MLS/CEF). Refer to the following page for QoS guidelines

http://www.cisco.com/warp/public/473/#LANqos

http://cio.cisco.com/univercd/cc/td/doc/product/lan/cat6000/sw_6_3/confg_gd/qos.htm

129
Views
0
Helpful
4
Replies
This widget could not be displayed.