Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

7970 Failed Firmware Upgrade

I attempted a firmware upgrade to the latest SCCP code (8.0(2)SR1) and after the phone sitting for 10 minutes at the white Cisco screen, I power cycled it. Now the phone wont boot at all. On power up, the Mute button lights up first, then the Handsfree button lights up and stays on. Nothing happens after that. I've tried during the factory reset procedure (holding down # while powering up) but I don't get the sequence of line lights flashing. I've also tried power it up with the handset off hook, and I get the Headset button light first, then the Mute, and then the Handsfree button stays on. Does any one have any suggestions? Right now all I've got is a *very* expensive brick.

4 REPLIES
Super Bronze

Re: 7970 Failed Firmware Upgrade

Hi

I had a phone in a similar state, it was completely useless... I built a console cable for it, and could see it trying to TFTP a particular image from the server - this image wasn't on the server and I'm sure it never was... I suspect it must have been the original load or something.

Anyway - make a serial cable, and plug it in. Start up the phone, and see what the debug shows you - it's quite easily readable.

You should be able to see where it fails. To fix mine I had to put the software it was looking for on the TFTP server and it fixed itself - I had to get someone on this forum to supply me the software as I couldn't find it anywhere...

Serial Cable (same for 7970 and 7960 regardless of software):

http://www.cisco.com/en/US/products/sw/iosswrel/ps5187/prod_troubleshooting_guide_chapter09186a0080558541.html#wp1041428

Aaron

Please rate helpful posts

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Re: 7970 Failed Firmware Upgrade

Hi

Although I have not encountered a dead phone like you are describing, the upgrade process to the latest versions of 7970 firmware will only work if certain firmware versions are on the phone and on the server respectively. It was well explained in the read me.

One thing the read me did say was that the upgrade sequence took a long time, even if going from 7.x code to 8.x code. It then said that it could take double the time if going from a 6.x version, and not to even attempt it if you had very early versions (or, rather, perform the necessary upgrades to get it up to 6.x or 7.x).

I know this does not solve your problem now, but it may be helpful to know as to why this has happened and help to avoid the pain in the future.

Rgds

Marc

New Member

Re: 7970 Failed Firmware Upgrade

I consoled the phone, and here's what I got:

CNU 3.1(1.15); Mar 21 2006 21:51:25

Copyright (c) 2001-2005 Cisco Systems, Inc. All rights reserved.

SYSMSG: Last reboot cause -> Power Loss

-->init: ver 3.7(1.4)

-->init: Starting syslogd...

-->syslogd: [2] ver 3.0 (2.0)

-->syslogd: waiting for filesystem...

It hangs there indefinitely. Any thoughts on resolving this would be appreciated.

New Member

Re: 7970 Failed Firmware Upgrade

Hi Gary,

I have the same problem as you these days. I would like to know if you solved your problem and how you solved it.

Best regards,

Marija

454
Views
5
Helpful
4
Replies