Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

AA configuration issue with CME 3.3

Hi,

I have a router with 2 port FXO card having an analog PSTN line terminated on one port. The number is 24785780. I have assigned this number to the AA. But I cannot get the AA work. when I dial the AA number, I get an dial tone and then after a few seconds I get a busy tone. Before the busy tone, if i dial any internal ip phone DN, the ip phone rings. But I cannot get the AA script to work.

I have attached the working config and also the debug .

Any advice on the same ?

Thanks

Brgds

renzil

15 REPLIES

Re: AA configuration issue with CME 3.3

Remove the incoming called number and only specify,

dial-peer voice 1 pots

port 0/0/0

service aa

See if this helps!

New Member

Re: AA configuration issue with CME 3.3

Thanks for the suggestion, but it does not work.

The same problem. when I dial the AA number, I get a dial tone for a few seconds and then a busy tone.

From the debug, I notice that the called number i.e the AA number does not display. Can this be a issue ??

Thanks

Brgds

Renzil

New Member

Re: AA configuration issue with CME 3.3

hi

how did you configure your application?

i done a dial-peer voip like this one:

dial-peer voice 100 voip

incoming called-number

destination-pattern

application aa

session target ipv4:< IP@ of the router>

codec G711ulaw.

See if it can help you

Re: AA configuration issue with CME 3.3

Eric, Like indicated in the original post. the application command has been deprecated in newer IOS and is replaced by service command.

Re: AA configuration issue with CME 3.3

Hi,

1) Under voice-port 0/0/0 configure "connection plar 24785780. This will provide the DNIS that IOS will use to match the inbound dial-peer 2. It will match dnis using "incoming called 24785780". FXO cannot provide DNIS, only ANI. So you have to provide it.

2) Configure direct-inward-dial on dial-peer 2. This is why you are getting the second dial-tone inbound.

You can prove it this way: if, when you get that dial-tone, you enter the dnis, the application should then start.

New Member

Re: AA configuration issue with CME 3.3

Thanks michael,

I do get the DNIS info now, but yet the application does not work. I get a fast busy tone when i call the AA number.

Attached is the log file. Any more debug that can be helpful to solve the issue ?

Thanks for your time.

Brgds

Renzil

Re: AA configuration issue with CME 3.3

I just downloaded the the acd application and readme that comes with it.

Let's start with a "debug voip dialpeer all" to make sure we are hitting the application, then a "debug voip ivr script" to see what errors it is seeing. I suspect that it is looking for some ephone-hunts for the acd portion of this, but I'm not sure. Hopefully the debug will tell us more.

I am attaching the readme because there is a lot of information that should be reviewed and understood for this application.

Re: AA configuration issue with CME 3.3

I haven't used this particular flavor of aa before, but I am very curious. I'm gonna lab it up tonight (CST) and see what I can come up with for you.

Were you able to pull any of those debugs?

New Member

Re: AA configuration issue with CME 3.3

hi Michael,

thanks for your assistance. I added some hunt groups to the config. I yet get the busy tone. Attached is the debug u mentioned.

Thanks

Brgds

renzil

Re: AA configuration issue with CME 3.3

So from the debug voip dialpeer all out put, we see call coming in on dial-peer 1

Sep 15 07:46:59.325: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=1

and hairpinning out to dial-peer 1.

Sep 15 07:46:59.337: //-1/BAF709488079/DPM/dpMatchPeersMoreArg:

Result=SUCCESS(0)

List of Matched Outgoing Dial-peer(s):

1: Dial-peer Tag=1

I would first remove the "port 0/0/0" from dial-peer 2.

Then if it fails, you should get output from "debug voice application error, to see if aa is really running.

New Member

Re: AA configuration issue with CME 3.3

Hi Michael,

can u advice on the attached debug.

Thanks

Renzil

New Member

Re: AA configuration issue with CME 3.3

I am also facing the exact problem which you are facing.

Did every part base on the documentation but still not greeted by the welcome prompt.

Any workaround? Am using CME3.3 IOS ver 12.4(3)

Bronze

Re: AA configuration issue with CME 3.3

hi,

here is a config that goes for me:))

additionally i have 1 queue in my config.

IOS Version: 12.3.14T2

greetings

mehmet

voice translation-rule 10

rule 5 /^$/ /98765000/

!

!

voice translation-profile INCOMING

translate called 10

!

application

service aa-basic flash:app-b-acd-aa-2.1.0.0.tcl

paramspace english index 0

param second-greeting-time 0

param welcome-prompt _PrivatWelcome.au

paramspace english language en

param call-retry-timer 1

param max-time-call-retry 900

param voice-mail 61

param service-name basic-queue

param number-of-hunt-grps 3

param handoff-string aa-basic

param dial-by-extension-option 1

paramspace english location flash:

param max-time-vm-retry 1

param max-extension-length 3

param aa-pilot 98765000

!

service basic-queue flash:app-b-acd-2.1.0.0.tcl

param number-of-hunt-grps 3

param aa-hunt2 60

param queue-len 10

!

dial-peer voice 1001 pots

service aa-basic

incoming called-number .

direct-inward-dial

port 0/0/0

!

voice-port 0/0/0

translation-profile incoming INCOMING

!

New Member

Re: AA configuration issue with CME 3.3

Mehmet,

Thanks for the heads up, I got it working finally. Realise that I missed out the "param voice-mail" command. Not knowing that it was mandatory since I wanted to try the feature out without CUE.

Cheers..

New Member

Re: AA configuration issue with CME 3.3

hi,

When i apply the service aa-basic application iget the below message like

Warning: parameter aa-pilot has not been registered under aa-basic namespace

CCME-ROUTER(config)#

CCME-ROUTER(config)#

CCME-ROUTER(config)#app

CCME-ROUTER(config-app)#service aa-basic flash:app-b-acd-aa-2.1.0.0.tcl

CCME-ROUTER(config-app-param)#paramspace english index 0

CCME-ROUTER(config-app-param)#param second-greeting-time 0

Warning: parameter second-greeting-time has not been registered under aa-basic namespace

CCME-ROUTER(config-app-param)#param welcome-prompt en_bacd_welcome.au

Warning: parameter welcome-prompt has not been registered under aa-basic namespace

CCME-ROUTER(config-app-param)#paramspace english language en

CCME-ROUTER(config-app-param)#param call-retry-timer 1

Warning: parameter call-retry-timer has not been registered under aa-basic namespace

CCME-ROUTER(config-app-param)#param max-time-call-retry 900

Warning: parameter max-time-call-retry has not been registered under aa-basic namespace

CCME-ROUTER(config-app-param)#param voice-mail 200

Warning: parameter voice-mail has not been registered under aa-basic namespace

CCME-ROUTER(config-app-param)#param service-name basic-queue

Warning: parameter service-name has not been registered under aa-basic namespace

CCME-ROUTER(config-app-param)#param number-of-hunt-grps 2

Warning: parameter number-of-hunt-grps has not been registered under aa-basic namespace

CCME-ROUTER(config-app-param)#param handoff-string aa-basic

Warning: parameter handoff-string has not been registered under aa-basic namespace

CCME-ROUTER(config-app-param)#param dial-by-extension-option 1

Warning: parameter dial-by-extension-option has not been registered under aa-basic namespace

CCME-ROUTER(config-app-param)#paramspace english location flash:

CCME-ROUTER(config-app-param)#param max-time-vm-retry 1

Warning: parameter max-time-vm-retry has not been registered under aa-basic namespace

CCME-ROUTER(config-app-param)#param max-extension-length 3

Warning: parameter max-extension-length has not been registered under aa-basic namespace

CCME-ROUTER(config-app-param)#param aa-pilot 300

Warning: parameter aa-pilot has not been registered under aa-basic namespace

CCME-ROUTER(config-app-param)#

CCME-ROUTER(config-app-param)#

CCME-ROUTER(config-app-param)#

CCME-ROUTER(config-app-param)#

864
Views
0
Helpful
15
Replies