Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

About 7950 IP Phone and 3550 Switch

Can anyone help me?

In case of that 7950 IP phone is connected to a 3550 switch, which configuration would be correct?

Config#1

SW-1 :

vlan 200

name VOICE

!

mls qos

!

interface FastEthernet 0/7

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 200

switchport trunk native vlan 11

Config#2

SW-1 :

vlan 200

name VOICE

!

interface FastEthernet 0/7

switchport mode access

switchport access vlan 11

switchport voice vlan 200

I think, Config#1 sets all cos value on the switch to 0 by enabling mls qos. So if voice traffic set with another cos value could not be assured even can't flow.

In case of Config#2, I think it would work fine. No change would be made in the voice and data traffic.

Your opinion would be valuable.

Cheers

2 REPLIES
Hall of Fame Super Silver

Re: About 7950 IP Phone and 3550 Switch

Both configuration will do the same thing, the prefered, newer way is the second config, I'd recommand adding spanning-tree portfast to it. Also, since you enabled QoS on the switch but did not establish trust bundry on the switchport all of the traffic will be remarked down to COS/DSCP 0. You need to add the following:

"mls qos trust device cisco-phone"

"mls qos trust cos"

also, add the following command under the uplink to the router"

"mls qos trust dscp"

HTH, please rate all posts!

Chris

Hall of Fame Super Gold

Re: About 7950 IP Phone and 3550 Switch

I think it is correct, basically with qos enabled, by default you give equal precedence to all traffic, and need to specify policies to classify traffic in queues different than 0.

You would need however severe egress congestion to get potential trouble.

BTW, what is a 7950 phone ?

1314
Views
0
Helpful
2
Replies