Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

About Cisco IP Phone usage without Call Manager

I have two Cisco 7960 IP Phone and some Cisco switches and Routers,but I have no Cisco Call Manager software.

Can I do some IP Telephony Lab test without Call Manager?

If yes,how?

Thank you!

18 REPLIES
Community Member

Re: About Cisco IP Phone usage without Call Manager

You have a couple of options:

1) Use ITS 2.1 - Cisco IOS Telephony Service.

Supported Routers :Cisco 1751, Cisco 1760, Cisco 2600-XM, Cisco 2650, Cisco 2650-XM, Cisco 2651, Cisco 2691, Cisco 3640, Cisco 3640A, Cisco 3660, Cisco 3725, Cisco 3745.

Supported Phones:Cisco IP Phone 7910, Cisco IP Phone Expansion Module 7914, Cisco IP Conference Station 7935, Cisco IP Phone 7940, Cisco IP Phone 7960, Cisco ATA-186, Cisco ATA-188.

This with not give you all the features of CCM. See link for more info:

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide_book09186a0080153d1f.html

2) Get the book Developing Cisco IP Phone Services from Cisco Press.

https://www.amazon.co.uk/exec/obidos/ASIN/1587050609/026-4415890-2862849

The enclosed CD contians CMSIM - Call manager Simulator. Again you will lose some functionality but might help for a lab enviroment.

HTH

David

Community Member

Re: About Cisco IP Phone usage without Call Manager

Yes, You can.

Look for IOS Telephony Service (ITS) at Cisco site. Configure this feature at Cisco Router.

You may need to change Software at Your Router, and You need also to buy Feature License to use ITS legal.

See URL below:

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_feature_guide09186a0080128fb3.html

Community Member

Re: About Cisco IP Phone usage without Call Manager

I'm setting up a ITS router-Cisco3640.When I set up ITS GUI,input "ephone 2" command,error message"ephone tag 2 exceeds max-ephones 0 ",what it mean?

Community Member

Re: About Cisco IP Phone usage without Call Manager

Try to add command "max-ephones " command under telephony-service configuration menu.

Look below for my lab config:

=====================================

telephony-service

load 7910 P00403020204

load 7960-7940 P00303020204

ip source-address 20.206.1.4 port 2000

max-ephones 8

max-dn 8

max-conferences 2

moh eagle2.ULAW.wav

time-format 24

date-format dd-mm-yy

admin-username admin

admin-password admin

dn-webedit

time-webedit

==================================

Good Luck.

Community Member

Re: About Cisco IP Phone usage without Call Manager

Dear support,

Thanks for your help!

I have connectted the ITS Router(Cisco3640) and one Cisco7960 to a Cat3524 switch,follows is configuration of the ITS router.When I powered on the Cisco7960,it always be in "config ip address" or "open 10.130.0.106" status,10.130.0.106 is the ip address of ITS router.I don't know wh

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

boot system tftp c3640-is-mz.122-15.T.bin 10.130.0.21

logging queue-limit 100

enable password unison

!

ip subnet-zero

!

!

no ip domain lookup

!

ip dhcp pool pool1

network 10.130.0.0 255.255.255.0

option 150 ip 10.130.0.106

default-router 10.130.0.106

!

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

mta receive maximum-recipients 0

partition flash 2 8 8

!

!

!

!

!

interface Ethernet0/0

no ip address

shutdown

half-duplex

!

interface FastEthernet1/0

ip address 10.130.0.106 255.255.255.0

ip helper-address 10.130.0.249

duplex auto

speed auto

!

interface TokenRing1/0

no ip address

shutdown

ring-speed 16

!

ip http server

ip http path flash:

ip classless

!

!

!

!

tftp-server flash:1:P00303020209.bin

call rsvp-sync

!

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

!

!

telephony-service

load 7960-7940 P00303020209

max-ephones 10

ip source-address 10.130.0.106 port 2000

web admin system name patrick password unison

dn-webedit

time-webedit

!

!

ephone 1

username "unison" password unison

!

!

!

!

line con 0

line aux 0

line vty 0 4

password unison

login

!

!

end

Community Member

Re: About Cisco IP Phone usage without Call Manager

Hi,

Maybe you are missing the command

tftp-server flash:SEPDEFAULT.cnf

according to the example at

http://www.cisco.com/en/US/partner/tech/tk652/tk701/technologies_configuration_example09186a00800ffdcc.shtml

regards,

Yanna

Community Member

Re: About Cisco IP Phone usage without Call Manager

Thank you!

But Wher can I get the SEPDEFAULT.cnf file?

I didn't find it in the ITS2.1.0.2 ZIPfile.

Community Member

Re: About Cisco IP Phone usage without Call Manager

The answer is below:

==========================

When Cisco IOS Telephony Service is configured, the Cisco IP phones receive initial configuration information and phone firmware from the TFTP server. In most cases, the Cisco IP phones obtain the IP address of their TFTP server with the Dynamic Host Configuration Protocol (DHCP) option 150 command. For Cisco IOS Telephony Service operation, the TFTP server address obtained by the Cisco IP phones should point at the Cisco IOS Telephony Service router IP address. The Cisco IP phones attempt to transfer a configuration file called SEPDEFAULT.cnf. This file is automatically generated by the Cisco IOS Telephony Service router through the ip source-address command and placed in the router's Flash memory. The SEPDEFAULT.cnf file contains the IP address that the phones use to register for service, using the Skinny Client Control Protocol (SCCP). This IP address should correspond to a valid Cisco IOS Telephony Service router IP address (and may be the same as the router TFTP server address). Access to the SEPDEFAULT.cnf file must be granted through the tftp-server command on the router.

==========================

Community Member

Re: About Cisco IP Phone usage without Call Manager

Patrick,

check flash files at your router. It should look like this (if You have only one IP phone You need only one P00???.bin file, and in Your case you may not need eagle2.ULAW.wav file):

===============

ITS#sh fla

System flash directory:

File Length Name/status

1 14097360 c2600-is-mz.122-11.T.bin

2 55 SEPDEFAULT.cnf

3 250 XMLDefault.cnf.xml

4 405626 P00303020204.bin

5 367838 P00403020204.bin

6 18717 eagle2.ULAW.wav

[14890240 bytes used, 1362688 available, 16252928 total]

16384K bytes of processor board System flash (Read/Write)

===============================

Don't forget to put phones Load images, and configuration files.

A good idea to download from Cisco site ITS file with all required files at put needed files to flash memory.

Next one, I haven't seen in Your config command like:

==============

tftp-server flash:SEPDEFAULT.cnf

tftp-server flash:XMLDefault.cnf.xml

==============

Last, You have only entered "ephone 1" and there is no "ephone-dn" command

In Your case it should be look like:

===================================

ephone 1

username "unison" password unison

mac-address

button 1:1

ephone-dn 1

number 1234

name unison

hold-alert 15 originator

============================

Try to do it.

Good Luck.

Community Member

Re: About Cisco IP Phone usage without Call Manager

Thank you!

But.......

I have add the configuration you asked,and the 7960 still in "configuring IP".

I have checked the "Network" in the 7960,I'm sure it got the ip address from DHCP(ITS router),and it's firmware has downloaded.May be the config file it can't download from DHCP server.

I have inputed the command "IP source-address port 2000",but no SEPDefault.cnf file created.

No dial tone in the "ear" of 7960.

Current configuration : 1515 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

boot system tftp c3640-is-mz.122-15.T.bin 10.130.0.21

logging queue-limit 100

enable password unison

!

ip subnet-zero

!

!

no ip domain lookup

!

ip dhcp pool pool1

network 10.130.0.0 255.255.255.0

option 150 ip 10.130.0.106

default-router 10.130.0.106

!

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

mta receive maximum-recipients 0

partition flash 2 8 8

!

!

!

!

!

interface Ethernet0/0

no ip address

shutdown

half-duplex

!

interface FastEthernet1/0

ip address 10.130.0.106 255.255.255.0

ip helper-address 10.130.0.249

duplex auto

speed auto

!

interface TokenRing1/0

no ip address

shutdown

ring-speed 16

!

ip http server

ip http path flash:

ip classless

!

!

!

!

tftp-server flash:1:P00303020209.bin

tftp-server flash:1:XMLDefault.cnf.xml

tftp-server flash:1:SEPDEFAULT.cnf

call rsvp-sync

!

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

!

!

telephony-service

load 7960-7940 P00303020209

max-ephones 10

max-dn 8

ip source-address 10.130.0.106 port 2000

max-conferences 2

time-format 24

date-format dd-mm-yy

web admin system name admin password admin

dn-webedit

time-webedit

!

!

ephone-dn 1

number 1234

name unison

hold-alert 15 originator

!

!

ephone 1

username "unison" password unison

mac-address 0009.B7DA.0C6E

button 1:1

!

!

!

!

line con 0

line aux 0

line vty 0 4

password unison

login

!

!

end

Router#sh flash

System flash directory, partition 1:

File Length Name/status

1 6165696 c3640-i-mz.122-12.bin

2 371312 P00303020209.bin

3 29092 logohome.gif

4 4001 ephone-admin.html

5 2240 telephony-service.html

6 35138 normal-user.html

7 1720 XMLDefault.cnf

8 1720 XMLDefault.cnf.xml

[6611436 bytes used, 1777172 available, 8388608 total]

8192K bytes of processor board System flash (Read/Write)

System flash directory, partition 2:

No files in System flash

[0 bytes used, 8388608 available, 8388608 total]

8192K bytes of processor board System flash (Read/Write)

Community Member

Re: About Cisco IP Phone usage without Call Manager

I've made now a test - I deleted file SEPDefault.cnf from flash, squeeze flash.

After that I go to telephony-service configuration menu and do next:

1. no IP source-address port 2000

2. reset all

3. IP source-address port 2000

After that I got again file SEPDefault at flash memory.

Community Member

Re: About Cisco IP Phone usage without Call Manager

No,I can't get this file.

show flash

Delete----reset all----Add,

sh flash

Nothing changed.

Community Member

Re: About Cisco IP Phone usage without Call Manager

Debug TFTP

Finished system:/its/XMLDefault7960.cnf.xml, time 00:00:00 for process 146

05:29:02: TFTP: Server request for port 51795, socket_id 0x633A078C for process 146

05:29:02: TFTP: read request from host 10.130.0.1(51795) via FastEthernet1/0

05:29:02: TFTP: Looking for OS79XX.TXT

05:29:02: TFTP: Sending error 1 No such file

05:29:02: TFTP: Server request for port 51796, socket_id 0x633A078C for process 146

05:29:02: TFTP: read request from host 10.130.0.1(51796) via FastEthernet1/0

05:29:02: TFTP: Looking for SEP0009B7DA0C6E.cnf.xml

05:29:02: TFTP: Opened system:/its/XMLDefault7960.cnf.xml, fd 0, size 0 for process 146

05:29:02: TFTP: Sending block 1 (retry 0), socket_id 0x633A078C

05:29:02: TFTP: Received ACK for block 1, socket_id 0x633A078C

05:29:02: TFTP: Finished system:/its/XMLDefault7960.cnf.xml, time 00:00:00 for process 146

05:29:17: TFTP: Server request for port 51993, socket_id 0x633A078C for process 146

05:29:17: TFTP: read request from host 10.130.0.3(51993) via FastEthernet1/0

05:29:17: TFTP: Looking for OS79XX.TXT

05:29:17: TFTP: Sending error 1 No such file

05:29:17: TFTP: Server request for port 51994, socket_id 0x633A078C for process 146

05:29:17: TFTP: read request from host 10.130.0.3(51994) via FastEthernet1/0

05:29:17: TFTP: Looking for SEP0009B7DA0C03.cnf.xml

05:29:17: TFTP: Opened system:/its/XMLDefault7960.cnf.xml, fd 0, size 0 for process 146

05:29:17: TFTP: Sending block 1 (retry 0), socket_id 0x633A078C

05:29:17: TFTP: Received ACK for block 1, socket_id 0x633A078C

05:29:17: TFTP: Finished system:/its/XMLDefault7960.cnf.xml, time 00:00:00 for

Community Member

Re: About Cisco IP Phone usage without Call Manager

Patrick.

Look below an information about requirements for ITS versions 2.1 and 2.0, and check what You have http://www.cisco.com/cgi-bin/tablebuild.pl/ip-iostsp

It could be a problem with IOS and ITS version mismatch.

Regards.

1968
Views
0
Helpful
18
Replies
CreatePlease to create content