Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Active Directory Corporate Directory Integration Issues

Two things:

The lastest SDK kit does not include the s.searchbase variable so you need to add it and take off the .1 off the LDAPSearch.LDAPSearchList object.

var ldapserver = "10.22.103.12";

var ldapport = "389";

var ldapuserid = "IPTelephony";

var ldapsearchbase = "OU=North America, dc=acme,dc=com";

var ldappassword = "54321";

// Create the COM object and initial values

var s = new ActiveXObject("LDAPSearch.LDAPSearchList");

s.server = ldapserver;

s.port = ldapport;

s.AuthName = ldapuserid;

s.AuthPasswd = ldappassword;

s.searchbase = ldapsearchbase;

s.AddReturnAttr("givenName, sn", "Name", "%2, %1", 31);

s.AddReturnAttr("telephoneNumber", "Telephone", "%1", 31);

Secondly,

If the way you structure your active directory does not have the top OU to include all the other OUs and CNs, this script isn't going to work for you.

You can't set the context to the dc=acme,dc=com and login.

2 REPLIES
New Member

Re: Active Directory Corporate Directory Integration Issues

Thank you for this post!

New Member

Re: Active Directory Corporate Directory Integration Issues

Hi Patrick,

I tried to do the things you explained above. I have a AD, created a new OU in it and put Users in that ou. I run the ldapsearch.asp against it but can´t see any users. Running the ldapsearch against DC Directory works fine. In AD, do I have to configure a user with ldap access rights. And when so, where? I actually try it with DomainAdmin.

Thank you for your help.

Markus

183
Views
0
Helpful
2
Replies