Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

admin web page

Hello,<br>I have a customer that believed he had the Nimba virus on his Unity Server. He took it upon himself to run a tool to clear his servers of the virus. Everything starts and seems to run fine now, however he can no longer open the admin web page. He gets an HTTP 500-Internal Server error and a message saying the web page cannot be displayed. He also previously ran OWA through this box and that no longer seems to work either. I am not very familiar with IIS and am looking for some places to begin. Would you suggest reinstalling IIS and if I were to do that would I have to reinstall anything else? <br>One other note. His PDC had gone down for awhile and he ended up recreating some user accounts. I don't know if this maybe creating some kind of problem with it as all services have started with no problems. Any ideas of where to start looking would be very much appreciated.<br><br>Thank you<br><br>Jeremy<br><br>

4 REPLIES
Anonymous
N/A

Re: admin web page

Some of the infected files may have been deleted. Once the system has been secured by patches & cleanup tools, run Unity setup to be sure the SA web site files get re-installed.



Scott Morgan
Cisco Systems TAC

New Member

Re: admin web page

Rather than running the Unity upgrade, would it be possible to just copy the saweb folder from the untiy cd over top of the saweb directory on the unity server? I say this becuase the last upgrade I did on this customers unity was a nightmare and would like to avoid an upgrade right now if possible. If running an upgrade is the only option than that's just the way it has to be done, but if there is an optional shortcut such as just copying over folders than that would be much easier.
Thank you

Anonymous
N/A

Re: admin web page

Using these steps you can restore restore the SA/AA and the Status Monitor without having to run Unity setup.

Procedure for Unity 2.4.6-
----------------------------------------------------------------------------------------------------------------------
From CD1 copy the SAWeb directory to the InetPub\WWWRoot\SAWeb directory. Overwrite destination files.
From CD1 copy the SAHelp directory to the InetPub\WWWRoot\SAHelp directory. Overwrite destination files.
From CD1 copy the Status directory to the InetPub\WWWRoot\Status directory. Overwrite destination files.
For US English -
From CD1 copy the Localize\SAWeb directory to the InetPub\WWWRoot\SAWeb directory. Overwrite destination files.
From CD1 copy the Localize\SAHelp directory to the InetPub\WWWRoot\SAHelp directory. Overwrite destination files.
From CD1 copy the Localize\Status directory to the InetPub\WWWRoot\Status directory. Overwrite destination files.
Repeat the procedure for any addition languages that you have. Locate the CD on which the language files are stored.


Procedure for Unity 3.0
-------------------------------------------------------------------------------------------------------------------------
From CD1 copy the Web directory to the CommServer\Web directory. Overwrite destination files.
For US English -
From CD1 copy the Localize\Web directory to the CommServer\Web directory. Overwrite destination files.
Repeat the procedure for any addition languages that you have. Locate the CD on which the language files are stored.


Anonymous
N/A

Re: admin web page

There are a few more steps that caqn be performed. If the error stating "... path not found." when you try to open the SA/SM. This error is caused by a corupt METABASE.BIN file found in the Winnt\System32\InetSrv directory. This means that either the Metabase file needs to be restored or IIS needs to be reloaded. In my case, I reinstalled IIS. The following steps are to restore the pointers to the directories needed for the SA/SM.
1.) Open the IIS Admin window.
2.) Create a new virtual directory called SAWeb and point this to the CommServer\WEB\SA directory.
3.) Create a new virtual directory called WEB and point this to the CommServer\WEB directory.
4.) Make sure the AvXml folder has the Execute Permissions set to Scripts and Executables.
5.) Restart the IIS service.

Tim

286
Views
0
Helpful
4
Replies
CreatePlease to create content