Cisco Support Community
Community Member

ADSchema Update Failure - Incorrect Function

I have an existing Unity 3.1.3 system that is AD integrated with Ex2K. I need to upgrade it to 4.0.3. In preparing for the upgrade I need to update the schema. When I run the ADSchemasetup.exe tool on my Schema Master/Domain Controller, it fails right away. The error I get is "ldifde failed for reason: Incorrect function." I've seen this error discussed in the forum but I haven't seen any resolutions. The account I'm using is the domain administrator which is in the schema admin and domain admin security groups. A log file called ADSchemaSetup.log is generated but it doesn't paste in this window very well. I can send it to anyone who would want to view it. I have tried with two different CD's but I get the same results. Does anyone have any suggestions?

Community Member

Re: ADSchema Update Failure - Incorrect Function

What win2k service pack are your domain controllers running? I think with sp2 and older, all the domain controllers had to be online for a schema change to work.

Paste in the actual error from the ldif.log file. What line was the error reported to have occurred?


Community Member

Re: ADSchema Update Failure - Incorrect Function

Thanks for replying adam. The controllers are all running SP3. All domain controllers are up and running. Below are a few lines from the the adschemasetup.log file. Unfortunately, nothing is written into the ldig.log (which tells you which line it fails on). I believe the log file you mentioned resides in the avdirmonex2k directory. That directory is empty on the schema master after the schema setup runs.

The ldifde command line is: ldifde.exe -i -k -c "" "CN=Schema,CN=Configuration,DC=fldoi,DC=gov" -s "DOITLHHQDC2" -f "E:\Schema\LdifScripts\avdirmonex2k.ldf" -j "C:\Documents and Settings\Administrator.FLDOI\Desktop\ldif logs\11132003_174419\avdirmonex2k" e:\views\Unity4.0.2.122\un_Setup\ADSchemaSetup\ADSchemaSetup\ADSchemaSetupDialog.cpp 378

2003-11-13 22:44:19 Information _tsystem returned 1. e:\views\Unity4.0.2.122\un_Setup\ADSchemaSetup\ADSchemaSetup\ADSchemaSetupDialog.cpp 382

2003-11-13 22:44:19 Information Entering CADSchemaSetupDialog::NotifyScriptError. e:\views\Unity4.0.2.122\un_Setup\ADSchemaSetup\ADSchemaSetup\ADSchemaSetupDialog.cpp 1127

2003-11-13 22:44:19 Error ldifde failed for reason: Incorrect function. e:\views\Unity4.0.2.122\un_Setup\ADSchemaSetup\ADSchemaSetup\ADSchemaSetupDialog.cpp 1143

2003-11-13 22:47:52 Information Safety interlock was initially set. e:\views\Unity4.0.2.122\un_Setup\ADSchemaSetup\ADSchemaSetup\ADSchemaSetupDialog.cpp 476

Community Member

Re: ADSchema Update Failure - Incorrect Function

To give the background, you said you're currently running Unity 3.1.3, Win2ksp2, and fixes KB823980 and Q301625.

My first thought is get that Windows box up to snuff with the rest of the available services packs. Move to Win2ksp4. This is to protect the box from the hundreds of defects discovered prior to sp4 and prep your box for 4.0.3. And it's also to head this error off at the pass.

It's breaking at a windows system call, "_tsystem", where we can see the value 1 being returned. According to this link, this system call passes a string (the "ldifde.exe -i -k..." part) to a command interpreter.

The page says is "A return value of \x{2013} 1 indicates an error, and errno is set to one of the following values." I tracked this down in the code, and the "Incorrect function" looks like it's a local windows system error, not a unity error, despite that text not being listed in the link above.

So, again, move the box to win2ksp4 and try again. Jeff could better answer as to why this happened, but I speculate the developers assumed you'd already be at win2ksp4 when you ran the latest ADSchemaSetup (since it is a requirement to install/upgrade to 4.0.3).


CreatePlease to create content