Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

after call established then call suddently disconnect . Please help me!

Hi,

I´ve got a 2621XM router with AIM and VWIC-1MFT-E1. The call gets established through the PSTN E1 but suddently it gets disconnected. The side calling from the PSTN doesn`t realized that the call goes down but the side from the IP phone 7960 listens call disconnect tones (busy signal). It happens periodically. I`ve detected that in the debug, I can see the next information:

11:01:44.611: ISDN Se0/0:15 Q921: User TX -> RRp sapi=0 tei=0 nr=2

Oct 5 11:01:44.623: ISDN Se0/0:15 Q921: User RX <- RRf sapi=0 tei=0 nr=3

Oct 5 11:01:54.623: ISDN Se0/0:15 Q921: User TX -> RRp sapi=0 tei=0 nr=2

Oct 5 11:01:54.639: ISDN Se0/0:15 Q921: User RX <- RRf sapi=0 tei=0 nr=3

Oct 5 11:02:04.639: ISDN Se0/0:15 Q921: User TX -> RRp sapi=0 tei=0 nr=2

Oct 5 11:02:04.651: ISDN Se0/0:15 Q921: User RX <- RRf sapi=0 tei=0 nr=3

Oct 5 11:02:08.599: ISDN Se0/0:15 Q921: User RX <- BAD FRAME(0x0648C8CACACACACACACACA)

Oct 5 11:02:11.783: %CONTROLLER-5-UPDOWN: Controller E1 0/0, changed state to down (RAI detected)

Oct 5 11:02:11.799: ISDN Se0/0:15 **ERROR**: CCPRI_Go: call id 0x7 event 0x57 No ccb Source->HOST

Oct 5 11:02:11.807: ISDN Se0/0:15 **ERROR**: CCPRI_Go: call id 0x7 event 0x4B No ccb Source->HOST

Oct 5 11:02:11.807: ISDN Se0/0:15 Q931: L3_ShutDown: Shutting down ISDN Layer 3

Oct 5 11:02:11.835: //-1/xxxxxxxxxxxx/CCAPI/ccTDConstructTDUsrContainer: usrContainer[0x82E52C6C], magic[FACE0FFF]

Oct 5 11:02:11.839: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtProfileTableBuildManager: Invoking necessary profileTable updaters...

Oct 5 11:02:11.839: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtUpdateProfileTabFromContainer: Updating profileTable[0x82E52CB8] with objects in container[0x82E52C6C]

Oct 5 11:02:11.839: //-1/xxxxxxxxxxxx/CCAPI/ccTDPvtProfileTableBuildManager:

Oct 5 11:02:11.839: ccTDUtilDumpAllElemInProfileTab: profileTable[0x82E52CB8], numBuckets[11], numEntries[5]

Oct 5 11:02:11.839: Bucket { 0 } ------>0x8394095C[0x0,t-24,l-22,d-0x8394097C,m-1,u-5990,g-FACE0FFF]

Oct 5 11:02:11.839:

Oct 5 11:02:11.839: Bucket { 3 } ------>0x8394090C[0x0,t-21,l-1,d-0x8394092C,m-1,u-5990,g-FACE0FFF]

Oct 5 11:02:11.839:

Oct 5 11:02:11.839: Bucket { 5 } ------>0x83B38D10[0x0,t-6,l-16,d-0x83B38D30,m-2,u-5990,g-FACE0FFF]

Oct 5 11:02:11.843:

Oct 5 11:02:11.843: Bucket { 6 } ------>0x83940A14[0x0,t-26,m-1,g-FACE0FFF 0x839409C0,i-0<t-26,l-4,d-0x839409E0,m-1,u-5990,g-FACE0FFF> ]

10 REPLIES

Re: after call established then call suddently disconnect . Plea

Check for clock slips, framing loss, and line code violations. Please see the following document for instructions as well as a couple of other items to check.

http://www.cisco.com/en/US/tech/tk713/tk628/technologies_tech_note09186a00800f99bb.shtml

Hope this helps.

Brandon

Cisco Employee

Re: after call established then call suddently disconnect . Plea

The key part of the problem is here:

Oct 5 11:02:08.599: ISDN Se0/0:15 Q921: User RX <- BAD FRAME(0x0648C8CACACACACACACACA)

Oct 5 11:02:11.783: %CONTROLLER-5-UPDOWN: Controller E1 0/0, changed state to down (RAI detected)

It looks like the E1 controller is not able to interpret some of the frames from the remote side. This could be due to a hardware issue with the controller, problem on the circuit, a problem with the remote end or even a config problem on the local router.

The RAI deteced is explained here:

http://www.cisco.com/warp/public/116/T1_alarms.html

You can use the "show controllers" command to see if there are any errors on the circuit.

You can try another E1 port on the router (if you have one).

I would work with the provider to see if they are seeing any errors and to verify there are no issues with the circuit.

Kevin

New Member

Re: after call established then call suddently disconnect . Plea

Hi,

I´ve rewiewed my configuration for many times. I think is fine. If i do sh controller e1 I see line code violation error, but I´m sure that line code is HDB3.

In the clock configuration, clock is taken from the line.

I don´t know what to do!!!

I only have this E1 port. I´m in a hurry!

E1 0/0 is up.

Applique type is Channelized E1 - unbalanced

No alarms detected.

alarm-trigger is not set

Version info Firmware: 20020812, FPGA: 11

Framing is CRC4, Line Code is HDB3, Clock Source is Line.

Data in current interval (185 seconds elapsed):

7098 Line Code Violations, 4577 Path Code Violations

3 Slip Secs, 0 Fr Loss Secs, 176 Line Err Secs, 2 Degraded Mins

131 Errored Secs, 131 Bursty Err Secs, 45 Severely Err Secs, 9 Unavail Secs

Total Data (last 28 15 minute intervals):

579170 Line Code Violations, 251862 Path Code Violations,

215 Slip Secs, 1 Fr Loss Secs, 12042 Line Err Secs, 162 Degraded Mins,

10187 Errored Secs, 9354 Bursty Err Secs, 1933 Severely Err Secs, 1320 Unavail Secs

!

logging queue-limit 100

logging buffered 4096 debugging

enable password cisco

!

network-clock-participate slot 1

network-clock-participate wic 0

network-clock-select 1 E1 0/0

voice-card 0

dspfarm

no local-bypass

ip subnet-zero

!

!

no ip domain lookup

!

isdn switch-type primary-net5

!

!

!

voice service voip

h323

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729br8

codec preference 3 g729r8

!

!

!

voice class h323 1

h225 timeout tcp establish 3

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

ccm-manager music-on-hold

mta receive maximum-recipients 0

!

!

controller E1 0/0

line-termination 75-ohm

pri-group timeslots 1-31

!

!

!

interface FastEthernet0/0

ip address 192.168.100.254 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip h323-id 192.168.100.254

!

interface Serial0/0:15

no ip address

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

!

ip http server

ip classless

call rsvp-sync

!

voice-port 0/0:15

timeouts interdigit 8

!

voice-port 1/0/0

cptone ES

!

voice-port 1/0/1

cptone ES

!

voice-port 1/0/2

cptone ES

!

voice-port 1/0/3

cptone ES

!

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

!

!

dial-peer voice 15 pots

incoming called-number 9466989..

direct-inward-dial

prefix 89

!

dial-peer voice 41 voip

description LLAMADAS ENTRANTES DESDE LOS FXS A LOS TELEFONOS IP DEL CALLMANA

destination-pattern 89..

voice-class codec 1

voice-class h323 1

session target ipv4:192.168.100.1

!

dial-peer voice 25 voip

description ENTRADA A LOS TELEFONOS DEL CALLMANAGER

preference 1

destination-pattern 9466989..

voice-class codec 1

voice-class h323 1

session target ipv4:192.168.100.1

dtmf-relay cisco-rtp h245-signal

no vad

!

dial-peer voice 42 voip

description LLAMADAS ENTRANTES DEL FXS AL AUTOATTENDANT

destination-pattern 4009

voice-class codec 1

voice-class h323 1

session target ipv4:192.168.100.1

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

!

dial-peer voice 43 voip

description ENTRADA AL AUTOATTENDANT DESDE FXS

destination-pattern 4010

voice-class codec 1

voice-class h323 1

session target ipv4:192.168.100.1

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

!

dial-peer voice 44 voip

description ENTRADA AL AUTOATTENDANT DESDE FXS

destination-pattern 4011

voice-class codec 1

voice-class h323 1

session target ipv4:192.168.100.1

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

!

New Member

Re: after call established then call suddently disconnect . Plea

In the show controller command, no alarms are detected. I have speaked with the telco provider and they have tell me that line code is hdb3, and framing crc4. I don´t understand why line code violations errors continue increasing.

Somebody can help me?

Thanks a lot

Bronze

Re: after call established then call suddently disconnect . Plea

maybe bad cable??

Cisco Employee

Re: after call established then call suddently disconnect . Plea

You are getting both line code and path code errors. So, unless the provider is giving you incorrect information regarding the line code and framing I would suspect something physical. Create loopback, found in my previous link, and start at the E1 interface on your router and work your way out toward the provider (as far as you can go) to determine when you start receiving the errors.

Here is more info regarding the line and path code errors:

http://www.cisco.com/en/US/tech/tk713/tk628/technologies_tech_note09186a00800f99bb.shtml

Kevin

New Member

Re: after call established then call suddently disconnect . Plea

I have taken the e1 line to a Nortel Meridian PBX and the call doesn´t fall down. But when I take the signal to my 2621XM router, calls allways disconnect after 1.30 minute active.

Should be something related to the cable that goes from the telco to the router?

Cisco Employee

Re: after call established then call suddently disconnect . Plea

If you are using a different cable it could be the cable. Compare the settings on the Nortel PBX to the router, line coding, etc. It could be a faulty E1 controller in the router.

Kevin

New Member

Re: after call established then call suddently disconnect . Plea

you could be overdriving the line. I had a similar situation where i was getting line code violations on a IMA ATM circuit. Once i set the cablelength to short 110ft the problem went away.

New Member

Re: after call established then call suddently disconnect . Plea

Hi!

I´ve done the loopback test and everything seems to be OK. The next thing I am going to do is to change the BNC-RJ45 cable from the telco to my router.

Thanks for your advices

297
Views
3
Helpful
10
Replies
CreatePlease to create content