Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

AIM/CUE not Picking-up in-bound external calls

I have a 2811 router with an AIM/CUE (12-VM) card. All of the telephony-service stuff works fine:

-All calls in house work fine

-All outbound calls work fine, to PSTN

-All inbound calls work fine, from PSTN

-Each phone can access it's VM internally

-the CME gui and the Unity-Express gui's are accessible on the LAN.

But, when I call from outside into the PRI with a DID number, I get four rings, then a pause, and then it never goes to voicemail. Sometimes; depending if I call with my celr or a land line, I get the message "Sorry your call cannot be completed as dialed, 000-000." Any clue why the vm does work for internal or external calls.

Here's a sample of the config.

interface FastEthernet0/0

no ip address

no ip mroute-cache

duplex full

speed 100

!

interface FastEthernet0/0.100

description SUB-IF for VOICE VLAN

encapsulation dot1Q 100

ip address 10.1.100.1 255.255.255.0

!

interface FastEthernet0/0.101

description GW FOR VOICEMAIL MODULE AIM/CUE

encapsulation dot1Q 101

ip address 10.1.101.1 255.255.255.0

!

interface Service-Engine0/1

discription AIM/CUE VOICEMAIL MODULE

ip unnumbered FastEthernet0/0.101

service-module ip address 10.1.101.2 255.255.255.0

service-module ip default-gateway 10.1.101.1

!

ip route 10.1.101.2 255.255.255.255 Service-Engin0/1

!

!

dial-peer voice 40 voip

description ** cue voicemail pilot **

destination-pattern 6000

session protocol sipv2

session target ipv4:10.1.101.2

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 41 voip

description ** cue auto attendant **

destination-pattern 6001

session protocol sipv2

session target ipv4:10.1.101.2

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 1 pots

description ** T1 PRI Emergency 911 **

destination-pattern 9911

port 0/0/0:23

forward-digits 3

!

dial-peer voice 2 pots

description ** T1 PRI OutBnd Calls **

destination-pattern 9T

port 0/0/0:23

!

dial-peer voice 3 pots

description ** T1 PRI InBnd Calls**

incoming called-number .

direct-inward-dial

port 0/0/0:23

  • Other Collaboration Voice and Video Subjects
8 REPLIES

Re: AIM/CUE not Picking-up in-bound external calls

How many digits is telco sending you?

Can you attached the following debug's

debug voip ccapi inout

debug isdn q931

Place a inbound call and see how many digits are being passed. And what dial-peer the router is taking.

New Member

Re: AIM/CUE not Picking-up in-bound external calls

The telco is pasing all 10 digits, at least that's what I see when a call comes in-bound to one of our DIDs/phones. I can do the dubug on thurds since i'm out sick today and tomorrow. Thank You for the response, I will repost with the debug info on thurs.

New Member

Re: AIM/CUE not Picking-up in-bound external calls

By the way, here is a copy of my telephony-service. Thanks.

telephony-service

load 7910 P00405000700

load 7960-7940 P0030702T023

max-ephones 20

max-dn 20

ip source-address 10.1.100.1 port 2000

auto assign 1 to 20

system message SSP

dialplan-pattern 1 6503926... extension-length 4

voicemail 6000

max-conferences 8 gain -6

call-forward pattern .T

moh music-on-hold.au

transfer-system full-consult

secondary-dialtone 9

create cnf-files version-stamp 7960 Jul 12 2006 10:45:43

!

!

ephone-dn 3 dual-line

number 6172 secondary 6503926172

label 6172

description Mina Hinojales

name Romina Hinojales

call-forward busy 6000

call-forward noan 6000 timeout 10

no huntstop

Re: AIM/CUE not Picking-up in-bound external calls

Problem has to do with how many Digits are getting sent to voice mail on the router when it tries to make the call. You should be seeing 10 digits in the debug.

Next question when one ephone calls another ephone locally does voice mail work?

Try the following commands. This will create a translation-rule that will strip incoming 10 digits to the 4 digits you need. I assume you do not need all 10 digits.

voice translation-rule 1

rule 1 /^650\(....\)/ /\1/

!

!

voice translation-profile digitstrip

translate called 1

!

voice-port 0/0/0:23

translation-profile incoming digitstrip

*************Voice port were you Telco Line comes in Port 0/0/0:23 based on your config*************

telephony-service

no dialplan-pattern 1 6503926... extension-length 4

Ronnie

Re: AIM/CUE not Picking-up in-bound external calls

Link to translation rules. If you get bored and want to do some reading.

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080325e8e.shtml

New Member

Re: AIM/CUE not Picking-up in-bound external calls

Next question when one ephone calls another ephone locally does voice mail work?

No, the VM does not kick-in even between internal ephones. That translation rule you sent me should do the job, i'll try it on thurs.

Thank You Very Much,

:-)>

New Member

Re: AIM/CUE not Picking-up in-bound external calls

Can I use a translation rule on the sip dial-peer instead of for the entire router? In other words, when I remove the dial-pattern command in tele-service I loose the caller-id on all outbound calls. If I make a translation rule to translate all inbound e164 numbers to the VM AIM-CUE, and then apply the rule to the sip dial-peer, will this work better? Or is it just easier to make my VM boxes 10-digits (the same as my DIDs/e.164 numbers) instead of 4 digits?

Thanks,

:-)

Re: AIM/CUE not Picking-up in-bound external calls

You can add tranlation rules to Voice-Ports, VOIP dial-peers and Pots dial-peers which ever you prefer.

You could add the rule to the sip peer and test it. I don't have a router in front of me to test it. You could also change your VM boxes to 10 digits.

But the quick and easy solution would be add another translation rule to handle outbound digit insertion.

I assume your internal DID block starts with a 6...

voice translation-rule 2

rule 1 /^6/ /6503926\1/

!

!

voice translation-profile clid

translate calling 2

voice-port 0/0/0:23

translation-profile outgoing clid

This will now add digits to your outbound calls.

392
Views
0
Helpful
8
Replies
This widget could not be displayed.