Cisco Support Community
Community Member

ATA and switchport parameter issues

Has anyone experienced problems using 'switchport voice vlan xx' with ATA's? I have installed 2 for my customer, using typical IP telephony port specifications (dot1q, native data vlan, and voice vlan). I could not get the units to respond to pings, or open the web interface. I came across bug CSCdz51702, referencing native vlan problems, so I set the ports to static access, natve vlan 1. I still had problems, but eventually got the units to operate. After a few days, they reverted to the previous inaccessible status. I tried removing the voice vlan parameter, and they both came online. I have tried both DHCP and static IP with the same results. I also upgraded from 2.14 to 2.16, with no difference in behavior. The symptoms toggle with the presence or absence of the voice vlan parameter. I did not have time to experiment to see if that was the only parameter affecting the behavior - i.e. if I could restore trunking and/or a native vlan other than 1 or not. I also did not change the OpFlags setting - is it necessary to disable dot1q in the ATA when running the switch in access mode? The bug report does not mention that. I had expected 2.16 to fix the problem, since there are no open issues according to the release notes. Basically, I am trying to find what combination of switchport parms and ATA settings work, and which don't. I also don't want to run without the voice vlan parameter if I can help it, since I don't want to lose the prioritization I'm running SCCP to a 3.2.2c Call manager, using 3550 PWR switches


Re: ATA and switchport parameter issues

I am running CCM 3.0(12) and 2.16 on the ATA 186; and I am also using typical Cisco IP Telephony port specifications on my switches. Each Catalyst 10/100 port for voice, whether on a 3512, 3524, 3524-PWR, or 3548, is:

interface FastEthernet 0/xx

switchport trunk encapsulation dot1q

switchport trunk native vlan yyy

switchport mode trunk

switchport voice vlan zzz

switchport priority extend cos 0

spanning-tree portfast

where xx is the port number; yyy is the native or untagged VLAN for the port (i.e. the "data" VLAN, where the user's PC attached to the IP Phone sends its traffic); and zzz is the VLAN for the IP Phones in each building. All attached IP Phones and the ATA get their IP addresses via DHCP: address request broadcasts on the voice VLANs are forwarded to the DHCP server running on one of the CallManagers.

Are you sure you didn't change anything in your PTAG.DAT file which might somehow be affecting your ATA's VLAN acquisition via CDP?

For what it's worth, I am running my ATA configured to emulate two one-line 7960 IP Phones. This is because my version of CallManager doesn't support the ATA natively.

Hope this helps.

Community Member

Re: ATA and switchport parameter issues

Thanks for your response. I have been informed by TAC that this should all work on 2.16, if I revert all the way to the config as you have it. My problem was to try backing out a step at a time, putting the voice vlan command back in whiule the port was still set for access mode, which apparently confuses the ATA as to which VLAN it shoud be in. I haven't been back to the customer yet, but based on what you and TAC have said, I expect io to work.

CreatePlease to create content