Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Attendant Console - Call Control Fail in different VLAN

Attendant console will work perfectly on the same VLAN were the Call Manager is located. If placed in a different VLAN, the WEB Attendant will show the user directory but will fail the call control. The other VLAN is a trunk port of an IP Phone with a PC connected to the PC port. Other IP connectivity on the PC works ok even to the Voice VLAN.

There is no access lists between VLANS and other IP trafic works fine. Below is a sample port on the switch config (3550XL).

interface FastEthernet0/8

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

switchport voice vlan 1

no ip address

spanning-tree portfast

4 REPLIES
New Member

Re: Attendant Console - Call Control Fail in different VLAN

The "call control failure" is usually caused by the AC user to being associated with the device. Is this the same phone in both VLANs? First thing I'd look at with that error (and last in every instance I've seen it) is the device association on the AC user.

New Member

Re: Attendant Console - Call Control Fail in different VLAN

AC user is not the problem because it works when the attendant is used in the same VLAN as the Call Manager. If the AC user was not associated with the IP Phone it would not work on either VLAN. I did multiple tests with multiple phones on both VLANS and the result was the same; it works on the voice vlan but not on the data one.

I think a saw a similar posting and the issue happened to be related to QoS. The only thing is that the solution was not posted.

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.ee91c90

New Member

Re: Attendant Console - Call Control Fail in different VLAN

If that is the case, I suppose it is possible that the call control packets are being blocked while CTI packets are allowed through. The call control packets use TCP port 2748. Make sure that this port isn't blocked. If it reliably fails, then it almost surely is blocked, rather than just not prioritzed by QoS.

Re: Attendant Console - Call Control Fail in different VLAN

If the switch is a 3550 then your configuration looks strange. I use the one shown below and it works fine with Attendent Console.

interface FastEthernet0/1

switchport access vlan 22

switchport voice vlan 42

no ip address

spanning-tree portfast

127
Views
0
Helpful
4
Replies
CreatePlease login to create content