Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bronze

Auto disappearing content using Refresh header?

Hi,

We're pushing a CiscoIPPhoneExecute to a phone. The phone requests the page (CiscoIPPhoneText) in the execute request.

The requested page needs to allow the user to respond to a question. If the user doesn't answer to the question, the question should disappear.

Can we cause the page to disappear after a set amount of seconds? I've tried a Refresh with url 30; Init:Services, but this doesn't work.

Does anyone have an idear on how to make the page disappear after x seconds?

Regards,

Erik

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Auto disappearing content using Refresh header?

Does the phone make the refresh request after 30 seconds? I haven't tried such high values.. I'm usually operating with 1 - 5 seconds, and that works just fine for me.

5 REPLIES

Re: Auto disappearing content using Refresh header?

Does the phone make the refresh request after 30 seconds? I haven't tried such high values.. I'm usually operating with 1 - 5 seconds, and that works just fine for me.

Bronze

Re: Auto disappearing content using Refresh header?

Fixed it.

Header "Refresh" with value "30; url=Init:Services"

... does work as expected. I made am mistake I should better not disclose any further :)

Thanks,

Erik.

Re: Auto disappearing content using Refresh header?

Well.. we're all entitled to screw up every now and then ;)

New Member

Re: Auto disappearing content using Refresh header?

Erik,

Hi! I'm having the same issue but I'm sure I'm doing right. I mean, HTTP-REFRESH is working as expected with IP Communicator but not within the physical device: Cisco 7960G Firmware: 8.0(9.0).

The device responds with: "HOST NOT FOUND" and after more tries it finally stays with the prompt message: "HTTP ERROR[12]".

I'm also implementing a feature similar to yours: like a pop-up window.

Which device/firmware are you using?

Thanks in advance.

New Member

Re: Auto disappearing content using Refresh header?

Thanks a lot for this forum...

There are always alternate ways of doing things...

Within the HTTP-Refresh header, I don't use the URI "Init:Services" anymore. Instead, I use a normal URL (http://) that points to a page withe the following code:

Now it works, thanks!

123
Views
0
Helpful
5
Replies
CreatePlease to create content