Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

autoattendant configuration

I have configured my router with CME 3.3 and now I'm trying to configure an autoattendant, I have tried a lot of things but it doesn't work, this is my config:

!

version 12.4

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

resource policy

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip subnet-zero

!

!

ip cef

ip name-server 80.58.0.33

no ip dhcp use vrf connected

!

ip dhcp pool ITS

network 192.168.3.0 255.255.255.0

option 150 ip 192.168.3.1

default-router 192.168.3.1

!

!

!

!

!

voice service voip

sip

!

!

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 /2../ /964812530/

!

voice translation-rule 3

rule 1 /964812530/ /200/

!

!

voice translation-profile SIPout

translate calling 1

!

voice translation-profile incoming

translate called 3

!

!

voip-incoming translation-profile incoming

!

application

service autoatt flash:app-b-acd-aa-2.1.0.0.tcl

param operator 1000

param aa-pilot 1000

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.3.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Ethernet1/0

ip address 192.168.2.200 255.255.255.0

ip nat outside

ip virtual-reassembly

half-duplex

!

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.2.1

!

!

ip nat inside source list 1 interface Ethernet1/0 overload

!

access-list 1 permit 192.168.3.0 0.0.0.255

no cdp log mismatch duplex

!

!

!

control-plane

!

!

!

!

!

!

!

!

dial-peer voice 100 voip

translation-profile outgoing SIPout

destination-pattern 9........

session protocol sipv2

session target sip-server

codec g711ulaw

!

dial-peer voice 101 voip

translation-profile outgoing SIPout

destination-pattern 6........

session protocol sipv2

session target sip-server

codec g711ulaw

!

sip-ua

authentication username 964812530 password 106F3E385D46585C54557268

no remote-party-id

retry invite 4

retry response 3

retry bye 2

retry cancel 2

retry register 5

timers register 250

registrar ipv4:213.162.201.146 expires 60

sip-server ipv4:213.162.201.146

!

!

gatekeeper

shutdown

!

!

telephony-service

max-ephones 3

max-dn 3

ip source-address 192.168.3.1 port 2000

auto assign 1 to 3

user-locale ES

network-locale ES

create cnf-files version-stamp Jan 01 2002 00:00:00

max-conferences 4 gain -6

transfer-system full-consult

!

!

ephone-dn 1 dual-line

number 200 no-reg primary

!

!

ephone-dn 2 dual-line

number 201 no-reg primary

!

!

ephone-dn 3 dual-line

number 964812530

!

!

ephone 1

mac-address 0012.431E.BF3E

type 7902

button 1:1

!

!

!

ephone 2

mac-address 0013.60C3.CE02

type 7902

button 1:2

!

!

!

ephone 3

!

!

!

line con 0

line aux 0

line vty 0 4

password 3Dx25.8*

login

!

!

end

Please I need an example for doing the autoattendant or help

  • Other Collaboration Voice and Video Subjects
2 REPLIES
Green

Re: autoattendant configuration

Hi,

Check out this post.

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Phone%20Services%20for%20End%20Users&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddc25b1/1#selected_message

You need to configure a dial-peer which calls the application when it is matched, normally the incoming dial-peer, in my example Im using a POTS but if u dont have any POTS dial-peer and you are using purely VoIP you need to configure a VOIP dial-peer which act as the incoming and call the application from there, ie:

dial-peer voice 1001 voip

application aa

session protocol sipv2

incoming called-number 1000

dtmf-relay rtp-nte

codec g711ulaw

!

HTH

//G

New Member

Re: autoattendant configuration

OK thank you I have upgraded my config as you are saying, I have followed the steps you have said and the steps in the link and now this is my config:

!

version 12.4

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

resource policy

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip subnet-zero

!

!

ip cef

ip name-server 80.58.0.33

no ip dhcp use vrf connected

!

ip dhcp pool ITS

network 192.168.3.0 255.255.255.0

option 150 ip 192.168.3.1

default-router 192.168.3.1

!

!

!

!

!

voice service voip

sip

!

!

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 /2../ /964812530/

!

voice translation-rule 3

rule 1 /964812530/ /200/

!

!

voice translation-profile SIPout

translate calling 1

!

voice translation-profile incoming

translate called 3

!

!

voip-incoming translation-profile incoming

!

application

service autoatt flash:app-b-acd-aa-2.1.0.0.tcl

param operator 6001

paramspace english language en

paramspace english index 0

paramspace english location flash:

param aa-pilot 6060

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.3.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Ethernet1/0

ip address 192.168.2.200 255.255.255.0

ip nat outside

ip virtual-reassembly

half-duplex

!

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.2.1

!

!

ip nat inside source list 1 interface Ethernet1/0 overload

!

access-list 1 permit 192.168.3.0 0.0.0.255

no cdp log mismatch duplex

!

!

!

control-plane

!

!

!

!

!

!

!

!

dial-peer voice 100 voip

translation-profile outgoing SIPout

destination-pattern 9........

session protocol sipv2

session target sip-server

codec g711ulaw

!

dial-peer voice 101 voip

translation-profile outgoing SIPout

destination-pattern 6........

session protocol sipv2

session target sip-server

codec g711ulaw

!

dial-peer voice 1001 voip

service autoatt

session protocol sipv2

session target sip-server

incoming called-number 1000

dtmf-relay rtp-nte

codec g711ulaw

!

sip-ua

authentication username xxx password xxx

no remote-party-id

retry invite 4

retry response 3

retry bye 2

retry cancel 2

retry register 5

timers register 250

registrar ipv4:213.162.201.146 expires 60

sip-server ipv4:213.162.201.146

!

!

gatekeeper

shutdown

!

!

telephony-service

max-ephones 3

max-dn 4

ip source-address 192.168.3.1 port 2000

auto assign 1 to 3

user-locale ES

network-locale ES

create cnf-files version-stamp Jan 01 2002 00:00:00

max-conferences 4 gain -6

transfer-system full-consult

!

!

ephone-dn 1 dual-line

number 200 no-reg primary

!

!

ephone-dn 2 dual-line

number 201 no-reg primary

!

!

ephone-dn 3 dual-line

number 964812530

!

!

ephone-dn 4

number 1000

!

!

ephone 1

mac-address 0012.431E.BF3E

type 7902

button 1:1

!

!

!

ephone 2

mac-address 0013.60C3.CE02

type 7902

button 1:2

!

!

!

ephone 3

!

!

!

line con 0

line aux 0

line vty 0 4

password 3Dx25.8*

login

!

!

end

But autoatt it's not running, when I have put this commands I have had warnings:

Router(config-app-param)#param operator 6001

Warning: parameter operator has not been registered under autoatt namespace

Router(config-app-param)#param aa-pilot 6060

Warning: parameter aa-pilot has not been registered under autoatt namespace

Is necessary to create a new ephone-dn with number 1000? Why I have this warnings?

Please you help will be great.

Thanks in advanced.

176
Views
0
Helpful
2
Replies