Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

autoattendant configure in cme

I am trying to configure an autoattendant in cme 3.3.

My tcl script is called app-b-acd-aa-2.1.0.0.tcl

My config is attached.

But autoatt it's not running, when I have put these commands you can see below I have had warnings:

Router(config-app-param)#param operator 6001

Warning: parameter operator has not been registered under autoatt namespace

Router(config-app-param)#param aa-pilot 6060

Warning: parameter aa-pilot has not been registered under autoatt namespace

Is necessary to create a new ephone-dn with number 1000? Why I have this warnings?

Please you help will be great. I need information for continuing investigating why is not working

Thanks in advanced.

11 REPLIES
Green

Re: autoattendant configure in cme

Those are warnings, can be ignored.

Ok aa-pilot will be used as the called number for the incoming-dial peer that will be reciving the call.

For example:

Your telco delivers a 4 digit number for incoming calls, you main number is 1000.

So you configure the incoming called number command with 1000, and the param aa-pilot 1000

For Operator param operator, its the extension that will ring when people dial 0 if I remmeber correctly or doenst enter a number.

Dont dial from an IP Phone it wont work, dial from either the PSTN or you remote SIP network.

Community Member

Re: autoattendant configure in cme

I have done your recommendations.

My telco delivers me the number 964812530

so I have put it in incoming called number and aa-pilot.

In param operator I have put 200, that is the operator extension.

But the system continues without running correctly.

As you can see in the configuration I have translation rules for incoming calls, I have disabled it and it's the same.

How can I do debugs? Can you see my config file and tell me your oppinion?

Green

Re: autoattendant configure in cme

Ok please do a debug voice ccapi inout

debug ccsip all.

You Telco delivers the number 964812530 using which protocol?

I see that you configure: paramspace english location flash:

Please confirm that you have all the .au files there.

Community Member

Re: autoattendant configure in cme

My telco is a sip provider ( sip protocol ), so I have configured a sip account in the router with the username is 964812530 and pass xxxxxx

so the public number is 964812530

these are the files I have in the flash:

Router#sh flash:

System flash directory:

File Length Name/status

1 25886372 c2600-jsx-mz.124-1

2 1022976 cme-b-acd-2.1.0.0.tar

3 33949 app-b-acd-aa-2.1.0.0.tcl

4 83291 en_bacd_disconnect.au

5 37952 en_bacd_invalidoption.au

6 123446 en_bacd_options_menu.au

7 75650 en_bacd_allagentsbusy.au

8 63055 en_bacd_enter_dest.au

9 496521 en_bacd_music_on_hold.au

10 42978 en_bacd_welcome.au

[27866844 bytes used, 5687584 available, 33554428 total]

32768K bytes of processor board System flash (Read/Write)

When I try to call 964812530 from the PSTN (the number from I'm trying the calls is 667433712 ) this is the

debug voice ccapi inout :

Router#debug voice ccapi inout

voip ccapi inout debugging is on

Router#

*Mar 27 20:54:10.988: //17/xxxxxxxxxxxx/CCAPI/cc_api_caps_ind:

Call Entry Is Not Found

*Mar 27 20:54:10.992: //-1/9F6EA05E801C/CCAPI/cc_api_display_ie_subfields:

cc_api_call_setup_ind_common:

cisco-username=667433712

----- ccCallInfo IE subfields -----

cisco-ani=667433712

cisco-anitype=0

cisco-aniplan=0

cisco-anipi=0

cisco-anisi=0

dest=964812530

cisco-desttype=0

cisco-destplan=0

cisco-rdie=FFFFFFFF

cisco-rdn=

cisco-rdntype=0

cisco-rdnplan=0

cisco-rdnpi=0

cisco-rdnsi=0

cisco-redirectreason=-1

*Mar 27 20:54:10.992: //-1/9F6EA05E801C/CCAPI/cc_api_call_setup_ind_common:

Interface=0x84E54E24, Call Info(

Calling Number=667433712(TON=Unknown, NPI=Unknown, Screening=Not Screened, Pr

esentation=Allowed),

Called Number=964812530(TON=Unknown, NPI=Unknown),

Calling Translated=FALSE, Subsriber Type Str=Unknown, FinalDestinationFlag=TR

UE,

Incoming Dial-peer=1001, Progress Indication=NULL(0), Calling IE Present=TRUE

,

Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALS

E), Call Id=17

*Mar 27 20:54:10.996: //-1/9F6EA05E801C/CCAPI/ccCheckClipClir:

In: Calling Number=667433712(TON=Unknown, NPI=Unknown, Screening=Not Screened

, Presentation=Allowed)

*Mar 27 20:54:10.996: //-1/9F6EA05E801C/CCAPI/ccCheckClipClir:

Out: Calling Number=667433712(TON=Unknown, NPI=Unknown, Screening=Not Screene

d, Presentation=Allowed)

*Mar 27 20:54:10.996: //17/9F6EA05E801C/CCAPI/cc_api_call_setup_ind_common:

Set Up Event Sent;

Call Info(Calling Number=667433712(TON=Unknown, NPI=Unknown, Screening=Not Sc

reened, Presentation=Allowed),

Called Number=964812530(TON=Unknown, NPI=Unknown))

*Mar 27 20:54:11.000: //17/9F6EA05E801C/CCAPI/cc_process_call_setup_ind:

Event=0x85284678

*Mar 27 20:54:11.016: //17/9F6EA05E801C/CCAPI/ccCallSetContext:

Context=0x85BC79E4

*Mar 27 20:54:11.016: //17/9F6EA05E801C/CCAPI/cc_process_call_setup_ind:

>>>>CCAPI handed cid 17 with tag 1001 to app "_ManagedAppProcess_autoatt"

*Mar 27 20:54:11.024: //17/9F6EA05E801C/CCAPI/ccCallDisconnect:

Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect C

ause=0)

*Mar 27 20:54:11.024: //17/9F6EA05E801C/CCAPI/ccCallDisconnect:

Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)

*Mar 27 20:54:11.212: //17/9F6EA05E801C/CCAPI/cc_api_call_disconnect_done:

Disposition=0, Interface=0x84E54E24, Tag=0x0, Call Id=17,

Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)

*Mar 27 20:54:11.212: //17/9F6EA05E801C/CCAPI/cc_api_call_disconnect_done:

Call Disconnect Event Sent

The debug ccsip all is attached.

And the config is attached too.

and the .tcl script is attachef too

I hope we can find a solution.

thanks in advanced

Green

Re: autoattendant configure in cme

Hi

I would like to know if you were able to get this up and running?

If not let us know so we can help you with your config.

Community Member

Re: autoattendant configure in cme

sip configuration is running perfectly. But now I'm trying to configure an autoattendant but its impossible. It doesn't works.

I have read all cisco documents and I think everything is correct but it doesn?t run.

Could you check my config?

Green

Re: autoattendant configure in cme

Hi Sarenos,

Your config looks good.

One last question, when you configure your CCME, to recieve a direct call from your Telco to your IP Phone...without attempting to use the TCL Script. which codec is being used. Press i button during the active this may be a codec issue.

debug ccsip messages

debug ccsip events

ter mon

You will see something like:

*Jan 4 13:44:43.342: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

INVITE sip:5512041843@X.X.X.X:5060 SIP/2.0

Max-Forwards: 9

Session-Expires: 3600;Refresher=uac

Supported: timer

To: <5512041843>

From: <5557996297>;tag=738934c8-13c4-453baa94-54d1ad7a-793

Call-ID: 375077-3370523608-630180@protelmsw1.subnet32.net

CSeq: 1 INVITE

Via: SIP/2.0/UDP 200.76.111.52:5060;branch=e21091e183f180b783564613e29e8705

Contact: sip:5557996297@200.76.111.52:5060

Content-Type: application/sdp

Content-Length: 287

v=0

o=NexTone-MSW 1234 1161538915 IN IP4 200.76.111.53

s=sip call

c=IN IP4 200.76.111.53

t=0 0

m=audio 27074 RTP/AVP 18 4 8 17 96

a=rtpmap:18 G729/8000

a=rtpmap:4 G723/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:17 T38/8000

a=fmtp:96 0-15

a=rtpmap:96 telephone-event/8000

a=ptime:20

As you can see in the SDP message the first codec announced by my Telco in attributes field for Media is G729 and prompts are recorded in G711U.

Please confirm

Community Member

Re: autoattendant configure in cme

OK, I have tested it without using the tcl script and doing the call directly.

I have done a debug ccsip messages

and the result has been:

outer#debug ccsip messages

SIP Call messages tracing is enabled

Router#

*Mar 27 21:40:24.323: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

INVITE sip:964812530@192.168.2.200:5060 SIP/2.0

Via: SIP/2.0/UDP 213.162.201.146:5060

Via: SIP/2.0/UDP 213.162.201.147:5060;branch=z9hG4bK929b93e0392b0db1fd8ab881

Max-Forwards: 69

From: <667433712>;tag=929b93e039d4c092fd8ab883

To: <964812530>

Call-ID: 929b93e0396c4a90fd8ab880@213.162.201.147

CSeq: 1 INVITE

User-agent: SysMaster VoIP Gateway v1.2.0

Contact:

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, INFO, REFER, SUBSCRIBE

Content-Type: application/sdp

Content-Length: 426

Record-Route: <213.162.201.146:5060>

v=0

o=- 220891596850131 1 IN IP4 213.162.201.146

s=-

c=IN IP4 213.162.201.146

t=0 0

m=audio 17018 RTP/AVP 3 0 8 18 4 99 98 97 96 101

a=rtpmap:3 GSM/8000

a=rtpmap:0 PCMU/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=no

a=rtpmap:4 G723/8000

a=rtpmap:99 G726-16/8000

a=rtpmap:98 G726-24/8000

a=rtpmap:97 G726-32/8000

a=rtpmap:96 G726-40/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

that's true the fist codec is g729.

and the promts are in g711, so what I need to do?

Convert de promts to g729?, Create new promts in g729?

Which utility can I use for doing the conversion?

Attached is the complete debug ccsip messages

Green

Re: autoattendant configure in cme

Hola Santi

Mandame un correo a mi direcci?n para que te pueda enviar la utilidad.

gogasca arroba cisco punto com

Community Member

Re: autoattendant configure in cme

ya te he mandado un correo, espero que pueda solucionar mi problema, muchas gracias por la colaboraci?n.

Green

Re: autoattendant configure in cme

The error message you seeing is just a warning that although you have configured them, they will not take effect until the next reload of the box or application (call

application voice load

678
Views
14
Helpful
11
Replies
CreatePlease to create content