Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Avaya IP Office and IP Phones with a 2950 switch

I am using VLAN 1 default for all data and then VLAN 2 for voice. DHCP options for the Avaya phones are set properly but the only way I can get the phones to register on VLAN 2 is by using:

switchport mode access

switchport access vlan 2

on a phone port - but then I get the wrong IP range if I plug a PC into that port as its forcing VLAN 2 for data as well.

I need to have any port be available for data on VLAN 1 or voice on VLAN 2.

What am I missing?

This is an inherited config and I am not sure where to start.

I have tried something like:

interface FastEthernet0/1

description Port For PC or Phone

switchport access vlan 1

switchport mode access

switchport voice vlan 2

no cdp enable

spanning-tree portfast

to no avail.

thanks for any help/guidance.

-Ross

17 REPLIES

Re: Avaya IP Office and IP Phones with a 2950 switch

Ross,

Cisco phones obtain the voice VLAN info through CDP. CDP is a proprietary Cisco protocol and will not work with Avaya. Avaya phones require option 176 in the data and voice DHCP scopes. Take a look at the link below for more information.

http://www.avayausers.com/showthread.php?s=ef1c678e4bcd6972457a0f59e79f0f15&postid=3570

Hope this helps. If so, please rate the post.

Brandon

Bronze

Re: Avaya IP Office and IP Phones with a 2950 switch

Your config with voice vlan is fine, and avaya phones can interop with aux/voice vlans all night and day.

interface FastEthernet0/1

description Port For PC or Phone

switchport access vlan 1

switchport mode access

switchport voice vlan 2

no cdp enable

spanning-tree portfast

The native dhcp option 176 scope should look like this and don't forget to use an ip-helper :-)

DHCP - Data Scope Option 176

L2Q=1,L2QVLAN=2

The Avaya telephone boots up by default without trunk tagging .. therefore it performs a dhcp request on the native VLAN of the data port. It is provided an address and "looks" at Option 176. In this case it states L2Q=1, L2QVLAN=2.. which means that the telephone should use 802.1Q tagging and utilize VLAN 2 (voice VLAN). The telephone then surrenders the IP address from VLAN1 and reboots while tagging on VLAN 2. The DHCP server sees the request from VLAN 2 and issues an IP address from the pool dedicated for that scope. The telephone again looks at the Option 176 field for its registration location, port, and TFTP server (along with a bunch of optional stuff)

can't wait till cisco decides to bite the bullet and starts supporting 802.1AB LLDP on data switches...not everyone wants to run cisco ip phones... sorry..come on cisco

New Member

Re: Avaya IP Office and IP Phones with a 2950 switch

The weird thing is - if I force the port to VLAN 2 - DHCP works as advertised - so its somehow not getting that cue to get onto VLAN 2 on initial boot

Where else do I need the IP Helper command? Its on both switches and the router and the Avaya BootIP util does get the DHCP server address fine.

Thanks for the help - this has been fristrating because its a remote location and my troubleshooting and "trying things" windows are very small.

New Member

Re: Avaya IP Office and IP Phones with a 2950 switch

Ok - I have a feeling this is a routing issue.

I CAN ping from any 12.x device to 22.x though.

It really appears that the devices are getting the 176 option from the data scope - but then not able to get to the 22.x scope unless I force the port to VLAN 2 explicitly.

This is the router config - but it appears to be handing off all routing to the PIX firewall... and maybe losing the tagged packets in the process?

interface FastEthernet0/0

no ip address

speed auto

!

interface FastEthernet0/0.1

description Native Vlan

encapsulation dot1Q 1 native

ip address 192.168.12.1 255.255.255.0

ip helper-address 192.168.12.5

!

interface FastEthernet0/0.2

description Voice Vlan

encapsulation dot1Q 2

ip address 192.168.22.1 255.255.255.0

ip helper-address 192.168.12.5

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.12.11

What would the config look like if I wanted to route between the VLANs on the router - but then pass VPN and Internet data to the PIX? The VPN endpoint is 192.168.11.x

Re: Avaya IP Office and IP Phones with a 2950 switch

I don't see any need to configure

switchport voice vlan 2

on the switch. Just configure the interface as a 802.1q trunk, with the native vlan = to your data vlan # (in this case vlan 1). In any case, do not use switchport mode access. This disables 802.1q tagging and defeats data/voice vlan separation on the interface.

As Kleo said, the phone will come up in non-trunking mode, obtain voice vlan info from dhcp, bounce into 802.1q trunk mode, and use vlan 2.

Try something like:

vlan 2

name voice

state active

(ensures the switch knows about vlan 2 - you may not need this if other devices are active on vlan 2)

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 1

Let me know if this helps by rating the post.

Michael

New Member

Re: Avaya IP Office and IP Phones with a 2950 switch

if you read the original message you will see I have tried trunking the ports. also the syntax you use is CatOS i think - IOS 12.x doesnt recognize swtichport trunk encapsulation commands

To reiterate where I am:

DHCP is configured correctly.

If I force a port to VLAN 2 - everything works fine

If I trunk or use access mode - phone does not get Data scope info on VLAN 1 and never jumps to VLAN 2 to complete the boot

Re: Avaya IP Office and IP Phones with a 2950 switch

When I read the post, I see that you have "switchport mode access" configured which disables trunking.

New Member

Re: Avaya IP Office and IP Phones with a 2950 switch

Sorry - just getting a bit frustrated because I'm going in circles. All of my ports were set to swtich mode trunk originally and changing to access is the only way I have been able to get them to work.

Bronze

Re: Avaya IP Office and IP Phones with a 2950 switch

ok try this... manually hardset the avaya ip phone with vlan 2... reset "power cycle " phone...and when *10/100MB ethernet flashs (right after boot loader image screen) press * and then tab through prompts by pressing # till you get to VLAN ID. Enter 2 and press # to save to flash/reboot.

Re: Avaya IP Office and IP Phones with a 2950 switch

LOL! I'll bite...

One of the selling points Avaya has used in the past, at least on some presentations I've attended, was that there was no reliance on CDP in their architecture. Their devices could set on any 802.1q switch and operate fine. I liked that fact as it gave me some flexibility - Catalyst, Cajun, HP, Extreme, etc., I didn't much need to worry about the particular 1q switch the phone sat on.

So it seems with 802.1AB LLDP, Avaya is finally going to adopt a "CDPv2 like" architecture after all. So you'll need to buy switches that are 1AB compatible. Don't suppose those switches are Cajun, do you? Are you getting the idea that a lot of this is market positioning via "standards"?

Kleo, I love your integrity and the technical quality of your posts such as this one! Seriously, I do. You speak from the heart. And we could learn a lot from you. But, dude, please speak to speak to specific features and benefits of Avaya or whatever else. Lay off the holy war stuff else the conversation quality degenerates and doesn't help anyone. You know what I'm saying?

Warmest regards,

Michael

Bronze

Re: Avaya IP Office and IP Phones with a 2950 switch

not sure what you are saying?? I've asked my cisco rep for LLDP/802.1ab information...and all i get is lip service. My data network is 100% cisco with close to 10k avaya ip phones. Portions of my data network are getting a refresh this fall..and only HP, Extreme and Avaya phones (no cajun hahaha!!! that was funny) are delivering 802.1ab products for me to test. Just disappointed with cisco. sorry for venting.

For me LLDP not only means to simplify deployment of access devices,network equipment vendors have developed but also as a troubleshooting and firmware management tool for my non-ciso devices.

Also, i don't like using explicit dot1q trunking, requires a bit more work. Vlan pruning, etc..

Bronze

Re: Avaya IP Office and IP Phones with a 2950 switch

ok try this... manually hardset the avaya ip phone with vlan 2... reset "power cycle " phone...and when *10/100MB ethernet flashs (right after boot loader image screen) press * and then tab through prompts by pressing # till you get to VLAN ID. Enter 2 and press # to save to flash/reboot.

Also try totally deleting you dhcp scopes for those subnets and start/stop dhcp services..i've had dhcp flakyness in the past bite me a few times. especially with windows server.

Re: Avaya IP Office and IP Phones with a 2950 switch

Just pointing out that LLDP/802.1ab is like basically standardized, extensible, non-proprietary CDP.

If I misunderstood, I owe you the apology.

New Member

Re: Avaya IP Office and IP Phones with a 2950 switch

I just want to make a quick comment about the problem that you are having. Cisco has been real good at switching from the proprietary protocols that they've developped to a standardized one once it's been ratified.

Such as: ISL Trunking to 802.1q; POE to 802.1af; STP to 802.1D etc...

So I think once LLDP is ratified they'll support it.

In the mean time Avaya's solution to supporting a Voice and Data Vlan on the same swithport is an Administrative Nightmare; because every port that the phone needs to be plugged into needs to be a trunk port and can't be an access port.

This means that once you've unplugged that phone to the switch, and plug in a regular device such as a PC, you have to touch that switchport to do some configuration.

Cisco's CDP solution automatically knows whther a device that's plugged into the switch is a phone or an end device, and it behaves appropriately. Seperate layer 2, and 3 on a unified layer 1.

So, consider that if you have a large network with 100% Cisco. I don't think this is such a big issue on a small network.

Bronze

Re: Avaya IP Office and IP Phones with a 2950 switch

You better check your facts about about an avaya phone needing a trunk port....WRONG...this config seems to work fine on almost 10,000 avaya ip phones on my cisco data network..

interface FastEthernet0/10

–Description to IP phone and PC

–switchport mode access

–switchport access vlan 1

–switchport voice vlan 10

–no ip address

–spanning-tree portfast

–mls qos trust cos

and even if i had cisco phones you still have to configure the port above about the same(with a few minor changes)

oh yeah so much more work..put down the marketing slicks.......though i do agree with your first paragraph..peace.

New Member

Re: Avaya IP Office and IP Phones with a 2950 switch

I was just making a purely generic comment from a technical stand point. No marketing; I'm a terrible salesman.

Every situation is different so this config may work fine for you; in fact it is working fine.

But What if you had 50 VLANs; even three?

or

What if you wanted to connect a PC to the Phone and have it get an address from a diffeent subnet than the phone automatically.

Would it still work?

I don't think this would work on our network because we don't use the native vlan to carry data traffic.

I don't see how the switchport would know whether the device that's plugged into it is a phone or an end device, especially if that end device was plugged into the phone.

That's all I was saying.

Bronze

Re: Avaya IP Office and IP Phones with a 2950 switch

I was showing an example i don't per se use vlan 1 for my data traffic.

example.

interface FastEthernet0/10

–Description to IP phone and PC

–switchport mode access

–switchport access vlan 5

–switchport voice vlan 10

–no ip address

–spanning-tree portfast

–mls qos trust cos

Also yes to all your questions, and this should clarify it for you.

The Avaya telephone boots up by default without trunk tagging . therefore it performs a dhcp request on the data VLAN(5 or whatever) of the switch port. It is provided an address and "looks" at Option 176. In this case it states L2Q=1, L2QVLAN=10. which means that the telephone should use 802.1Q tagging and utilize VLAN 10 (voice VLAN). The telephone then surrenders the IP address from VLAN 5 and reboots while tagging on VLAN 10. The DHCP server sees the request from VLAN 10 and issues an IP address from the pool dedicated for that scope. The telephone again looks at the Option 176 field for its registration location, port, and TFTP server (along with a bunch of optional stuff).

The phone can also re-write all cos tags, which is similar to extend-cos command on switch port.Also, the phone can also do a dot1q tag for pc by placing PHY2VLAN=5 into option176 scope.

I have avaya ip phone working with VMPS, IP Snooping/DAI, port security, and may more cisco data network tools...no issues and my network is quite complex and varies from site to site.

yes the avaya system does reuqire an bit more planning, but once setup...just as easy to support and maintain as cisco phones. You still have to setup your voice vlans and do dhcp sson option on both systems....

hope this clarifies.

4641
Views
4
Helpful
17
Replies
CreatePlease to create content